don't be afraid of buying books Next
• | Table of Contents
• | Index

THE CASE FOR VIRTUAL BUSINESS PROCESSES: REDUCE COSTS, IMPROVE EFFICIENCIES, AND FOCUS ON YOUR CORE BUSINESS
By Martha Young, Michael Jude
Publisher | : Cisco Press
Pub Date | : March 02, 2004
ISBN | : 1-58720-087-2
Pages | : 240

Reduce costs, improve efficiencies, and focus on your core business

  • Leverage your technology infrastructure to save money and virtualize processes.

  • Discover the principles behind BPV and the ways in which they can benefit your business.

  • Benefit from incremental cost savings, maximizing your business' ROI.

  • Learn from real-world case studies that illustrate best practices.

  • Understand the solution-provider market, maximizing the impact of your investment.

The dot-com collapse generally discredited the idea of leveraging the Internet to build viable businesses. Many market pundits have decried the concept without examining the underlying dynamics associated with these companies' failures. The truth is, prior business models were built on a flawed business case, not bad technology. In fact, the dot-com bubble created a whole new class of automation that, when applied to conventional businesses, can dramatically improve time to market, competitive response, and customer interaction. This is not virtual business; this is business process virtualization (BPV), and enterprises that don't grasp and apply the principals of BPV will rapidly be rendered obsolete by those that do, being quickly outmaneuvered and displaced in the market.

BPV is the application of networked, intelligent IT infrastructure to enhance skilled personnel, processes, and assets, which enables companies to improve efficiencies, increase competitive advantage, heighten brand awareness, reduce costs, and improve bottom line revenues. Unlike business process automation, BPV focuses on new management approaches for personnel and technology, signaling a fundamental change in the way that we think about business and its objectives.

While reading The Case for Virtual Business Processes, you will understand why BPV is critical to the long-term viability of your business, while learning how to leverage your intelligent networked infrastructure using leading-edge products and technologies from Cisco Systems.

This volume is in the Network Business Series offered by Cisco Press. Books in this series provide IT executives, decision makers, and networking professionals with pertinent information on today's most important technologies and business strategies.


Prev don't be afraid of buying books Next
• | Table of Contents
• | Index

THE CASE FOR VIRTUAL BUSINESS PROCESSES: REDUCE COSTS, IMPROVE EFFICIENCIES, AND FOCUS ON YOUR CORE BUSINESS
By Martha Young, Michael Jude
Publisher | : Cisco Press
Pub Date | : March 02, 2004
ISBN | : 1-58720-087-2
Pages | : 240

Copyright
About the Authors
About the Technical Reviewers
Acknowledgments
Foreword
Introduction
 | Case Study Methodology
 | Chapter Layout
 | How to Use This Book
Chapter 1. The Role of Business Process Virtualization in Your Business
 | What Is Business Process Virtualization?
 | What Is Incrementalization?
 | What Is Technology's Impact on Business Models?
 | Technology and BPV
 | Summary
 | References
Chapter 2. History Lessons: Why Conventional Business Models No Longer Work
 | What Business Are You In? Why Firms Should Focus on Their Core Business and Not Make IT a Core Competency
 | Internet-Based Business Models
 | Why More Data Is Not the Answer
 | Summary
 | Case Study: vCustomer Corporation, Seattle, Washington (www.vcustomer.com)
 | References
Chapter 3. Capitalizing on Enabling Technologies
 | A Day in the Life of a Virtual Employee
 | Scott, You Were Right: The Network as a Computer
 | Summary
 | Case Study: Teletext, United Kingdom (www.teletext.com)
Chapter 4. Capitalizing on Enabling Applications
 | VoIP
 | Streaming Media
 | Follow-Me IP Addresses
 | Summary
 | Case Study: KnowledgeNet (www.knowledgenet.com)
Chapter 5. Capitalizing on a Virtual Presence
 | Telecommuting
 | VLANs
 | Webification and Portals
 | Summary
 | Case Study: ARUP Laboratories, Inc.
 | Endnote Reference
 | Endnotes
Chapter 6. Capitalizing on Outsourcing
 | Why You Don't Want to Manage 100 Percent of Your Infrastructure
 | Ways to Safeguard Your Business Infrastructure
 | How to Select an Outsourcer
 | Summary
 | Case Study: InfoWorld Media Group
Chapter 7. Internal Security Implications of Managing the BPV-Centric Company
 | The Importance of Internal Security
 | Safeguarding the Company's Intellectual Property
 | Quality of Service
 | Summary
 | Case Study: Motorola (www.motorola.com)
Chapter 8. Financial Implications of BPV on Conventional Businesses
 | Reduced Costs
 | The True Total Cost of Ownership
 | The ROI for a Virtualized Business
 | Knowledge of Customer Issues
 | Improved Decision Making
 | Competitive Advantages of a Virtualized Corporation
 | Summary
Appendix A. Survey Instrument
 | Survey Instrument Format
 | The BPV Survey Instrument
Appendix B. BPV Providers
Glossary
Index


Copyright

Copyright © 2004 Cisco Systems, Inc.

Cisco Press logo is a trademark of Cisco Systems, Inc.

Published by:
Cisco Press
800 East 96th Street
Indianapolis, IN 46240 USA

All rights reserved. No part of this book may be reproduced or transmitted in any form or by any means, electronic or mechanical, including photocopying, recording, or by any information storage and retrieval system, without written permission from the publisher, except for the inclusion of brief quotations in a review.

Printed in the United States of America 1 2 3 4 5 6 7 8 9 0

First Printing March 2004

Library of Congress Cataloging-in-Publication Number: 2003101610

Warning and Disclaimer

This book is designed to provide information about business process virtualization (BPV). Every effort has been made to make this book as complete and accurate as possible, but no warranty or fitness is implied.

The information is provided on an "as is" basis. The authors, Cisco Press, and Cisco Systems, Inc., shall have neither liability nor responsibility to any person or entity with respect to any loss or damages arising from the information contained in this book or from the use of the discs or programs that may accompany it.

The opinions expressed in this book belong to the authors and are not necessarily those of Cisco Systems, Inc.

Trademark Acknowledgments

All terms mentioned in this book that are known to be trademarks or service marks have been appropriately capitalized. Cisco Press or Cisco Systems, Inc., cannot attest to the accuracy of this information. Use of a term in this book should not be regarded as affecting the validity of any trademark or service mark.

Feedback Information

At Cisco Press, our goal is to create in-depth technical books of the highest quality and value. Each book is crafted with care and precision, undergoing rigorous development that involves the unique expertise of members of the professional technical community.

Reader feedback is a natural continuation of this process. If you have any comments about how we could improve the quality of this book, or otherwise alter it to better suit your needs, you can contact us through e-mail at feedback@ciscopress.com. Please be sure to include the book title and ISBN in your message.

We greatly appreciate your assistance.

Credits

Publisher John Wait

Editor-in-Chief John Kane

Executive Editor Jim Schachterle

Cisco Representative Anthony Wolfenden

Cisco Press Program Manager Sonia Torres Chavez

Manager, Marketing Communications, Cisco Systems Scott Miller

Cisco Marketing Program Manager Edie Quiroz

Production Manager Patrick Kanouse

Senior Development Editor Christopher Cleveland

Project Editor Marc Fowler

Copy Editor Gayle Johnson

Technical Editors Kevin R. MacRitchie, Dan Reed, Ben Wen

Team Coordinator Tammi Barnett

Book Designer Gina Rexrode

Cover Designer Louisa Adair

Compositor Interactive Composition Corporation

Indexer Tim Wright

Corporate Headquarters
Cisco Systems, Inc.
170 West Tasman Drive
San Jose, CA 95134-1706
USA
www.cisco.com
Tel: 408 526-4000
800 553-NETS (6387)
Fax: 408 526-4100

European Headquarters
Cisco Systems International BV
Haarlerbergpark
Haarlerbergweg 13-19
1101 CH Amsterdam
The Netherlands
www-europe.cisco.com
Tel: 31 0 20 357 1000
Fax: 31 0 20 357 1100

Americas Headquarters
Cisco Systems, Inc.
170 West Tasman Drive
San Jose, CA 95134-1706
USA
www.cisco.com
Tel: 408 526-7660
Fax: 408 527-0883

Asia Pacific Headquarters
Cisco Systems, Inc.
Capital Tower
168 Robinson Road
#22-01 to #29-01
Singapore 068912
www.cisco.com
Tel: +65 6317 7777
Fax: +65 6317 7799

Cisco Systems has more than 200 offices in the following countries and regions. Addresses, phone numbers, and fax numbers are listed on the Cisco.com Web site at www.cisco.com/go/offices.

Argentina • Australia • Austria • Belgium • Brazil • Bulgaria • Canada • Chile • China PRC • Colombia • Costa Rica • Croatia • Czech Republic Denmark • Dubai, UAE • Finland • France • Germany • Greece • Hong Kong SAR • Hungary • India • Indonesia • Ireland • Israel • Italy Japan • Korea • Luxembourg • Malaysia • Mexico • The Netherlands • New Zealand • Norway • Peru • Philippines • Poland • Portugal Puerto Rico • Romania • Russia • Saudi Arabia • Scotland • Singapore • Slovakia • Slovenia • South Africa • Spain • Sweden Switzerland • Taiwan • Thailand • Turkey • Ukraine • United Kingdom • United States • Venezuela • Vietnam • Zimbabwe

Copyright © 2003 Cisco Systems, Inc. All rights reserved. CCIP, CCSP, the Cisco Arrow logo, the Cisco Powered Network mark, the Cisco Systems Verified logo, Cisco Unity, Follow Me Browsing, FormShare, iQ Net Readiness Storecard, Networking Academy, and ScriptShare are trademarks of Cisco Systems, Inc.; Changing the Way We Work, Live, Play, and Learn, The Fastest Way to Increase Your Internet Quotient, and iQuick Study are service marks of Cisco Systems, Inc.; and Aironet, ASIST, BPX, Catalyst, CCDA, CCDP, CCIE, CCNA, CCNP, Cisco, the Cisco Certified Internetwork Expert logo, Cisco IOS, the Cisco IOS logo, Cisco Press, Cisco Systems, Cisco Systems Capital, the Cisco Systems logo, Empowering the Internet Generation, Enterprise/Solver, EtherChannel, EtherSwitch, Fast Step, GigaStack, Internet Quotient, IOS, IP/TV, iQ Expertise, the iQ logo, LightStream, MGX, MICA, the Networkers logo, Network Registrar Packet, PIX, Post-Routing, Pre-Routing, RateMUX, Registrar, SlideCast, SMARTnet, Strata View Plus, Stratm, SwitchProbe, TeleRouter, TransPath, and VCO are registered trademarks of Cisco Systems, Inc. and/or its affiliates in the U.S. and certain other countries.

All other trademarks mentioned in this document or Web site are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (0303R)

Printed in the USA

Dedications

I dedicate this book to my husband, David, and our children, Amber, Ryan, and Abigail. You are my eternal spring of support and encouragement in all that I pursue. I am especially grateful to David, who listened patiently to half-baked ideas at random moments, helping to bring clarity to my thoughts for this book. You are a wonderful friend and partner, and I am a lucky woman.

—Martha Young

I dedicate this book to my wife and best friend, Barbara, and to my daughter, Nova. You two are my inspiration and keep me straight. Thank you.

—Michael Jude


About the Authors

Martha L. Young is president and founder of Nova Amber, LLC, a virtualized business consulting organization based in Golden, Colorado. She has been actively involved in the research and analysis market for more than 15 years. Her areas of expertise include desktop management, directory-enabled policy-based management, virtual private networks, management service providers, and business process outsourcing. She writes and speaks on these topics at focused events. She holds a B.S. in international business from the University of Colorado, Denver. She lives in the foothills of Colorado with her husband and daughter.

Michael Jude, Ph.D., works at Sun Microsystems. With more than 20 years of experience in telecommunications, as well as extensive experience with management automation, he manages accounts with some of the leading management solution vendors. He has been published in Network World, where he wrote a weekly column on the service provider space for nearly a year, as well as Business Communications Review, Ad Astra, IEEE Spectrum, and Front Range Tech Biz. He has a Ph.D. in decision science from Walden University, where he wrote a dissertation titled "Hidden Impacts: The Effect of Regulation on the Creative Individual." Additionally, he has a Master of Engineering in engineering management from the University of Colorado and a Bachelor of Science in electrical engineering from the University of Colorado.


About the Technical Reviewers

Kevin R. MacRitchie is vice president of worldwide channel operations at Cisco Systems, Inc., the worldwide leader in networking for the Internet. In this role, he leads Cisco's efforts to help the Partner Community achieve new levels of success through technology leadership and leading-edge business practices for Cisco channel operations and channel systems engineers. During his tenure at Cisco, MacRitchie has played a pivotal part in evolving the role of system engineers. He has spearheaded the efforts within Cisco and its Partner Community to drive system engineering skill levels to an all-time high. Promoted to his current position in August 2000, MacRitchie has evolved the WW Channel Operations organization into a partner-focused team that brings Cisco's solutions to a diverse Partner Community worldwide to meet the needs of Cisco's broader customer base. MacRitchie, his wife, and two children live in Michigan on his horse and buffalo ranch.

Daniel R. Reed, corporate vice president and general manager of TeleTech, is responsible for establishing the self-service vision encompassing development, sales, and delivery of voice recognition, automated outbound, acquisition, and loyalty operations. Before joining TeleTech, Reed was chief operating officer of enhansiv, with responsibility for sales, professional services, and development of a Java-based, VoIP, multichannel interaction router and CRM solution offered from a hardened data center. He is founder of the Information Management Executive Council (IMEC), a technology think tank composed of senior IT executives spanning nearly every industry.

Ben Wen is Senior Director of Channel Sales at DataPower Technology an XML network infrastructure company in Massachusetts. Prior to that, Ben was an Associate Partner at Mobius Venture Capital. At Computer Associates, he oversaw the Advanced Visualization team in San Francisco. In 1995 he and three partners co-founded ThinkFish Productions, a 3D graphics technology company. Ben has a Bachelor of Science degree in Computer Science and Electrical Engineering from MIT.


Acknowledgments

We are indebted to Jim Schachterle and the Cisco Press team. Your guidance, support, suggestions, and work on this book have been a terrific experience from beginning to end.

A warm thank-you to key members of the incredible analyst relations staff at Cisco Systems: Susan Haag, Rachel Myers, and Katie Efstratis. Without your encouragement, support, and efforts, this book would not have been possible.

A special thank-you to Amy Poon of Cisco's analyst relations team. We appreciate all your efforts in working with Cisco's sales team, locating and lining up the case studies, and ensuring we had all the resources we needed to make this project a success.

To our technical editors, reviewers, and critics, thank you for keeping us focused, concise, and clear. Your support has made this a reader-friendly work, and we are indebted to you.

We are grateful to all the companies that participated in the case studies: vCustomer, Teletext, KnowledgeNet, ARUP Laboratories, InfoWorld, and Motorola. Your time spent in the initial interview, transcript review, and case study review is sincerely appreciated. Many of your companies' successes can be attributed to the dedication of the IT teams and their focus on meeting business objectives.

To all the other people who have had a role in making this book a reality: our friends, families, colleagues, and business associates. Your support, encouragement, and cheerleading have made the road of writing a joy to travel.

To Mike, my coauthor: You are one of the most intelligent people I have ever had the pleasure of working with. Your wit and wisdom have made many gray days sunny. You are the master of project planning and focus. Because of your work, we have been able to bring a startling, brilliant idea from germination to publication. Thank you for being my coauthor and friend.

To Martha, my coauthor: You are the most knowledgeable industry analyst in my experience. Your guidance and support through the process of writing this book have been instrumental in bringing the project to a successful conclusion. Your sacrifices and hard work ensured that this project would have a firm foundation on which to build. I am fortunate to be able to work with you.


Foreword

Business process virtualization (BPV): What is it? Many of us have our own perspective, but some of us might not. Current modern businesses can thrive on it and, at supersonic speed, can accelerate past their competition if they understand it and use it to its fullest potential. BPV is the process by which physical infrastructure, representing sunk costs, can be replaced with electronic infrastructure, representing a dynamic business environment. This book explores some technologies and their application that can radically change the cost structure, balance sheet, P&L, and business practices of firms of all sizes.

This book is a testimony to how BPV is possible and, most importantly, what is possible. The ideas presented provide a road map to success and outline the pitfalls of failure.

Was the dot-com bubble a blessing or a bust? No matter what your perspective, there are many lessons to be learned on the successes and failures of those who pioneered many philosophies and business plans. Some were successful, some had almost the right recipe, and others were missing some of the basic ingredients of business success.

In the industrial age and the age of automation, process on the manufacturing line was the key to success. It drove rapid growth of a nation and even more opportunities for financial success, jobs, and a chance to get financially ahead in the world. In the early age of computing, we used the complexity of systems to drive process. Many computing systems were not as intuitive or as easy to use as they are today.

In current times, systems deployment has been made relatively easy. Almost anyone can drop in a system, create a new tool, develop an application, or just create another website to consolidate the current information of numerous websites. A question arises out of this ease of entry—Does the effort create business benefit with real financial return, or is it simply another effort without regard to the top or bottom line?

This book does an excellent job of covering the processes of managing a business and the leverage gained from proper review and execution of a systems-and-process approach to return on investment. It also covers gaining a competitive advantage, proper situational analysis, and aligning initiatives to key goals. Gone are the days of IT spending being just a cost of doing business. Although many companies are still in this mode, it is the companies that leverage their investment in systems to create the networked virtual organization that break down company barriers. They no longer rely on bricks-and-mortar requirements and are best positioned for breakaway success in the new technology-driven business world. Now, even the smallest of companies can link suppliers to their manufacturing systems. This creates an entire seamless manufacturing environment in which products may be subassembled in a variety of locations and by multiple suppliers. However, operationally, it appears as a single seamless manufacturing process managed by an integrated set of systems designed to increase the productivity of the end-to-end process, reduce costs, and decrease time to market.

The sales process and access to corporate networked information are done in much the same way. An intelligent information network gives the traveling executive or salesperson, telecommuter, or remote employee access to the internal corporate infrastructure to make faster, better business decisions. For example, this can include access to customer product information, configuring and booking product orders while at the customer premises, and automatically updating a sales forecast. These intelligent, networked systems are designed to reduce the input and time needed to interact with systems and maximize the time spent with customers or managing the business. Networks designed to support this remote but robust interface include all aspects of VPNs and other security needs, to remote wired and wireless connectivity to provide maximum flexibility to the front end of the sales process.

These are just two of the many examples that are explored in this book. It's a 360-degree perspective on investments in planning, systems, network infrastructure support, clear goals on financial return, and a clear business plan. The examples of successes and failures of models that have been tried provide clarity to support the text in each chapter. They also pull together the overall message with real-world, measurable examples from which to learn.

If you never thought you could take your current systems and transform them into a capability to increase top-line growth and maximize the bottom line while increasing your competitive advantage, this is the book for you. Even if you have several initiatives in this area, the concepts and examples on globalizing your efforts will prove extremely beneficial.

There is no better time than now to make a difference! Read on so that you can lead the change necessary to make that difference a positive one through BPV.

Make it a great day!
Kevin R. MacRitchie
Vice President, Worldwide Channel Operations Cisco Systems, Inc.


Introduction

We developed the concept behind BPV and this book during months of lunchtime power walks and animated debate. At the time, the U.S. economy was spiraling down, the news across all market sectors was doom and gloom, and press release after press release was punctuated with announcements of massive layoffs. Surely there had to be a better way to handle belt-tightening, cost-cutting requirements without repeatedly having to look at reducing headcount.

We looked at existing business models and realized they were founded on old-school management theories. We picked apart a number of companies, examining their strengths and weaknesses. What we learned in these exercises was that management theory rooted in the Industrial Age could not be reasonably applied to businesses of the Information Age and Knowledge Era. What worked in the past does not necessarily work in the future. If this were true, businesses would still be using telex machines and telegraphs to conduct day-to-day operations.

Instead, businesses of all types have seen huge leaps in progress and efficiencies based on technology and technology evolution. Over the last century, the speed of business has increased substantially across all processes, from product design through product delivery, thanks to technology. Surely technology could be leveraged to continue enhancing process efficiencies, reducing costs, and allowing companies to retain employees, even during challenging economic times.

The macroeconomic thought process behind BPV theory is that by retaining employees, the overall economy would recover more quickly based on continued consumer spending. Not surprisingly, the unemployed reduce their spending only adding increased pressure to a restrictive economy. Businesses have to retain employees to abbreviate the downward economic spiral. The question we had to answer was, How can companies keep their employees and concurrently sustain profitability during economic turmoil?

By retaining employees, companies achieve positive gains on several fronts:

  • Improved employee morale and employee loyalty through job security

  • Improved customer service, leading to a stronger customer base

  • Rapid recovery of the overall economy because of continued consumer spending

We looked at the value of a wide variety of technologies, including wireless communications, collaboration tools, network management tools, broadband technology, converged networking, unified messaging, the rise and consolidation of the outsourced managed services industry, and the rise and stumble of application service providers. We saw an interesting trend: Success was not rooted in a specific technology implementation. Companies that were implementing technology of any sort in a laser-focused manner, with discrete timelines, budgets, and an emphasis on meeting business objectives, were reaping significant benefits from the technology. This was a big, giant, forehead-thumping gee whiz and wow revelation.

Every analyst firm focuses on the vendor side of the technology business. Sure, they talk with businesses and users, but the discussions are focused on supporting the vendors and where they need to go with product development and next-generation tools. The discussions are vendor-centric because vendors are the financial pockets of the analyst community.

This book is not about vendors. This book is about technologies and business and profits. To delve deeper into the minds of the business community and to understand how technology is being used and the impact it has on the business, a change needed to occur in the nature of the discussions. The emphasis needed to be on what companies were doing with technology and why.

This shift in focus in conversing with the user community is the foundation of this book. The findings were astonishing, amazing, and downright fascinating. We have shared these findings with you in the case studies at the end of each chapter. The cases cover mid- and enterprise-sized companies. Some of the firms in the case studies are multinationals, and others are regional players. Some firms use near-shore and offshore talent, and others use in-house expertise. The case studies emphasize the benefit a particular technology has provided to the company.

Here are some significant findings that span all the case studies:

  • Every company added IT talent and personnel, expanding the employment market.

  • Every company increased the technical skill set of existing IT personnel.

  • Every company focused on meeting business objectives as the key reason for implementing the technology.

  • Every company tested the technology first in a test bed, and then with a few customers, before a full production implementation.

  • Every company obtained a positive ROI (return on investment) for the project within a year.

  • Every company focused on TCO (total cost of ownership) over ROI when working through the decision process.

The result of this research into BPV substantiated our hypothesis going into this project: Businesses can leverage technology to improve cash flow, allowing them to retain employees even during times of economic turmoil.


Case Study Methodology

The case studies were a joy to execute. As business analysts, we thrive on new information and information that unequivocally, empirically substantiates or refutes our theories. To achieve our objectives for this book, we needed to interview companies leveraging technology and understand the driving factors behind the decision metrics. The process for case study execution was as follows:

1. Develop an outline for the case study presentation.

2. Develop the survey instrument (see Appendix A for more on the instrument).

3. Line up the case study.

4. Send the survey instrument to the interview subject 1 week before the teleconference.

5. Conduct the teleconference, tape recording the conversation.

6. Transcribe the teleconference.

7. Seek the interview subject's approval on the transcript.

8. Write up the case study.

9. Send the case study to the interview subject for publishing approval.

10. Place the case study in the appropriate chapter.

Cisco Systems, its analyst relations team, and specifically Amy Poon were instrumental in finding and lining up the case studies. Amy is a fantastic asset to Cisco, and her work in ensuring the successful execution of this book is appreciated more than words can express. Even though the case studies are Cisco Systems customers, the concepts behind the technologies and execution strategies are universal.


Chapter Layout

This book is aimed at the nontechnical businessperson. Our goal is to demonstrate how technology can enhance and improve a firm's bottom line. It is a business book with an eye toward the role of technology in the business.

Each chapter focuses on a specific technology. The text briefly explores a technology's history and the hows and whys of its implementation. Each chapter provides a foundation for understanding the technology. We also cover many misconceptions that have been set forth by the media, technology analysts, and vendors. We also discuss the reasons why a firm would consider implementing the technology. Each chapter wraps up with a case study that explores the decision metrics, anticipated and unanticipated barriers to implementation, and unanticipated benefits.


How to Use This Book

The book is not written to be read sequentially. Skip around; enjoy the chapters that interest you. Don't feel guilty if you never bother with a chapter or two. We won't be offended. Read the case studies and realize that their success is rooted in a tightly managed, focused implementation that emphasizes the support of a strategic business objective. Technology was implemented across each of the case studies for its benefits of reducing costs, improving efficiencies, and supporting the core business. The greatest success with BPV is obtained through manageable, measured, incremental steps.

We are interested in both your positive and negative feedback on this book. Tell us where we fell off our rockers. Tell us how you have been successful with a BPV initiative within your firm. We would appreciate receiving your e-mails, and we will respond to you when you reach out to us (info@novaamber.com).


Chapter 1. The Role of Business Process Virtualization in Your Business

Remember the halcyon days of the dot-com boom? They were the modern equivalent of the gold rush of 1849. Nothing seemed impossible, and absolutely everything generated money. Now, bumper stickers lament, "Just one more bubble, Lord!"

Just like the gold-rush days, the dot-bomb left its trail of broken dreams and ghost towns. Unlike the gold rush, though, the dot-bomb left behind a glittering new set of technologies and highways throughout the business world. In gold-rush terms, the dot-com/dot-bomb era is the equivalent of building an interstate highway system to the gold deposits, building vast new cities to process gold and handle commerce, and then just walking away from it all when the bust comes. However, a few hardy miners are left. This book outlines the research we have done to locate a few of these pioneers in the new age of technology-enabled business.

Like most technology-savvy managers today, you probably have read numerous books that promised to show you the way to unlimited success through the application of technology. This book is different. This book is not an advertisement for new and more-expensive professional services. It is a primer on how you can apply the tools that presently exist in your inventory in new ways to virtualize your business and increase profitability.

IBM coined the term virtualization to describe the process of outsourcing. Although outsourcing is a hot topic in current cash-strapped enterprises, this book does not discuss shipping internal work to external providers, whether on-shore, near-shore, or off-shore. The reference in this book is to the process by which physical infrastructure, representing sunk costs, can be replaced with electronic infrastructure, representing a dynamic business environment. This book also talks about a fundamentally new way of working with and managing employees, many of whom might not be employees in the traditional sense. This process is called business process virtualization (BPV). In this book you will explore through exposition and case studies the technologies and the application of those technologies that can radically change the cost structure, balance sheet, profit and loss, and business practices of firms of all sizes.

Many or most of these technologies probably exist within your company today. The focus of this book is on how you can leverage your existing information technology (IT) infrastructure to do new things and create practices aimed at improving your bottom line. You might lack time to develop a vision and rationale for taking the leap into the world of BPV. This book helps you develop the vision and provides, unequivocally, the rational for making the foray into BPV. Companies around the globe are cutting back on IT spending and personnel in an effort to improve their bottom line. We closely examine the logic behind these actions, and we demonstrate throughout this book that the problem lies in the reasons companies apply technology to business, not in the technology itself.

The business paradigm of the 20th century was one of centralized organizations using a management hierarchy. The majority of employees were located in a single facility, and management acted as command central. This was a good model for economies emerging from an agrarian economic base. It allowed for a relatively smooth transition from field work to desk work.

As conducting business has become more and more complex through supply chains, just-in-time deliveries, and electronic order processing, the technology we have applied to addressing the complexity has only exacerbated the situation. Why? Because the technology, designed on a distributed client/server architecture, has been applied to enable centralized management. Technology has been used to concentrate people and data rather than enabling the geographic distribution of critical corporate assets.

The dynamic of centralizing business assets, including personnel and intellectual property, is so ingrained in the business mind-set that questioning the legitimacy or business costs of the practice borders on heresy. Companies that routinely spend millions of dollars on legal counsel and that worry about enacting policies designed to protect critical intellectual property discount the fact that many of their key personnel spend up to four hours each day commuting. How acceptable is such a commute should a fatal accident wipe out all the intellectual property stored in the brain of a CEO, strategic planner, or key scientist?

The fact is, modern business runs on intellectual property, and intellectual property is created when people interact. The command-and-control business model, one developed in the context of the Industrial Revolution, with deep roots in the 20th century, nodded in the direction of centralized business when it sought to place people in close proximity within corporate walls. Block after block of looming skyscrapers creating glass, cement, and steel urban canyons are the ultimate expression of centralized business.

The old model is suffering from numerous age-related problems, not just an outdated notion of work management. It is becoming increasingly difficult to achieve proximity of desired brains. The best people might not be willing or able to devote four hours each day to getting to and from work. The best people might not even be within commuting distance of the office. When these people do come into work, modern technological endeavors in the form of skyscrapers and cubicle mazes ensure that they spend a significant chunk of their time each day attempting to locate the correct people or data that they need to complete their work.

Additionally, as specialization continues to drive areas of expertise, it is likely that a particular skill set might be vested in one individual or a small group of individuals—in Bangalore, India, perhaps. When such expertise is contentedly located outside an urban setting, the individual or individuals might not want to move away from their perceived paradise. The people possessing the critical skill set might not even want to work a 9-to-5 workday. However, tapping into that expertise might be the difference between a firm's survival and failure in the current hypercompetitive markets.

In his book The Structure of Scientific Revolutions, Thomas Kuhn noted that paradigms change when the old way of doing something fails to address evolving problems.[1] Joel Barker, in his Paradigm book and lectures, notes that people immersed in a particular paradigm rarely understand the need for a new paradigm, and in fact usually actively oppose the emergence of a new one.[2] Paradigm stagnation is the ailment that businesses of all sizes are facing today. Rather than adopting a new paradigm, businesses continue to pursue the actions and activities of an old paradigm that no longer supports the new dynamic business environment in a futile attempt to improve revenues and cut costs. Unfortunately, this includes the cutting of critical personnel, with their embedded intellectual property, when the market turns bearish. What, they should be asking, happens when the bulls return? The old paradigm has served its purpose, but as the markets evolve, becoming more global and real-time in nature, a new, more-robust model must evolve with it.

But what is the new paradigm? As noted earlier, this book identifies and defines the new business order of business process virtualization and illustrates through comprehensive case studies its numerous significant advantages over the old centralized command-and-control method of conducting business. In the process, this book demonstrates that because of new, widely implemented technologies, this paradigm shift does not have to be a flash cut, with all the social disruption that entails. Rather, the new paradigm can be incrementally integrated into the existing paradigm infrastructure.

Ultimately, BPV will supplant the centralized method of conducting business. The book provides plenty of case studies to examine businesses that have firmly set their path toward implementing the new paradigm, the benefits they have gleaned along the way, and how these benefits are driving additional migration to the new business model. The cases examined are Cisco-centric. The intent of the case studies is to show that business process virtualization can be applied to any size company within any industry.

BPV formalizes a notion that has been around for a while: constant change. BPV should consistently reflect the change a business goes through to obtain and retain a competitive advantage. BPV is focused on business changes enabled through the focused application of technology. Although change-focused enterprises have always existed, even some whose focus was on technology-enabled change processes, BPV is driven by a whole new dynamic. BPV emphasizes that change can be made less painful and made to happen more swiftly, with fewer personnel impacts, than traditional business management approaches. But what is BPV, specifically?


What Is Business Process Virtualization?

Figure 1-1 illustrates the concept of business process virtualization and the ease with which it can be implemented incrementally.

Figure 1-1. BPV Includes Many Different Technologies and Considerations
[View full size image]

BPV is the application of intelligent network-enabled automation to leverage what you already have—people and their intellectual productivity, capital, and infrastructure/real estate—to achieve quantum improvements in productivity, profitability, and competitiveness. BPV, like any good paradigm, has existed for a long time. It began when the first clerk exchanged quill pens and vellum for a typewriter and fax machine, allowing him to work outside a centralized environment. In its modern incarnation, BPV can be traced to the general deployment of the PC and the Internet.

BPV is not just about technology. It is derived from the application of a new approach to management, a new focus by IT professionals, a new focus by corporate oversight, and enlightened involvement by many of the traditionally passive (or disruptive) business support activities.

BPV is not about telecommuting or teleprocessing or any other kind of "tele"-hyphenated construction. Although telepresence is one aspect of BPV, it is not the whole story. BPV is the application of technology in the context of a single individual, a team, a department, or a company to improve efficiency. BPV encompasses the technology of yesterday, today, and increasingly tomorrow to render the bricks-and-mortar in the traditional business irrelevant.

Of course, similar claims have been made repeatedly for each advance in the area of business automation. However, what distinguishes this shift from others is that, for the first time, technologists are not independently driving the paradigm shift. The free-market economy and competitive forces are driving business process virtualization. Reality has insinuated itself into the technology cycle with profound results. Many companies, some of which are reviewed in this book's case studies, are beginning to get it and are reaping the rewards of doing so. To see why these companies' successes represent a sea change, it is only necessary to see why technology, left to its own devices, is not the answer.

The Role of Technology

Technology by itself is a loser's game. That is, it is a loser's game when played for its own sake. For many years companies treated technology, especially business technology, as though it were a subsidized game for technicians. Before the dot-com bubble burst, companies were buying the latest bleeding-edge technology with few, if any, serious questions about what value the technology would bring to the company. It is unfortunate that the lesson many took away from the dot-com collapse was the lack of virtue in networked technology. The technology was not to blame for the dot-com failures or the collapse of the telecommunications market. The lack of a good business case for technology acquisition and implementation was at the root of these failures. It is ironic that the technology merely accelerated and magnified the poor business dynamic.

BPV depends on technology. The application of powerful computer platforms, combined with enabling software and high-capacity networks, provides the fabric with which to weave virtual business infrastructure. Rather than constructing buildings, BPV allows for the construction of global virtual structures, with very compelling financial implications. For example, only a few years ago, most call centers were housed in large, centralized cubicle farms. Now many contact centers are staffed by home workers who might not even know what their boss looks like.

Generally accepted accounting principles state that a building's depreciation period is 50 years. That of a desktop computer is 3 years. In that depreciation window, the business uses the investment as a tax write-off, but no one questions the business value of the real estate investment against other investment opportunities in the first place. All companies have only three assets from which to grow their business: land, labor, and capital. What if a company never made the real estate investment in the first place? Instead, what if the investment the firm made was in increasing its reach? Also, what if the incremental investment the firm made in technology (technology always costs less than its equivalent in fixed infrastructure) had an accelerated write-off period so that the firm could quickly replace it and continue to improve efficiencies? Put another way, which would a business rather do—invest in sales or invest in buildings?

The technology of networked automation lets companies of all sizes place in close proximity (in a virtual sense) the people, information, and intellectual property on which the business's future depends. The result is intellectual property created at accelerated rates. And, if the corporate capital resource is not going into maintaining sunk land assets, the capital can be used to acquire or support more labor, increasing the likelihood of good ideas.

The point is that any business process that depends on fixed assets can be improved, accelerated, and virtualized through the application of IT. Contact centers and manufacturing processes are two functions requiring fixed assets that lend themselves nicely to virtualization. The economics of cost containment is the hook that entices businesses to virtualize a function. However, the ongoing competitive advantages are what encourage them to continue virtualizing additional processes and functions within a specific process.

The Role of Executive Management

Technology by itself can never achieve a virtual business process. For that, firms need executives who can manage in an entirely new way. What businesses need is a focus on process rather than people.

Since the development of scientific management theory by Frederick Winslow Taylor during the mid-1940s, management has been focused primarily on the management of people and the work they do.[3] Although this has evolved into multiple variations, such as empowered teams, the fundamental focus has been on how best to control people. This is even true of white-collar workers. How many mid-level managers keep in the back of their minds the notion that higher authorities are subtly monitoring their comings and goings? Books have even been written on the subject of being in the office during strategic periods of the day.

An emphasis on what people do loses sight of the fact that it is how people do their jobs that matters. Although the output of professionals does have meaning, output is controlled through contract. Improvements in process efficiency lead to increased productivity and subsequently lower costs. As economic conditions tighten, executives lose sight of this fact. The knee-jerk reaction is to turn the screws on already overtaxed workers, resulting in reduced morale and output.

BPV requires a different focus entirely—a focus on process improvement through the use of networked technology. Of course, if BPV enables such work approaches as telecommuting and collaboration at a distance, the manager cannot see what the workers are doing. At some level, the output becomes the focus, regardless of how much actual work goes into producing it. Managers in a BPV environment have to resort to a project management focus, the output, to ensure that the mission is accomplished.

It is not just the focus of management with respect to worker management that must change. Executive management must adopt a new perspective on the decision-making process. As the dot-com bomb illustrated, the days of empowering managers to make decisions merely because you think they will make good ones is over. Decision theory has been loosely practiced for several decades. Its principles are well known and easily applied to the process of optimizing decisions. BPV includes the application of business intelligence, gleaned from a company's operations, to optimize business decisions. BPV, in conjunction with some simple rules for thinking about business decisions, can radically change a company's response to changing market conditions. BPV, as a result, has the potential to provide the enterprise with the nimbleness associated with small startups. BPV makes it possible to turn the Queen Elizabeth cruise liner in the same distance as a rowboat and, just as importantly, in the same amount of time.

The implications of BPV's effect on a business are profound, for both managers and employees. Although the manager needs to make some serious adjustments to the way in which work is accomplished, the biggest adjustment is required from the workers. Employees need to become self-managed and, to a certain extent, self-sufficient. Managers cannot be baby-sitters in a BPV-enabled workplace—nor should workers expect them to be.

The Role of Information Technology Implementers

It is not just management and employees who need to make adjustments. IT professionals need to divest themselves of the expense/overhead mind-set and accept the role of primary business enabler. IT should be a powerful voice at the level of corporate governance. If this is not as a CXO, this person nevertheless should have easy access to those who make the fundamental business decisions.

Since the dawn of the Information Age, IT has adopted and maintained the role of "keepers of the holy of holies." The old idea of lab-coated acolytes prostrate at the altar of the mainframe computer was not far off the mark. A certain mysticism has always been associated with IT. As a consequence, the emphasis has been less on increasing revenues and more on just "keeping the damn thing running." (Some people take exception to the notion that business has evolved past the Information Age. In fact, business has just emerged from the Data Age and is making its first tentative steps into the Information Age—but more on this later.)

IT can no longer afford such an approach. In the first place, useless baggage in the form of excess staffing and islands of technology, no matter how much it glitters, can no longer be tolerated as companies struggle to survive. In the second place, IT might be the only hope for struggling businesses attempting to maneuver in markets characterized by hypercompetition and ruthless cost-cutting.

IT is the mechanism by which BPV is accomplished. Although the networked technology that is the basis of BPV is becoming more intelligent and easier to implement all the time, maximum advantage can be achieved only when this technology is applied in the most advantageous way. This takes solid technology planning. This takes IT.

However, it takes a different kind of IT. It takes IT that is focused on strategic planning, not operations. Operations is becoming a high-cost overhead that businesses are increasingly loathe to support. In a competitive market that is driven by a price-to-cost dynamic, the highest-cost competitor always loses. This dynamic includes internal enterprise IT organizations.

IT must focus on the highest-yielding short- and long-term activities. High-yielding activities require firms to evaluate the company's business processes and find ways to apply technology to build virtual business processes. This is something that is hard to outsource effectively. When it is outsourced, it always costs more than if you had an internal team, properly empowered, perform the strategic planning functions.

The Role of the Board of Directors

Corporate governance is under extreme scrutiny. The debate over whether proper fiduciary responsibility would have stopped so many large companies from imploding is not the issue. As companies move into the age of virtualized business, the focus is not on whether the activities of the past were dysfunctional, but on what the appropriate role for boards of directors should be in the emerging era.

A board of directors is fundamentally an oversight panel that is placed in the corporate hierarchy to look after the shareholders' interests. The intent is to provide a balance and, most importantly, a check on the CEO's power. In this role, the expectation is that there will be an acute interest in the firm's cost and revenue dynamics. As a result, it is reasonable to expect that corporations will seek to place technology-literate directors on their boards so that when the question of whether to invest in automation is debated, there are people on the board who are capable of exercising rational levels of control and oversight.

Boards of directors who are merely friends of the CEO or who are CEOs providing a reciprocal favor in exchange for similar considerations by their own boards will no longer do. This is especially true if the board must provide governance in a technical domain. When a company is highly virtualized, with complex automated business processes, governance can no longer be symbolic. It must be intelligent and acutely conversant with technology.

Other Roles

Management, IT, governance, and labor are not the only constituents in any organization. What about the traditional support functions? How will issues such as intellectual property management, liability, and the various labor laws be administered? The simple answer, as we will illustrate, is that mostly they will not be!

In other words, to the extent that such functions were dependent on centralized command-and-control activities in the past, in a virtualized business world such functions are relegated to and built into the processes by which work gets done.

It is important to understand what is meant by the term intellectual property (IP). In most businesses, IP is whatever the company has created but for which it has no immediate need. In large corporations, substantial legal staffs are kept busy trying to devise ever-more-complex rules to prevent the leakage of such IP into the business community. Of course, IP is valuable only if it is used, and it has an amazingly short shelf life. Rather than imposing the burden of rules and regulations, administered by several levels of management, and ultimately directed by very expensive lawyers, what if IP was cataloged automatically when it was created, and was used quickly and frequently, but was not managed otherwise? Can this model work? As we will demonstrate, the answer is a resounding "yes."

Legal staffs in such a setup would be redeployed to enable IP transfers and utilization rather than attempting to build walls around and within the company. Of course, the legal team would be a much smaller group within an organization.

What about the human resources (HR) functions? HR is basically an artifact of management's desire to control employees. Rarely is this group trained to identify a strong candidate for any role within a firm beyond entry-level positions. In most cases, HR is associated not with helping employees but with control and termination functions. In the current market, the HR function of fulfilling key roles within a firm has already moved to virtualization via executive recruiting firms.

When a business is totally virtualized, employees are essentially free agents working under contract. There's a nominal need for HR functions. Where this process does exist, it can easily be automated. Contractors can be set up with full access to the requisite systems, benefits, and support services (many of which are outsourced) automatically on project initiation. They can be unplugged just as easily when the project ends. HR, such as it is, can be an outsourced function and can be directed toward building services people want.

As noted previously, the focus of all this employee control isn't necessary. Employees, for the most part, aren't permanent staff members. They are self-managing free agents with skills to sell. To imply that these workers are essentially white collar is incorrect. White-collar work, with its implication of being part of a command-and-control structure, misses the point. Neither is it correct to infer that they must, then, be blue collar in their orientation, with an expectation of narrowly focused work, with no responsibility to think creatively. The new workforce fits a new dynamic: They are highly motivated, exceptionally creative, and self-directed. They take responsibility for their work and their support, but they might be part of a union.

BPV leads to profound changes in organizational dynamics. BPV mixes up the notions of what constitutes management and what constitutes an employee, and it calls for a different sort of economic model. The change is so profound that you might be tempted to conclude that making the jump to a virtualized company is a daunting, expensive, and time-consuming task. That would be an incorrect assumption.


What Is Incrementalization?

BPV is a process in itself. It is not a flash cut to a new business model. In fact, it can't be. Because the changes are so profound, BPV is achieved in increments. This is the good news of BPV. It can be achieved one step at a time, and each step can yield significant benefits. The benefits are not isolated, but are cumulative. The total is substantially greater than the sum of its parts.

One Process at a Time

Consider the typical enterprise, composed of dozens of departments and hundreds of workgroups. Each of these workgroups has defined multiple work processes. In many cases, these processes are part of company-wide business processes, but a large percentage of these work processes are particular to the group. These processes also are highly manual. They can range from the procedures for approval of work to the ways in which people collaborate and document what they do.

Each of these processes can be automated to varying degrees; in some cases they can be virtualized so that they become location-independent. Each of these conversions can be justified on the basis of an immediate timesaving benefit. Ultimately, the virtual process of one group or many groups can be stitched together to form virtual departments and, ultimately, virtual companies.

The point is that each individual process can be virtualized incrementally without waiting for some grand scheme to answer all the questions associated with virtualization at an enterprise level. However, this isn't the only way to think of incremental improvements.

Horizontal Incrementalization

Consider the business processes that cut across multiple departments. These are typically associated with service delivery, engineering, time management, and accountability. In these cases, BPV can be applied to such processes to accelerate the flow of information and to improve communication between groups. BPV can also be used to facilitate the inclusion of groups that might not ordinarily be included in a process because of geographical separation or other factors.

Horizontal incrementalization typically involves investments that are larger and systems that are more complex than those applied to individual group processes but that can be a logical adjunct to them. As noted, when sufficient numbers of workgroups are virtualized, it makes sense to tie them together with higher orders of BPV. If the groups work together in different departments, horizontal incrementalization yields excellent returns. This doesn't mean virtualizing the entire enterprise; rather, it means an incremental, stepped approach within target workgroups or departments where positive economics can be demonstrated.

Vertical Incrementalization

Vertical incrementalization, like horizontal incrementalization, merely extends BPV from the workgroup. However, whereas the focus of horizontal incrementalization is on the business process between groups at an equivalent level of responsibility, vertical incrementalization focuses on extending the virtual workspace up the reporting hierarchy within the same division.

Vertical incrementalization is the process of upscaling incrementalization as successes are achieved in specific work processes. For example, a workgroup could implement document management to rationalize the process of manipulating and using documents. Once stable, this could be augmented with desktop management to rationalize and improve the use of individual desktop environments. Ultimately, this could be extended to the development of a completely virtual work environment.

Vertical incrementalization is actually BPV's most powerful principle, because it is how an organization can ultimately achieve the highest degree of virtualization. As control becomes vested in automation rather than in interaction of management layers, the actual location of management and workgroups becomes less important. Ultimately, the process itself is the control structure, with management focused on process rather than people.


What Is Technology's Impact on Business Models?

The technology that was the enabler of the dot-com bubble is the most profound development in the business world in the last 100 years. In response to the needs of dot-com companies, networked computing technology achieved a quantum leap of improvement as well as implementation.

Why Alan Greenspan Was Only Partially Correct with "Irrational Exuberance"

Near the pinnacle of the dot-com era, Alan Greenspan made what was to become a famous speech at the Annual Dinner and Francis Boyer Lecture of the American Enterprise Institute for Public Policy Research in Washington, D.C., on December 5, 1996. He made headlines with his comment that the stock market's exponential increase was because of "irrational exuberance." From a current perspective, it is easy to say that he was correct. However, this is only partially true, and Mr. Greenspan was only partially correct.

As to whether the market valuation was based on uninformed enthusiasm on the part of investors, we can hardly debate this notion. If any proof were required, it would be the depressed state of affairs that followed the dot-com bust, where even highly rated companies having significant current and projected cash flow were trading just above junk bond status. If investors were uninformed on the upturn, it is clear that they are grossly uninformed on the downturn. Mr. Greenspan was correct about the psychological basis for market overvaluation. However, he was incorrect in his implication that the impetus for that psychology was unwarranted.

Network technology, from the Internet to advanced telecommunications capabilities such as unified messaging and video teleconferencing, was perfected during the dot-com bubble. Network technology was perfected to the point where it is widely available today to apply to conventional businesses of all sizes and markets. However, where many of the dot-coms were built on poor business models, with few to no customers, conventional business has an established customer base, revenues, and existing competition. Applied intelligently, network technology can reduce the cost structure and improve the speed of operation of these conventional businesses. Where Mr. Greenspan saw only irrational exuberance and poor business models, we see the enabling technologies for the next big expansion, and complete transformation, of the American economy.


Technology and BPV

The point of technology within any company is to improve the way in which business is done so that productivity and revenue can increase, costs can decrease, and the quality of working people's lives can be improved. In that sense, this book shows you how BPV technology can work for you in your business and within your workgroup.

This is a wake-up call to all businesses. Profound things are happening; the paradigm for business has shifted. Those who recognize the signs and adopt the new paradigm early will have significant opportunities and competitive advantages. Those who wait might have no business future at all. BPV has the potential to accelerate business so extensively that enterprises adopting it will become much more agile and nimble. By the time nonenabled companies recognize the threat, the BPV-enabled firms will be in a market-dominating position.

This book is also a primer on how to make good decisions. Through each of the case studies, we will step you through BPV's rationale, technology, and real-life applications. In the process, you will be asked to think carefully about how technology is applied in your company. Each chapter concludes with a case study on the application of specific Cisco solutions to real-world business problems. Each case is framed in terms of BPV principles and is organized around a structured decision process, as shown in Figure 1-2. The case studies and analysis will give you the appropriate tools to replicate a similar decision process within the context of your own business environment.

Figure 1-2. Structured Decision Model

The fundamental concept behind BPV is economic. Change when initiated only for the sake of change (Tom Peters notwithstanding) is rarely successful in improving the business. Only when a change has proven to drive cost reduction, improve efficiencies, or increase revenue will it last and enable additional changes. BPV, then, demands measurable improvement in the company's finances as it is applied. Caution is the key word; however, getting on with it is the key dynamic.

BPV is here today and is being implemented in a variety of arenas. Improved processes are the reason to apply technology in the first place, and BPV is the framework within which enterprises can rationalize their ongoing technological deployments. BPV does not demand radical thinking from decision makers, but it does ask that they think about the impact of networked technology as they make their plans and evaluate investments.

The path to enlightenment starts with a lesson. The next chapter explores why the conventional business model is no longer valid and how the dot-bomb made this clear.


Summary

  • The dynamic of centralizing business assets, including personnel and intellectual property, is so ingrained in the business mind-set that questioning the practice's legitimacy or business costs would border on heresy.

  • The fact is, modern business runs on intellectual property, and intellectual property is created when people interact.

  • Paradigm stagnation is the ailment that businesses of all sizes face today.

  • Business process virtualization (BPV) is the application of intelligent network-enabled automation to leverage what you already have—people, capital, and intellectual property—to achieve quantum improvements in productivity, profitability, and competitiveness.

  • The free-market economy and competitive forces are driving BPV.

  • Technology by itself is a loser's game.

  • The application of powerful computer platforms, combined with enabling software and high-capacity networks, provides the fabric with which to weave virtual business infrastructure.

  • An emphasis on what people do loses sight of the fact that it is how people do their jobs that matters.

  • BPV includes the application of business intelligence, gleaned from the company's operations, to optimize business decisions.

  • Information technology (IT) professionals need to divest themselves of the expense/overhead mind-set and accept the role of primary business enabler.

  • As companies move into the age of virtualized business, the focus should not be on whether the activities of the past were dysfunctional, but rather on what the appropriate role for boards of directors should be in the emerging era.

  • In the current market, the HR function of fulfilling key roles within a firm has started moving toward virtualization via executive recruiting firms.

  • Employees, for the most part, won't be permanent staff members. They will be self-managing free agents with skills to sell.

  • BPV can be achieved one step at a time, and each step can yield significant benefits.

  • Where Alan Greenspan saw only irrational exuberance and poor business models, we see the enabling technologies for the next big expansion, and complete transformation, of the American economy.

  • The point of technology within any company is to improve the way in which business is done so that productivity and revenue can increase, costs can decrease, and the quality of working people's lives can be improved.


References

  1. Kuhn, Thomas. 1962. The Structure of Scientific Revolutions. Chicago, Ill.: University of Chicago Press.

  2. Barker, Joel. 1989. Discovering the Future: The Business of Paradigms. St. Paul, Minn.: ILI Press.

  3. Taylor, Frederick Winslow. 1967. The Principles of Scientific Management. New York: Norton.


Chapter 2. History Lessons: Why Conventional Business Models No Longer Work

Philosopher George Santayana is best known for the quote "Those who cannot remember the past are condemned to repeat it." Presently, business is repeating its approach to achieving profitability through aggressive headcount reductions in the hopes that the results will somehow be different than they were before the dot-com bubble. For the most part, this return to yesteryear is a knee-jerk reaction to the collapse of the dot-com market. However, to truly evolve, it is important to understand the lessons history has to teach us. According to Santayana, "History is always written wrong, and so always needs to be rewritten."

This chapter delves into business history and points out the lessons to be learned by

  • Examining the process that promoted the rise of a new technological infrastructure.

  • Showing how that infrastructure was used, initially, in a way that virtually guaranteed failure.

  • Discussing how the current return to basic practices that is taking place is a reactionary attempt to pretend that the Dot-com Era never took place.

  • Discussing the implications of the technology already loose in the market, how technology has made business decisions complex, and why more data is not the answer.

  • Introducing a structured decision modeling approach to convert data into actionable information.

  • Concluding with a case study that illustrates the application of data to decisions using Cisco Systems' call center technology.

The business environment runs in cycles. Presently, we are on the downside of a boom/bust cycle. Down cycles tend to get labeled, and this particular one has been labeled the dot-com bomb, or just the dot-bomb. During the height of the dot-com bubble, in early 2000, nearly 131 million new PCs were sold.[1] In those halcyon days, technology was king. Technology was going to completely change the way we did business, from "bricks-and-mortar" to a more enlightened environment characterized by entrepreneurial types sitting by the pool typing on a wireless laptop. Volumes were written on the subject, generally concluding that business would become a wholly virtual pursuit in which all the really hard work would be done by automation accessed by and manipulated through the web.

Of course, this hasn't happened yet, and to a large extent it is because the dot-bomb brought the easy-money days of online entrepreneurship to an abrupt end. As the Dot-com Era came to an end, questions naturally arose as to what had caused the dot-bomb and, more importantly, what had been wrong with the dot-com bubble in the first place. At the highest level of reflection, the dot-com model for business was fundamentally flawed—a result of bad business planning and poor execution combined with undiscriminating investment.

The dot-bomb sharply illuminated several erroneous dynamics of the existing economy:

  • Business leaders assumed that extraordinary improvements in productivity and revenue growth were essentially activities of the past.

  • Information technology was a necessary evil of doing business.

  • Information technology produced nominal value by itself.

  • Information technology was a means of managing overhead.

The dot-com revolution served as a wake-up call to the business world. Here, for the first time, was a new vision for technology. It was the notion of the business as technology. Put another way, it was information technology in place of the bricks-and-mortar business. The implication was that, instead of people, buildings, and inventory, all you needed was an Internet presence via a web page parked on a server somewhere. Best of all, companies sprang up that would cheerfully provide the server and the web page. The gleam in executives' eyes came from thoughts of zero-overhead profit-generating shells. The market's motto should have been "Money for nothing!" The reason anyone could take this notion seriously was partly because of bad business skills but also because of bad technology skills: Executives were essentially ignorant when it came to leveraging the power of technology for their business.

The dot-com dynamic illustrated the extent to which the status quo was deeply entrenched in the business world. Executives could make sense of the new technology only in the context of that with which they were familiar. This generally was a model of business as a fixed infrastructure operation. Even though dot-com promised to change the dynamics of business, the only way most companies conceived of this change was as a wholesale replacement for existing operations, not as a complement to them. This explains the phenomenon in which bricks-and-mortar businesses that engaged in e-commerce activities launched dot-coms as operations that were completely separate from the existing conventional business.

The dot-bomb, when it finally occurred, reinforced for many executives the notion that technology was a cost center and could never really enable improvements in conventional businesses. As a consequence, since 2001 the professional press has been replete with stories about the need to focus on conventional business planning, as though there is an alternative to business planning that does not take into account technology. The fact that CIOs still have professional tenures measured in quarters at most companies shows the extent to which technology is still misunderstood and therefore grossly devalued.

The Dot-com Era was not about technology; it was about the application of technology. More accurately, it was about the application of technology to business processes that were already generating revenues. The problem that eventually triggered the dot-bomb was that no one recognized this during the dot-com market run. Investors and executives alike persisted in viewing the dot-com phenomenon as replacing one type of business with another. The new type of business was to be completely network-enabled. B2B (for business-to-business), B2C (for business-to-customer), and B2E (for business-to-everything) became the catch words. Each was to be so different from conventional business that fortunes could be made with no product, no market, and, most importantly, no customers. Unfortunately, the new business was assumed to run on a different set of financial rules.

When the raging money flow dried up, reality loomed large and ugly. Even though the technology that had been developed was capable of profoundly changing the very concept of business process execution, when the companies using it foundered, the technology was unceremoniously disassembled and spread to the four winds.

As the technology and the people who created it hit the market, the price of technology tanked. To a large extent, the implosion of the technology market is a consequence of oversupply more than it is a slowdown in consumption. After all, why buy a new router when one that is nearly as good is available for pennies on the dollar in the gray market?

As Figure 2-1 illustrates, with a few assumptions, it is fairly easy to predict when the technology market will turn around. Looking at the total consumption of IT technology for the year 2000, the tail end of the dot-com bubble, and assuming that 50 percent of that consumption was because of dot-com startups, it is possible to treat that data as a supply curve for the balance of the market. Plotting a rational consumption curve, incorporating an assumption of additional supply being introduced, it is reasonable to conclude that the consumption curve will cross the supply curve in 2004. Although other economy-affecting events such as interest rate fluctuations, wars, and unethical accounting practices coming to light can have an impact on this curve, it is still true that dynamics such as obsolescence drive continued consumption regardless of sociopolitical circumstances.

Figure 2-1. Supply and Demand for Information Technology

The technology did not cause the dot-bomb; it only accelerated it, just as it could have accelerated conventional business growth. The dot-com led to the dot-bomb not because the technology was not the right technology but because the application of the technology was wrong.

Many business leaders have inaccurately concluded that the dot-bomb has discredited the possibility of web-enabled business. These business leaders are also finding that their shareholders are again looking at financial fundamentals. Wisely, they are concluding that the key to good business is to cut costs as much as possible and stick to core competencies. Unfortunately, technology has been relegated to the category of necessary, but purely overhead.

Ironically, as a consequence of this return to the old perspective on technology, there has been a rising popularity in the application of financial analysis to technology investments. This has led to applications of metrics such as ROI (return on investment). The fact that a retrospective measurement would be distorted to evaluate prospective purchases indicates the desperation that decision makers are feeling. It also indicates the degree to which the old model for business is beginning to show signs of inadequacy within a new business era.

The conventional post-industrial business model had been showing signs of cracking when the dot-com model came along. Business leaders had recognized that the bricks-and-mortar approach had been yielding smaller and smaller improvements in productivity and profitability. The exhortations of people such as Tom Peters to embrace change and to "break it" even if it worked were desperation tactics designed to manipulate workers into higher states of productivity. The underlying notion was that only by managing labor could growth continue; technology was not being viewed as a corporate asset.

Bricks-and-mortar business, without the enabler of technology, is constrained. Constraints are imposed by capital, land, labor, and data. Each can limit the degree to which business can grow or respond to its environment.

Capital, tied up in long-term real estate as the bricks-and-mortar component of conventional business, ties down a business geographically. It necessitates the allocation of scarce resources and additional capital to support and maintain facilities. Although external artificialities such as depreciation laws provide incentives to invest in buildings and real estate, the overhead these expenditures introduce into business reduces the capital necessary to develop new services or deliver existing services more efficiently.

Labor—or, more appropriately, the application of labor—is the component of business that has traditionally been problematic from an executive's perspective. Although production is clearly impossible without labor, the overhead associated with labor can consume tremendous amounts of corporate time and effort. The acquisition, discharge, and care of employees is the sole reason for human resources (HR) departments. To complicate matters further, the people you need to hire might be located in areas where the company isn't and might not want to relocate.

Data is increasingly a problem for business. Collecting, storing, and using data has become a significant load on most businesses. The problem is that data is information-neutral. Data is intrinsically worthless unless some effort is made to interpret it. The interpretation of data is what creates actionable information. Even before the dot-com bubble, excessive data was threatening to choke business. Data is still a problem, and with the hypercompetitive market, the need to do something meaningful with it is even more immediate.

It was no wonder that the dot-com generated such irrational exuberance. In one fell swoop it was going to reduce the need for capital, land, and labor, and it was going to integrate the use of data into the business seamlessly. Unfortunately, this was not the case. Business is now attempting to go back to its roots, but in the interim, time has marched on, exacerbating the problems that existed before the dot-com occurred.

History teaches us that new technology generates an initial spike of optimism. This optimism typically dissipates after a short time, when early adopters find they are not as successful as they thought they would be. Most of the dot-com businesses fit this category. They believed that technology alone would drive the business's success. Armed with this erroneous assumption, they failed to focus on a value proposition that would sell. They assumed that being current in router configurations was sufficient to sell goldfish over the web. They never defined their core business.


What Business Are You In? Why Firms Should Focus on Their Core Business and Not Make IT a Core Competency

What is your core business? Unless you are building computer equipment, your answer should not be "IT." Information technology is an enabler; it is not an end unto itself. The fact that some people think it is ultimately leads to the conflict described in the first chapter: executive management viewing technology as a necessary evil that returns nothing.

The essential value of BPV is that it is based on the idea that if an activity is not a core competency, it is probably not something your business should be doing. The BPV value proposition can be stated as follows: If the value an activity returns to the business as a measurable cash flow is less than the cost to do it, it should be done by someone else for whom the costs are lower.

If you consider managing IT infrastructure a strategic function, consider how much, in terms of salary and benefits, highly qualified IT professionals demand in the market. Furthermore, consider that highly qualified IT professionals are not likely to stay that way unless you invest in their ongoing training. As soon as you get the IT team trained on the latest technology, who's to say they will stay with your firm? If training and maintenance of IT professionals is not part of your core business, the IT staffing function begins to look less like a strategic capability and more like a strategic liability.

What constitutes a core business function? We offer a simple test: If the function is one that generates (or has the potential to generate) revenue with a higher-than-industry margin, it is a core competency.

In this light, hardly anything a firm does is a core competency. We want to focus on the idea of IT as a non-core competency. Unless your business is IT, IT is not a business you want to spend a lot of time making a core capability. The reason is hidden costs.

IT is a function that tends to hide a lot of overhead. Although many vendors encourage users to think of IT in terms of direct costs such as software licenses, hardware purchases, and so forth, the fact is that IT's total cost of ownership also must include the cost to maintain the software, the cost to train people on its use, the cost of upgrades and modifications, and the cost of security. IT is an iceberg that shows only the top 20 percent of IT expenditures. The remaining 80 percent is what typically introduces a negative leverage on IT investments.

Information technology is also an area where there is a distinct cost of obsolescence. When hardware generations turn over every 18 months, and the next software release can leave your technicians in the dark, there is a constant push to stay current. This forced technology evolution can consume vast resources that are better applied to research and development (R&D) of the next product or service your company offers.

Of course, if the company elects to invest in R&D instead of keeping the IT environment current, costs are associated with that as well. As competitors field better technology, they develop new capabilities that can be used to deliver services faster.

The flip side of this argument is that the competitor who chooses IT over R&D ultimately is faced with decreasing investment capabilities. The issue is timing. You can never know exactly when an investment will yield a compelling advantage. If you're given the opportunity to keep up on technology or maximize product development investment, the choice is obvious. By focusing on doing what you do better than anyone else, and by having other best-in-class providers do all the other ancillary functions, you can achieve the path of maximum technology application and maximum investment in products and services.

Therefore, the answer to the question of how to structure business for the new paradigm is to achieve a laser focus on your core capabilities. Everything else is a distraction—or worse, a capital sinkhole. Taken to its logical extreme, most business processes should be outsourced.


Internet-Based Business Models

The Internet is probably the single-most profound development in business and societal evolution since the development of the written word. Since the Internet's development as a generally accessible communications and transaction expediting medium, it has, in a sense, virtualized society and created a new frontier in which almost all human activities can be conducted. This includes business and was the point of the dot-com bubble.

However, the dot-com bubble didn't turn out quite so well. As a pure business environment, the Internet is no more desirable a place to conduct business than a railroad car would have been in the early days of the railroads. However, as a business enabler, the Internet is great; as the totality of your business, it suffers from significant deficiencies. The dot-com marketplace uncovered most of them.

What the dot-com people failed to appreciate was that the Internet is virtual, but people are not. This fundamental disconnect led to the notion that you could sell dogs on the web. People who buy such things want to pick up the dog and see if it bites. They want to experience the product in a way that no virtual experience can match. The ability to experience the product is why sites such as Amazon.com are doing so well. A printed page looks pretty much the same in a book as it does on your screen. The tactile sensations are similar enough that people can get used to it. Dogs . . . never.

This is not to say that the Internet is a bad thing; it is actually the foundation of BPV. As an enabler of business, Internet technology provides several key advantages over the physical alternatives:

  • Proximity— The Internet, because it is a high-bandwidth communications medium, can simulate some of the same kinds of proximity that a physical interaction can provide. In some ways, the proximity is superior, because it can accommodate information transfer that two people in a room together could never achieve.

  • Immediacy— The Internet is a medium in which everyone is connected to everyone else (at least, those who have access).

  • Low overhead— As the dot-com phenomenon demonstrated, the Internet can provide many of the same attributes of a business environment that physical infrastructure can, but at a radically reduced cost.

  • Speed— The Internet, because it enables proximate, immediate, easily supported interactions, can facilitate transactions at the speed of a computer. This has important implications when you're thinking in terms of a virtualized business.

The combination of these capabilities means that an Internet-based business can be a fundamentally different creature from its purely physical counterpart. At the extreme, a business using the Internet as a virtual medium for enabling business can move orders of magnitude more quickly, place its people much more strategically, and evolve to exploit market niches exponentially faster than a business that still depends on a fixed infrastructure.

The dot-com players managed to ignore most of these advantages and instead focused on one: low overhead. An Internet-based business model, as envisioned by the dot-comers, was one that avoided all costs because it avoided all overhead. The pure dot-com business was to meld virtual warehouses, cranking out real products for real customers, using a minimum of employees. These nonexistent employees were to be replaced with automation: intelligent applications, running on intelligent servers, over an intelligent network.

The Internet is a transport medium. As a model for business, it is fundamentally flawed. It requires many of the same things a business on the side of a highway needs: a product people want, a means of enticing people to stop and shop, and employees who care enough to provide superb service. The dot-com crowd never factored in these basic business concepts. The net result is that a lot of capital was expended, with little revenue to show for it.


Why More Data Is Not the Answer

What was commonly assumed to be the Information Age was actually the Data Age. With the advent of practical computing systems, we had the opportunity to generate ever-greater quantities of data. You can never have all the data. By the time you think you have gotten it all, more has been generated.

Data-rich environments soon became data-clogged environments. Increasing amounts of overhead were devoted just to managing the data from creation through storage and ultimately to obsolescence and disposal. It is no accident that early IT personnel were considered data-processing professionals. Data was the focus—and, to a large extent, it continues to be the focus today.

Businesses can no longer afford to manage data. If the IT department is devoted to such tasks, it is not adding value to the business of the business. The paradox of too much data is that it creates a great deal of activity and returns very little value. Generating data is not the answer, and deploying technology that only generates data is not a solution.

The Paradox of Too Much Data: Poor Decisions

Having a lot of data is comforting. Having a stack of printouts purporting to provide every fact available makes the whole process of decision making seem very rational. If you can only find a way of factoring every data point into the decision, success is sure to follow. Of course, it doesn't work that way. Ultimately, you just make the decision you would have initially made and then look for data points to support it.

Now consider a decision process plugged into an infinite data source. Using the technology infrastructure enabled by the Internet can potentially generate a virtually limitless amount of data. If you are committed to waiting on this flow, you will wait forever to make a single decision. This is the paradox of improper technology use: Technology can generate lots of data, and an infinite amount of technology can generate an infinite amount of data. Only the right technology that can put the data into context can deliver actionable information.

The Paradox of Information Poverty and Data Overload

Companies that don't know the difference between data and information are constantly waiting for a perfect data set, as though that will enable perfect decision making. Information is data in context. Context comes from thoughtful evaluation.

Information is much more valuable than data precisely because someone has taken the time to put it into context. In the world of automated management solutions, this is called correlation. Correlation seeks to extract meaning from data points. As soon as this correlation has taken place, information emerges from noise.

In a practical sense, information is of high value because someone or something has expended energy to produce it. Data by itself is noise, and the process of extracting information is an application of signal processing. In his book An Introduction to Information Theory, John Pierce points out that any data-rich environment can be thought of as a noisy environment.[2] Generally, the noisier it is, the greater the amount of power that is required to extract a signal.

As a consequence of the power-to-signal ratio, another interesting principle applies to information extraction. The Heisenberg Uncertainty Principle states that the more energetic the observation process, the more likely that the observed system will be influenced by the observer. This seemingly esoteric theory applies perfectly to information extraction from data-rich environments, because at some point the amount of effort required to correlate data produces diminishing returns that are likely to be influenced by the correlation process.

Information, then, is an abstraction of data. It is a set of data points connected by relationships. The relationships carry the meaning and produce the value. BPV recognizes this fact and seeks to build technical infrastructures that are appropriately telemetered to produce data in context. BPV infrastructure, then, is an information-rich environment that enables quick decision-making. The test of appropriate BPV is technology that contributes to this dynamic. Technology for technology's sake is wasted effort.

The Role of Wall Street Analysts and Industry Analysts

Much of the data overload besetting today's companies is exacerbated by the analyst community. Financial and industry analysts muddy the information extraction process by preinterpreting many of the data streams.

As the Enron debacle clearly demonstrated, analysts might have their own agendas. It is fairly clear that the dot-com bubble occurred, in part, because of the hype generated by analysts. The dot-bomb occurred so precipitously, at least partially, for the same reason. When the market data is being manipulated by active filtering for personal gain, the decision maker must be especially careful. Unfortunately, many companies base their decisions almost exclusively on what analysts tell them, even to the extent of making long-term investment decisions to influence the analyst community.

The old business paradigm was, in a sense, responsible for the inflated expectations of the dot-com bubble. As the old paradigm began to crumble, technology was seen as a means to replace conventional business notions with a more modern Internet-based business, with a foundation built on data. The assumption was that this would make for a much more cost-effective, intelligent enterprise with no people to muck up things. The notion was flawed from the outset. The Internet is not about data; the Internet is only about transport.

We are back to business as usual, but with better technology. This technology can create vast amounts of data, and we are confused about how to use it to make good business decisions. It turns out that BPV has an answer: Apply structured decision approaches to convert data to information. At its heart, BPV is the application of rational decision making to the process of technology application. Using this approach to manage the data that an Internet-enabled business can generate is the first step in virtualizing a company.

Decision Modeling: A Way to Translate Data into Information

World War II drove many developments in management science. One of the most notable but overlooked accomplishments was the development of a new theory on gaming strategy. In 1944, in their seminal work on the subject, Theory of Games and Economic Behavior, Von Neumann and Mergenstern showed that it was possible to mathematically model complex game scenarios in a way that made possible the idea of maximizing a winning position.[3] Later, in 1952, this concept was expanded to include a wide class of non-game-oriented decisions.

Data in and of itself offers no clear advantage to business. Too much data or too little data can effectively paralyze a business. BPV, with its emphasis on integration and use of intelligence derived from the production process itself, promises to radically change business's response mechanism to the market. However, the process by which this intelligence is created is not strictly in the realm of automation. Just as BPV demands a different way of managing resources, it also demands a different way to approach decision making.

Although much of decision theory's reputation of impermeability has been earned (after all, mathematical modeling can be rather involved), most of the principles associated with decision modeling are straightforward and can be applied by anyone to improve the process of decision making. Decision modeling is a powerful way to convert data into actionable information. When the data is generated by business-aware automation, the result can be an unprecedented improvement in business management.

Decision modeling is as much a process as it is a method of data reduction.

Good decisions are made only when the people directly affected by a decision are involved in defining the decision to be made. This means that the reality being addressed by a decision must be a reality that everyone affected recognizes as such. Too often, decisions are made in a vacuum that ignores facts of which others might be aware. How many times have you heard "Whoever made this decision doesn't understand the situation!" This is a symptom of inappropriate involvement.

The hardest part of decision making is achieving consensus on what the decision really involves. Usually emotions run high, especially when the decision cuts across work groups. Everyone has been involved in a decision making scenario like that depicted in Figure 2-2.

Figure 2-2. Achieving Consensus

The power of obtaining consensus is that it illuminates and resolves differences in perceptions up front that usually surface to torpedo decisions after they have been made in the standard way. Although it is unusual for everyone to be reconciled to a particular decision definition, it is still true that everyone exits such focus sessions with a good idea of what decision is being made, where others stand with respect to how the decision will be made, who is likely to be affected, and who holds strong opinions on the decision's outcome.

The definition of the decision is a definition of the decision in terms of the principle influences on the decision and its impact on business processes. The typical way to look at such a definition is in terms of the variables that influence the decision. It is usually clear, as in the case of a purchase, that a decision is necessary. What is less clear is how other factors in the organization will affect that decision.

After the decision has been mapped, the process continues with validation and reduction. Validation simply recognizes the fact that assumptions made at the beginning of a decision process must be checked against available data. Additionally, validation encompasses sensitivity analysis, which seeks to gauge how important each variable is to the decision's outcome. It is usually the case that although a decision might depend on a myriad of variables, most of the influence is generated by just a few variables. Validation seeks to reduce the number of variables that must be considered.

After the validation is accomplished, reduction can take place. This is where the remaining variables are tested against the outcome and the optimum decision is determined.

The beauty of decision modeling is that preemption by management can also be taken into account. After the decision model has been built, it is possible to estimate the value of the decision and the weight of the contributing factors. If the decision maker overrides these, the decision can be evaluated after the fact, and the relative value of the decision maker's intuition can be measured. For companies that embrace this approach, that might be a scary thought.

A decision must be thought of as a result driven by variables, which in turn are data-driven. The decision process is most easily conceptualized in the form of influence diagrams, although decision trees are also a powerful way to represent decisions. A decision tree approach is much more useful when probabilities can be assigned to decision options. Influence diagrams, like the one shown in Figure 2-3, are expressed as a decision, with contributing variables connected by influence vectors.

Figure 2-3. Simple Decision Model

A simple yes/no decision can be represented as a decision block with two influencing variables. The direction of the arrows represents the direction of influence. The beauty of this simple diagram is that it shows a decision maker instantly what the decision is and what tends to affect that decision.

Assume for a moment that you are faced with the decision of whether to purchase a router. Clearly, your decision will be based on the router's cost. Additionally, you might think in terms of benefits derived from owning the router. As shown in Figure 2-4, the model now shows a decision, Buy a Router, influenced by two variables, Cost and Benefit.

Figure 2-4. Decision to Buy a Router

However, the router's total cost is more complex than just the sticker price. Costs might be associated with installation, maintenance and configuration, reliability, vendor viability, vendor and third party-enabled product support, and training. These influences must all be factored into the decision.

Likewise, the benefits associated with the router might involve things such as the ability to support additional revenue-producing employees, enhanced security, or improved service to existing employees. IT efficiency might be improved through such impacts as enhanced service levels, a reduction in capacity-related trouble tickets, or a reduced need for operational personnel to manage users. If these contributing costs and benefits are added to the simple model of Figure 2-4, you end up with the model shown in Figure 2-5. As you can see, this model is quite a bit more comprehensive.

Figure 2-5. Decision to Buy a Router with Second-Order Effects

As shown in Figure 2-6, the decision of the router purchase can be taken to extraordinary extremes. However, isn't this just a reflection of the situation described in the section "The Paradox of Information Poverty and Data Overload"? Fortunately, a good decision model provides tools to reduce the clutter and isolate the data that matters.

Figure 2-6. Decision to Buy a Router with a Full Analysis
[View full size image]

A decision model is not simply a bunch of variable labels connected by lines. It turns out that the lines are meaningful. These influences are actually transfer functions. They carry meaning in the sense that they express a mathematical relationship that ties the influenced variable to the influencing variables. In some cases, this is simple addition, as in the case of a cost that sums two other costs. In other cases it might be a complex formula that must be derived through curve fitting or historical trending. It is the process of deriving the relationships that provides the insight.

Decision models endeavor to express things in units that lend themselves to arithmetic analysis. It is possible to test the outcome's sensitivity to the variables that influence the outcome. This is known as sensitivity analysis, and it can be done through a variety of means, but mostly it all boils down to a version of Monte Carlo Analysis.

In Monte Carlo Analysis, all the variables are allowed to vary between expected maximum and minimum points. When you do this, you can view the outcome as a cluster of possible values. By noting the effect of allowing one variable to float between its maximum and minimum points, you can determine how much of the total variability of outcome is because of that one influence. By doing this, you can determine to which variable the outcome is most sensitive.

Ultimately, you can find the few variables that generate the most change. This subset of all the variables that could influence the outcome provides a filter for all the data that might be used in the decision. It also provides the relationships that turn the data into actionable intelligence. As shown in Figure 2-7, this sensitivity analysis can be displayed as a tornado diagram. In a tornado diagram, the outcome's sensitivity is expressed by the width of the bar: the greater the width, the more the influence. As you can see, the router purchase is most sensitive to revenue generation and price.

Figure 2-7. Tornado Diagram for a Router Purchase

It's important to understand that the sensitivities generated by this form of decision modeling can be quite different for different decision makers. They can depend on local conditions and perceptions. The idea behind decision modeling is not to generate the ideal decision in all cases, but merely the best decision for the given set of circumstances.

Although there are other tools and technologies for analyzing decisions, this example provides the basics of understanding the case studies presented in this book. In each case, we endeavor to provide the metrics or variables used by the case study subject to evaluate a particular decision. We also provide some insight into the efficacy of the process used.

Let's summarize the discussion to this point. The post-industrial model for business had yielded as many improvements in productivity and revenue growth as it could up to when the dot-com model offered the promise of quantum improvements in both. The reaction was an exuberance of investment and high expectations that created the dot-com bubble. Ultimately, when the dot-com failed to live up to its promises, there was a crash. This is the period through which we are now progressing. However, the Dot-com Era left us with technology that purported to bring order out of data overload, but in many cases it exacerbated the problem of information extraction and decision making. Ironically, the use of this technology in a structured, decision-making environment has the capability to achieve a radical improvement in both the appropriate use of data and the viability of business enabled with the technology.

The following case study shows how one company's problems led it to apply Cisco Systems' call center technology to help manage its call center process.


Summary

  • At the highest level of reflection, the dot-com model for business was fundamentally flawed—a result of bad business planning and poor execution combined with undiscriminating investment.

  • The dot-bomb sharply illuminated several erroneous dynamics of the existing economy.

  • Even though dot-com promised to change the dynamics of business, the only way most companies conceived of this change was as a wholesale replacement for existing operations, not as a complement to them.

  • The Dot-com Era was not about technology; it was about the application of technology.

  • The technology did not cause the dot-bomb; it only accelerated it, just as it could have accelerated conventional business growth.

  • Bricks-and-mortar business, without the enabler of technology, is constrained.

  • Information technology is an enabler; it is not an end unto itself.

  • The essential value of BPV is that it is based on the idea that if an activity is not a core competency, it is probably not something your business should be doing.

  • You structure business for the new paradigm by achieving a laser focus on your core capabilities.

  • As an enabler of business, Internet technology provides several key advantages over the physical alternatives.

  • Information is much more valuable than data because someone has taken the time to put it into context.

  • At its heart, BPV is the application of rational decision making to the process of technology application.

  • Decision modeling is a powerful way to convert data into actionable information.

  • The beauty of decision modeling is that preemption by management can also be taken into account.

  • Fortunately, a good decision model provides tools to reduce the clutter and isolate the data that matters.

  • Ultimately, it is possible to find the few variables that generate the most change.

  • The idea behind decision modeling is not to generate the ideal decision in all cases, but merely the best decision for the given set of circumstances.


Case Study: vCustomer Corporation, Seattle, Washington (www.vcustomer.com)

Personal interview conducted with Jeff Wasierski, vice president of technology

Virtualized business process: Offshore call center

Company Background

Company Overview

vCustomer, founded in 1999 in Seattle to provide medium- and enterprise-sized businesses in the technology and retail markets with offshore customer contact support, found itself struggling with the same dynamic this chapter has discussed. On the one hand, customer contact support is a business that is highly sensitive to the cost of labor. On the other, utilizing that labor introduces some real risk in the viability of the business. While the labor pool available is highly capable, the geographic location ensures that the impact of network overhead and failures can quickly degrade the quality of service to the point where such service is no longer competitive with domestically based solutions.

If vCustomer had used a conventional business model based on conventional technology, it would have found it very difficult to conduct business, let alone do so competitively. What was required was a radically new solution. vCustomer management had to think outside the box. To do so, it turned to Cisco.

vCustomer has been able to achieve a significant improvement in performance over its conventionally built rivals. With highly trained technical, customer care, and collections staffs, as well as a wholly redundant intelligent networked infrastructure, vCustomer ensures 100 percent uptime and availability. Utilizing robust call center technology, vCustomer endeavors to constantly improve its clients' satisfaction with the customer care business process. The particulars of its success are enumerated in the following sections.

Network Overview

The vCustomer network is an international network aimed at servicing clients in the United States, Canada, and the United Kingdom from three call centers based in New Delhi, India.

vCustomer uses co-location facilities in Seattle to support its India operations. The co-location facility is vCustomer's primary point of presence in the United States. It houses vCustomer's voice gateway equipment and provides vCustomer with typical co-location services, including rack space, power, security, and environmental monitoring and support. Links between Seattle and New Delhi are private, leased 2-MB E1 circuits. Only vCustomer traffic runs on these circuits.

As shown in Figure 2-8, three call centers in New Delhi support nearly 2000 seats. vCustomer is based on a packet-based infrastructure, leveraging voice over IP technology throughout the company, including the call centers. The intelligent infrastructure consists of Cisco Systems 7200 series routers and Catalyst 6500 switches at the network core. The routers support the wide-area network connectivity. In addition to other functions, the 6500 series switches perform the voice-to-packet conversion. The wiring closets are built out with Catalyst 3524 stackable switches with inline DC power. These switches connect to IP telephones. The IP telephones, supporting a two-port embedded switch, connect to the desktop PC.

Figure 2-8. vCustomer Network Diagram

The desktops are Intel-based, running Microsoft's Windows 2000 operating system. There is an emphasis on standardization within reason. Desktops are clustered into VLANS, leveraging the switch within the IP telephone, to support and segregate each vCustomer client's traffic. Within each VLAN the desktops have the exact same configuration, including software, browser, and security levels. Applications, customer greetings, and client requirements for data acquisition on customers are all based on client-defined parameters; herein is one of the key differentiators at the desktop level.

Security

Security is a strong selling point for vCustomer. To ensure security within the call center facilities, access to desktops, customer campaigns, and contracted programs is highly restricted.

One of the ways vCustomer ensures the highest levels of security is by placing contracted programs on individual subnets within the vCustomer network. For example, if there is an inbound customer for which vCustomer is providing technical support services, and it is a 100-seat program, that 100-seat program is placed on its own subnet entirely. This means that the workstations and the phones are all on a subnet that is unique to that particular program. Agents from another program who try to log in with their own ID are not going to be able to log in. Agents from one program are not able to log in or access applications developed for other programs and clients.

For additional security, call center agents are not permitted or enabled to access external websites; they can't Telnet anywhere that hasn't been opened for that particular client. vCustomer has designed isolated spheres of environments. Within a defined sphere, call center agents can interact with all the tools that they need in order to service that customer, to answer service calls, and to capture the information required by the client. The call center agents cannot send any information about the customer or the call outside of that sphere.

Management's Attitude Toward Technology for the Business

vCustomer's management team's views on technology revolve around their need to meet and exceed customer expectations for quality service. The team recognizes that technology is a cost center, but only in terms of working around a third-world telecommunications infrastructure. vCustomer's emphasis is on quality of service; to achieve that goal, it must mitigate the risks associated with working in New Delhi. By not connecting to India's public switched telephone network, vCustomer is able to commit to delivering offshore services at domestic quality levels.

vCustomer's management team views technology as a business enabler: IP technology is definitely viewed as an asset. vCustomer believes it could not be in the business it is in today if it were not running the kind of voice over IP technology it is.

Voice over IP technology allows vCustomer to provision a network where circuits can fail on a regular basis. Because it is packet-switched voice, the routers can see that a route has gone down. It takes the conversation that is going over one T1 back to the gateway. If that T1 drops, the router is going to see that that link's gone down, and it's immediately going to switch it over an alternate path. Worst case, a customer might detect a 1-second pause in the conversation while the conversation picks back up. In a traditional circuit-switched environment, every call that's on a link that goes down is dropped.

"Because we are running this particular IP solution, technology is a business enabler. It means vCustomer is able to put contact centers anywhere in the world it can get a data network to go. We are able to deliver extremely high-quality services, because we can apply quality of service metrics, we can apply a lot of very sophisticated rules to how we route traffic that was built in natively to IP networks that doesn't exist on TDM networks."

The Planning Process

vCustomer's test bed and pilot program ran approximately six months prior to going into full production. "We started out by using some of our early infrastructure, which wasn't as tuned to the type of offshore voice services that we now have developed. When we saw that it was going to work, even at those earlier stages, without having everything optimized, then we knew we were on to something. We knew what we needed to do to improve it and to really make it an effective system. Because we were successful early on, even with a limited infrastructure, we knew that once we had it optimized to really deliver this type of service there was going to be no stopping us."

Decision Metrics for Implementation

vCustomer's decision metrics focused on taking an idea and evaluating it in terms of being a viable, profitable business model. vCustomer started out in the e-mail business doing non-time-sensitive business response business services. Two-and-a-half years ago, vCustomer looked into moving into the voice side of business. In that evaluation, vCustomer learned that the technology was available and capable of meeting its needs. "Now that Cisco products were available, we were really able to leverage offshore business process virtualization using this particular product line.

"Seventy percent of the decision metrics were rooted in evaluating and determining if the technology was stable enough to support an offshore business. The remaining 30 percent of the decisions focused on the legal and financial aspects of the model." On the legal side, the decisions included everything associated with doing business in a foreign country: working with the government and appropriate regulatory agencies, understanding the rules of engagement, building an employee base, and training. "We had to get the foreign end piece in place to make sure that, apart from the technology, we were going to be able to work with the local government there.

"While the technology was an interesting challenge, that's kind of a known challenge. We know how to work that kind of challenge. Working with the foreign government, in order to get them to understand what it was we were trying to do and buy off on it—that was something new."

Barriers to Implementation

  • ". . . challenges politically and with regulations for what we were trying to do because what we were doing was relatively new."

  • "We had to spend quite a bit of time working with the various regulators in India to get them to understand what it was we were doing—to educate them and to explain to them it wasn't a particular threat."

  • "There were no rules and regulations (in India) for specifically what we were trying to do. Because there was no document saying yes you can do this, their intuition told them that they needed to answer no."

  • "One of the other barriers was explaining it to our client base as well."

  • "As we talked to new customers to explain to them [our services], they're used to their vendors delivering that in a particular way. We were delivering it (customer care services) in a very new way. Not only a virtual way, we're offshore, we're using a technology they are not that familiar with, and they have a hard time touching how we are handling this for them."

Lessons Learned in the Testing Phase

  • ". . . we fine-tuned the compression that we were going to use on the network."

  • "We determined quite a few quality (of service) things in some of our preliminary testing before we rolled it out into production."

  • "We had to clean up the desktop application we were using, because we realized it wasn't fast enough for production."

  • "We also changed the configuration of our PBX deployment."

Unforeseen Benefits of Implementation

  • "One of the things we discovered was just how simple it is to administer the platform. Administration of the platform was much easier than we thought it was going to be, because the interfaces on it are all very much web-based."

  • "One of the other advantages has been on the U.S. side from working at home and from traveling, it has been much easier to engage remote employees in the business."

  • ". . . we converged our voice mail to e-mail. It was purely supposed to be at an executive administrative level. It wasn't a production-driven decision. Once we did it, we realized there were some real advantages to having done this, even on the production side."

  • ". . . the Cisco solution can queue and route different types of media . . . . The agents could read the e-mail when there was a low voice volume, find out what the person's problem was, execute an outbound call back to the person . . . . It made our clients very happy that we were able to offer this kind of service."

Unforeseen Barriers to Implementation

  • ". . . the biggest thing, and this is specific to the new technology, the new platform that we used, was the reporting piece of it wasn't ready."

  • ". . . now that we have taken that all in-house and we now build all of our own reports, we do all of our own SQL queries, it has tremendously added to the flexibility that we have and the value that we can offer to our clients. Regardless of what they want, as long as the data is there, we can generate a report in a matter of hours for them."

Future Plans for Business Process Virtualization

  • "We are very much interested in the streaming media side. . . . So there are a lot of smaller concerts that one of our customers wants to be able to make available on their website. . . .Because of the network that we have, we are able to provide the development resources to this customer in order for them to build these applications very cost-effectively."

  • "One of the newer angles we have been taking on through business process virtualization is to utilize some of the fax services that are available through the Cisco products. . . .That's really opened up a whole new business direction for us."

  • ". . . we very much want to move to wireless. . . . Right now our IT, and really our networking team, is working very closely with Cisco and one other wireless provider, looking at some of the wireless technologies and obviously the security around wireless, because we take security, very, very seriously. Security is critical to our business. We would lose our reputation if we cannot guarantee it."

  • "We are also, frankly, investigating Linux-based and non-Windows-based workstations. . . . From an ROI and cost-effective perspective, that's got the potential to increase our bottom line revenue by a couple of points . . ."

Words of Advice

"I would say, the advice would be, understand your business cycle, and understand the business flow you are looking to outsource. Make sure you are engaging people who have experience working in that area. If they are people who you have internally in your organization, absolutely that is a terrific thing. A lot of companies don't have the internal staff who understand how to take a traditional business process and virtualize it. In that case, you really do need to shop around and bring in a vendor who understands how to virtualize your particular type of business. When you asked earlier what would make me go to an outsourcer, this is what would make me go to an outsourcer. Like everything in life, if it's not worth doing right, then it's not worth doing. When you want to business process virtualize, you are going to want to talk to an organization who knows, who has the experience, and can give you some good hard ROI numbers. And help you understand what it is going to really change in your business before you start down that road."


References

  1. Hof, Robert D. and Steve Hamm. May 2002. "The Future of E-Business: How E-Biz Rose, Fell, and Will Rise Again." Business Week.

  2. Pierce, John. June 1980. An Introduction to Information Theory. New York: Dover Publications.

  3. Von Neumann and Mergenstern. August 1953. Theory of Games and Economic Behavior. New Jersey: John Wiley and Sons.


Chapter 3. Capitalizing on Enabling Technologies

Chapters 1, "The Role of Business Process Virtualization in Your Business," and 2, "History Lessons: Why Conventional Business Models No Longer Work," discussed the whys of BPV:

  • Why BPV provides a fundamentally different way to organize business.

  • Why it is a different model than has been the norm.

  • Why it is a process that fundamentally depends on the management of data and its conversion into information.

This chapter explores the hows of BPV—how specific technologies are applied to achieve the virtues that BPV can confer on the business organized to take advantage of its principles.

First, however, we must spend some time discussing the structural components of a virtualized business. Virtual businesses are structured around the following principles:

  • Geographic dispersion— A virtual business is not necessarily located in any particular place. Although its headquarters might be located in a building, its center of mass cannot be said to be there. Instead, the virtual business uses technology to place employees close to the customer.

  • Distributed/networked systems and automation— To support the necessity of geographic dispersion, a virtual business uses networking technology to disperse its automated resources. This provides immediacy of response to remote workers and also provides a high degree of survivability. This extends to such computer resources as storage and processing.

  • Adaptive business intelligence— The mark of a virtualized business is how it converts data into information to support business decisions. A virtualized business responds more quickly to market conditions because its employees are provided the means to actualize intelligence gathered in real time.

These principles work interactively, building on each other. Each principle fundamentally depends on technologies that were perfected and refined during the dot-com boom and that are now available to bricks-and-mortar businesses.

Of course, the question is, Why are these characteristics deemed virtuous in the current business climate? The answer is that business is done between people, and high-value business is done face-to-face. This is the fundamental disconnect of the dot-com bubble, and it forms the basis of implementing a virtualized business.

By allowing employees to meet customers or clients on their own turf, with the full support of and access to the appropriate resources and tools that a traditional employee would enjoy, the periphery of the business has also been extended. The real effect of BPV is to make the virtual company's center of mass the product or offering of the business rather than the facility in which the business is conducted.

A virtual business needs to be geographically dispersed because it needs to meet its customers wherever they are located. To do this, a virtual business needs a networked infrastructure that supports employee dispersion. Additionally, a virtual business needs to be able to make available or simulate the resources over the network that would be expected in a centralized, bricks-and-mortar environment.

This book has been somewhat theoretical up to this point, but the ways in which these principles are applied can best be illustrated by painting a picture of a day in the life of an employee of a virtual corporation.


A Day in the Life of a Virtual Employee

Sally is an employee of Acme Computer Products. Until the day before yesterday, she was a freelance computer consultant, but then she came across an ad on the web announcing that Acme was staffing to address the evolving needs of its clientele. After submitting her resume to Acme through a bonded and certified hiring portal, she was contacted for a telephone interview. A hiring manager, who was located on the other side of the country, conducted the interview.

As soon as the terms and conditions of employment were agreed on, a contract was executed by e-mail. The contract execution initiated an automated e-mail that provided access information to Acme's employee web portal.

Last night, Sally logged on to the Acme site and selected her employee health benefit options, provided banking information to accommodate her paycheck, and took a virtual tour of Acme. During this session, she also activated a company e-mail box. Her first e-mail directed her to her virtual work group, where she exchanged messages with her supervisor, received information on her first assignment, and was provided access to the appropriate folders in the virtual workspace.

Today, Sally is on her way to meet with her first customer, having been provided with contact information and the appropriate collateral through her workspace. At the customer site, Sally has access to the appropriate enterprise resource planning (ERP) applications through her wireless laptop, and she can access specific customer support applications as well. She can access all these applications through her virtual workspace using a single security logon.

As Sally continues to meet with customers, she is always connected with Acme and can always contact her coworkers for support or advice. In 6 months, when Sally accepts another assignment with Virtual Machines, Inc., her access arrangements will be automatically closed and terminated, and her employment record on the hiring portal will be updated. When Sally resigns, she will carry fond memories of working at Acme, but if pressed, she will have difficulty explaining exactly where Acme is located or describing her coworkers.

If you have followed the evolution of distributed computing, most of this will seem vaguely familiar. If you have this feeling, we tip our hats, because this is very similar to a notion first articulated by Scott McNeeley of Sun Microsystems—the idea of the network as the computer.


Scott, You Were Right: The Network as a Computer

Scott McNeeley has a reputation for being brash, but when he proclaimed the ascendancy of the network over the computer, most in the IT world laughed. The Internet of a decade ago was rough and unreliable, to say the least. McNeeley's notion that all intelligence could be vested in the network seemed the height of folly. How could a basically unreliable medium assume the functions that a desktop PC could provide?

To answer this question, we must briefly review the concept of the computer. For many of us, computers seem so old hat and normal that we rarely question exactly what goes on inside the box. However, to do the same things over a network that a PC does on the desktop, it is necessary to complete the same functions.

As shown in Figure 3-1, the standard Von Neumann model for a computer architecture comprises five building blocks:

  • Input

  • Output

  • Arithmetic

  • Memory

  • Control

Figure 3-1. Von Neumann Model for Computer Architecture

Each of these functions is necessary to complete a task.

To execute and complete an operation, an input is received, interpreted by control, operated on by arithmetic, and output as some form of action. All intermediate results are stored in memory.

As shown in Figure 3-2, the same sort of process can be performed in a networked environment. Now, however, there is an order of abstraction, because many of the functions are themselves performed on computer devices. In any case, an instruction is sent by a networked device, it is interpreted by another computer, an operation is performed, and an output is returned to the requestor. All intermediate results and data are stored in various storage points in the network. Conceptually, these are the first steps a firm takes when moving toward implementing a grid or utility computing environment.

Figure 3-2. The Network as a Computer

In the network domain, however, there is a fundamental difference from a standalone processor. Because the architecture is open, the internal processes must be managed in a secure way that allows them to be shielded from intrusion or examination. Although a desktop PC does not need to worry about the loss of data between the various processing points, a network-computing environment does. Thus, the networked computer space incurs overhead associated with data and user integrity that a standalone PC does not.

The logical conclusion is that this overhead necessarily makes a networked environment less efficient than an integrated processor. This is, of course, correct; however, the loss in efficiency is more than offset by the gains in utility. A network is more flexible, more distributed, and less prone to catastrophic single-source failure. Because of high-bandwidth pipes and parallel processing, it can be nearly as fast as its standalone counterpart.

As a consequence of this open-architecture approach, a networked computing environment is much more complex than a centralized processing environment. Until recently, the network as a computer foundered on the rocks of three core capabilities: distributed storage, distributed intelligence, and an intelligent switch fabric. This makes sense if you recall what takes place in a conventional computer and how this relates to similar functions that must take place in a network to provide the same services.

As previously noted, in a conventional computer, an instruction is loaded into the buffer and is operated on by the arithmetic logic unit (ALU). The ALU interprets the instruction and then extracts from storage the data to which the instruction points. The data is operated on, and results are saved back in storage. If an output is required, it is sent to the appropriate output device.

In a networked computer environment, the process is much more involved; an instruction may be received by another device, such as a server, connected to the network. To execute the instruction, the server might have to access information that is not resident locally. It then must search nonlocal resources to acquire the appropriate data. Frequently this might involve searching storage belonging to other processors that are also attached to the network. In such a case, the virtual memory available to the server might be the entire storage capacity of all networked devices. Managing such a process is fairly complex and requires a method of accessing distributed storage.

Additionally, what if the server that receives the instruction is incapable of executing it? The server then must search for a server that can execute the instruction. This implies a need to coordinate the operations of multiple network-connected processors.

Each of these dynamics must take place across the network, but many other processes are also taking place on the same network. How are the network resources allocated so that each process receives the necessary capacity to be completed in the appropriate amount of time? This implies the need for an intelligent switched fabric that can adjust the networked resources on-the-fly in response to changing user needs based on defined network usage policies.

To support the notion of flexible employment enabled by a networked infrastructure, the virtual corporation should adopt technology that facilitates the ideas of distributed storage, distributed intelligence, and an intelligent network switching fabric. These capabilities, aimed as they are at simulating a local computer through the network, are essential to achieve the advantages of virtualization. It is useful to explore each of these concepts so that a foundation can be established for a more-detailed discussion of virtualization technology.

Distributed Storage

Distributed storage, as the name implies, deals with making storage available in multiple locations so that it can be accessed as though it were local. This distribution of storage introduces the concept of virtual storage, in which the logical address of a memory location need not be physically coresident with the process accessing it. Although you could argue that such is the case in a standard PC, the difference is that the storage in this case cannot be directly addressed, nor can it be accessed in a machine cycle time.

In a conventional computer, memory carries logical memory ranges that match buffer sizes in the CPU. In practice, such buffer sizes need not limit the amount of addressable memory, but practically, the limit becomes the size of the hard disk being accessed. However, if the data being sought does not correspond to a logical memory range that can be accessed in the hard drive, several things need to happen. First, the processor must interrogate the network to determine whether the data is available within that space. Second, it must launch a request for the data so that the pending operation can be completed.

It is probably clear that the process for doing this is dependent on a packaged request for information so that the network can be interrogated. It also involves waiting while the network responds. If the response is affirmative, the processor must perform the appropriate handshaking so that the data can be delivered. As must be apparent, such a task always takes more processor cycles than simply accessing local storage. It always takes longer to access remote storage than local storage.

This latency of operation can have a profound impact on a process's ability to execute properly. In the case of simple operations such as word processing, latency in data delivery can be troublesome, but manageable. In the case of time-sensitive operations such as timed transactions in an ERP system, the impact can be a failure of the process to complete.

To deal with latency, many architectures have been developed to store multiple images of data across the network so that some local data is always available. This imaging of data introduces its own problems, however, because each of the images must be reconciled with each of the others so that each image is a true one. As you might imagine, such image reconciliation or mirroring can generate large amounts of network traffic and overhead.

Partly in response to the overhead associated with managing multiple-image data sources, storage architectures for networks have been, to some extent, standardized. The storage-area network (SAN) and network-attached storage (NAS) are two ways of managing distributed storage from a direct-access point of view. The distributed database is another way that is available to applications at a somewhat higher level of abstraction.

SAN technology attempts to provide storage in increments much larger than would be available on a single hard drive, at much higher levels of reliability. Typically this is accomplished through the application of redundant array of independent disks (RAID) technology, in which data is stored across many hard disks running in parallel. The RAID arrays are connected through a special-purpose LAN that allows data to flow from one RAID array to another. This allows for flexible capacity that can grow as the demands for storage grow. The SAN is then connected to the data network through a server and is made available to all connected processing devices. Figure 3-3 shows a typical SAN configuration. Although it is complex in practice, the effect is the same as having a very large hard drive that is accessible by all the network-connected computers.

Figure 3-3. SAN Architecture

NAS is another approach to distributed storage. Rather than building a special-purpose storage environment, a NAS architecture places network-accessible storage across the network in storage appliances. This approach is much simpler in practice to apply and can be less expensive as well. Figure 3-4 illustrates an NAS-constructed environment. A NAS-based storage architecture suffers from the problem of network latency more frequently than the SAN approach. This increased latency is because of the mirroring that takes place across the entire LAN rather than within a dedicated storage network.

Figure 3-4. NAS Architecture

Finally, an approach that abstracts data access at the logical level rather than at the physical access level is distributed databases. In a distributed-database environment, relationships are established among multiple databases that can be accessed locally. In this way, data is stored near its intended user. This storage technique is conceptually similar to the idea of caching that is used in a desktop PC. Data that is operated on locally must be synchronized with the other databases. This tends to dramatically increase the complexity of mirroring and can, at the extreme, place unacceptable loads on network capacity. Using a distributed database approach requires fairly involved capacity planning considerations.

All approaches to distributed storage seek to manage data transparently to minimize the impact on the users. As far as an employee or manager is concerned, data required to perform his or her job function is available instantly, regardless of the location of work or the mode of network access. Distributed data storage solves the problem of managing data, but as you no doubt have noticed, distributed storage can conceivably introduce severe loadings on a network. For distributed storage to operate in an environment of multiple applications, each requiring access to the data that is important to them, the networked computer must have the same sort of traffic management that a conventional PC uses to manage data on its internal data buses. What is required is a form of distributed intelligence to manage the priorities associated with allocated resources to applications.

Distributed Intelligence: Policy-Based Management

Distributed intelligence is how a virtual business ensures that resources are allocated appropriately within the virtualized business space. In other words, distributed intelligence is how applications and employees are provided the resources they need to get the job done. In practice this has carried a number of names, some of which (like quality of service [QoS]) have come to be somewhat pejorative. In any case, the current notion associated with distributed intelligence is policy-based management.

In policy-based management, the company decides which applications and employees receive priority and access to networked resources. For example, if a CEO is using voice over IP (VoIP) telephony, which is a high-bandwidth, latency-sensitive application, and another employee decides to download the complete video for The Sound of Music, Maria will just have to wait while the CEO finishes her call. Of course, you could also set up a policy that prohibits such video downloads.

Policy-based approaches force the company to think in terms of priorities and can involve sensitive negotiations around which groups will ultimately get priority in a highly loaded network environment. In fact, this contention for scarce resources has usually precluded companies from adopting policy-based approaches. Many CIOs have lost their jobs trying to referee fights that have developed at the executive level over the degree to which network bandwidth was made available by application or workgroup. (See the Motorola case study in Chapter 7, "Internal Security Implications of Managing the BPV-Centric Company," to see how one firm eliminated this problem.)

In fact, this contention has forced the evolution of policy-based appliances that provide bandwidth control over dedicated links. Such appliances, rather than attempting to apply policies at a workgroup or individual employee level, instead assign bandwidth priority to classes of applications. In such a scheme, VoIP might get higher priority than e-mail, for example.

Policies can be assigned and managed at a packet level through many different schema. In the simplest instances, policies are assigned at the packet header level. This allows network devices to monitor the header and assign priority routing to high-priority packets. More-complex policy approaches might completely replace the normal packet header, effectively encapsulating existing packets in one that is associated with a defined policy.

However it is accomplished in practice, it is clear that policy management imposes its own set of overheads on network performance. If an appliance is used, it obviously must cycle many times faster than the network itself so that packet prioritization does not introduce delays in packet delivery. If the policies are centrally administered, they need to be monitored in such a way that more traffic is not being generated by the policy manager than is being transported. Within an intelligent networked infrastructure, policy enforcement is distributed throughout the environment at the switch and router level to alleviate latency issues.

The most significant implication of policy-based management is the impact it can have on the management of employees and company resources. When policy management at a network level is tied to policies at a business level, the dynamic for networking is fundamentally changed. For example, consider the employee with which we opened this chapter. Sally can log in to the company with a preassigned password that automatically makes available to her all the company applications she needs to use, her workspace, and all HR-related resources. This is possible because business policies have been extended throughout the network. As an employee in a particular workgroup doing particular tasks, Sally must have access to specific applications at a minimum quality level.

The use of policies to tie business objectives to networked infrastructure provides a powerful new way of managing a dispersed workforce. Rather than attempting to directly manage an employee's time, the company merely manages his or her access in the context of established work performance criteria. Managers in a virtualized business need to think in terms of business processes and results management rather than people management. Policy-based management technology provides an important tool for accomplishing this change in management objective.

Intelligent IP Switch Fabric

A business that is enabled with distributed storage capability, as well as distributed intelligence, is nearly capable of applying network-based computing to virtualize business operations. At the technical level, however, one component is missing—the attribute of a dynamic networking environment.

Although the whole point of Internet Protocol (IP) is to construct a network that is flexible and dynamic, the fact remains that IP-based networking is somewhat mindless when it comes to optimizing the transport of critical data. Even with policy-based management, the ultimate routing of data is a nondeterministic process; that is, it is governed by rules that are applied locally rather than through any global approach to routing. To accomplish this, a higher order of network intelligence must seek to optimize the routing of data for critical purposes. This is called an intelligent switch fabric.

In the desktop computer, data is directed through physical buses to the desired destination. As a consequence, there is no need to simulate such busing. In the network, however, there may be a need to simulate direct connections between end devices. This is most often the case when security is an issue.

Intelligent switching, then, is the application of logical levels above conventional IP routing to simulate a directly connected network. One application of a simulated directly connected network is a virtual private network (VPN). It is implemented through the application of security layers to the IP packets.

In practice, VPNs are implemented through the application of such protocols as Multiprotocol Label Switching (MPLS) and IP Security (IPSec). Although the most desirable from a WAN/multinetwork vendor environment is IPSec, MPLS has lately made significant headway in that space and is likely to emerge as the de facto standard for VPN deployment.

VPNs are exceedingly important to the virtual business. Through VPNs, a virtual business can establish secure communications with its suppliers and customers. It can also establish and maintain network connections to remote offices or employees working remotely. Using VPNs, a virtualized business can use the Internet as a secure point-to-point circuit environment. Leveraging directory-enabled, policy-based management, a firm's VPN architecture can become fully meshed, eliminating islands of people and information.

By combining distributed storage, distributed intelligence, and an intelligent switching fabric, and by enabling VPN connectivity, a company ends up with a completely virtual infrastructure that is literally anywhere the Internet is. The advantage of technology over bricks-and-mortar can then be perceived to be one of presence: presence through secure channels providing connectivity with data and applications regardless of location.

This is all well and good, we can hear you thinking, but it is not a trivial thing to build or maintain. That is true. What is being done is to simulate a standalone computer environment through a very dynamic and leaky IP network—a network that doesn't even belong to you. Historically this has been a stumbling block for businesses. Although technology can substitute for physical infrastructure, the trade-off has been complexity. To manage this complexity, enterprises have had to hire significant numbers of skilled technologists to manage the infrastructure nearly minute by minute around the clock. To date, the cost of doing this has exceeded the benefit of executing the strategy.

However, by virtue of the dot-com bubble and the technological revolution it has fostered, prepackaged technologies can be applied to achieve virtualization. One such technology is Cisco Systems' Architecture for Voice, Video, and Integrated Data (AVVID).

AVVID

AVVID is an attempt to knit together all the critical network attributes to support a virtual business. It combines the concepts of distributed storage, distributed intelligence, and an intelligent switching fabric.

AVVID has the virtue of being one of the first comprehensive, completely articulated expressions of what a networked architecture enabling BPV looks like. It combines the concept of data transfer for business applications with concurrently providing management of service quality to enable interactive functions such as voice and video. Furthermore, it packages these functions in a dynamic, policy-driven networking fabric that allows the networked space to adapt in near-real time to changing network and application demands.

As shown in Figure 3-5, AVVID is built on the idea that a consumer of networked services has a wide array of devices available to perform his or her responsibilities. It can no longer be assumed that users will consistently use any particular device.

Figure 3-5. AVVID
[View full size image]

For example, an employee might use a desktop computer, a laptop computer, or even a PDA or cell phone to access networked services. This access might be through wireless media or even through networks other than those supported by the providing company. In every case, the network must recognize the transport medium and package the content appropriately.

AVVID accomplishes this by recognizing and managing a wide variety of network platforms, including servers, routers, and wireless edge devices. This control is provided by an intelligent network services layer. Within this layer, such functions as quality of service, security, and network availability are considered and controlled.

Undoubtedly, one of the most important functions in the intelligent network services layer is that of securing the virtual environment against unauthorized access. This in effect defines a perimeter in virtual space that establishes and defines the bounds of the network-enabled business.

On top of this intelligent network services management layer, AVVID places a unified control plane that provides the distributed intelligence necessary to deliver networked services flexibly and at the desired service levels, regardless of the networked environment that is being used.

AVVID establishes networked services and service levels by using security information from the intelligent network services layer and then applying predefined policies to map the user to the appropriate services within the appropriate service quality boundaries. This has the effect of abstracting the network environment to higher-level applications. As far as the layers above are concerned, the unified control plane is the user.

Above the control plane live communications services. These services are concerned with making the appropriate connection between users and applications. All delivery problems and service issues are managed here, allowing the applications to react and operate as though they are located on a dedicated desktop computer.

Communications services are the heart of the virtualized business. Within an IP networked environment, any service can be represented by a data stream. However, each data stream has particular requirements in terms of delivery quality and processing. The AVVID architecture recognizes the individual data stream requirements and provides different levels of networked resources to different functions. Such communications functions as collaboration, video, and voice are enabled here. In a sense, the virtual company lives in this layer, because this is where real interaction is accomplished.

Above the communications layer live all the virtual business's applications. The Internet business solutions layer is where all the company's intellectual property is accessed. HR applications, customer care applications, supply chain management functionality, and all associated business functionality necessary to the conduct of the virtualized business reside at the Internet business solutions layer.

The AVVID approach provides all the necessary functionality to enable BPV. Within a homogeneous Cisco environment, AVVID can be a viable and well-structured way to achieve BPV. For enterprises that use the Internet as an access medium, AVVID can still be a significant step in the right direction, providing the core functionality to connect virtualized business services to networked employees.


Summary

  • Virtual businesses are structured around the following principles: geographic dispersion, distributed/networked systems and automation, and adaptive business intelligence.

  • The real effect of BPV is to make the virtual company's center of mass wherever business needs to be conducted.

  • Additionally, a virtual business needs to be able to make available or simulate the resources over the network that would be expected in a centralized, bricks-and-mortar environment.

  • Because the architecture is open, the internal processes must be managed in a secure way that allows them to be shielded from intrusion or examination.

  • To support the notion of flexible employment enabled by a networked infrastructure, the virtual corporation must adopt technology that enables the ideas of distributed storage, distributed intelligence, and an intelligent network switching fabric.

  • To deal with latency, many architectures have been developed to store multiple images of data across the network so that some local data is always available.

  • Distributed intelligence is the way in which a virtual business ensures that resources are allocated appropriately within the virtualized business space.

  • In policy-based management, the company decides which applications and employees will receive priority and access to networked resources.

  • When policy management at a network level is tied to policies at a business level, the dynamic for networking is fundamentally changed.

  • The use of policies to tie business objectives to networked infrastructure provides a powerful new way of managing a dispersed workforce.

  • Intelligent switching is the application of logical levels above conventional IP routing to simulate a directly connected network.

  • VPNs are exceedingly important to the virtual business. Through VPNs, a virtual business can establish secure communications with its suppliers and customers.

  • The advantage of technology over bricks-and-mortar can be perceived to be one of presence: presence through secure channels providing connectivity with data and applications regardless of location.

  • AVVID has the virtue of being one of the first comprehensive, completely articulated expressions of what a networked architecture enabling BPV looks like.


Case Study: Teletext, United Kingdom (www.teletext.com)

Personal interview conducted with Jason Liggins, manager of infrastructure, services, and platforms

Virtualized business process: AVVID

Company Background

Company Overview

Teletext Ltd. is the number one U.K. repository of holiday television advertising, with viewing figures of approximately 23 million per week. In addition, its holidays website (www.teletextholidays.co.uk) generates interest amounting to 30 million page impressions per month. Teletext is a news and entertainment communications company; its business medium is to offer advertising space. In the United Kingdom, the Teletext brand is synonymous with up-to-the-minute holiday offers, news, sporting results, financial market information, and money-management advice. Additionally, Teletext offers its customers entertainment information such as cinema, theater, concert events, and television listings. Business services, listings, location, and contact information are also available.

Teletext is a full-service communications company offering its customers up-to-the-minute news and information in formats that fit an active lifestyle.Teletext-generated information can be received via television, the web, and mobile telephones.

Teletext was founded in the U.K. in 1992 to bid for the British public teletext license. The company is owned by two entities: Harmsworth Media, a large communications conglomerate, and Media Ventures International.

Teletext began broadcasting on January 1, 1993. Like any broadcasting company, Teletext is licensed and regulated. In the U.K., the regulatory agency is ITC. Broadcasting is available over a variety of media, including the Internet via the Teletext website, analog, digital, cable, and satellite television.

Network Overview

The Teletext network is an international network aimed at distributing television services in the U.K. and by satellite internationally. Network links to advertising clients allow the client to change its advertising in real time. Teletext has two corporate offices—one located in England and the other in Scotland supporting more than 400 employees. Additionally, there are 45 unmanned sites supporting TV distribution, distributed data centers, and web hosting.

Teletext moved both of its office locations into new facilities at the turn of the century. With the relocation, the company took the opportunity to upgrade its network infrastructure with an eye toward supporting emerging technologies. The firm incorporated Cisco Systems' AVVID into both green field sites.

Today Teletext leverages the AVVID architecture to support voice over IP. In the future, when Teletext is ready to execute, it will be able to easily incorporate streaming media, video, distributed storage-area networks, policy-based management, and distributed intelligence.

Teletext places an emphasis on integrating its critical business applications with business processes. As part of the initial evaluation, they determined that AVVID supports this key business objective.

The Teletext network is built on 12 Cisco Catalyst 6500 switches set up in a collapsed architecture. The core of the network is composed of five Catalyst 6500 switches using Multilayer Switch Feature Card (MSFC) supervisor modules. These are supported by eight 7200VXR routers. The availability of this core is maintained with redundancy within each device and with geographic diversity. The backbone of the network has a 4 GB capacity on the LAN and 100 MB on the metropolitan-area network (MAN). The remaining Catalyst 6500 switches redundantly support servers and with the aid of power-enabled 10/100 48-port Fast Ethernet modules Cisco IP hard phones and office PCs.

The wide-area network (WAN) consists of redundant leased lines ranging from X21 at 64 KB to 100-MB SDH circuits. Redundant circuits are delivered from geographically disparate sites within the MAN either as leased lines or as basic-rate ISDN circuits concentrated at the MAN into primary-rate circuits. VoIP is run on the MAN and on a WAN link between the offices in England and Scotland. To economize on the cost of the backup circuit, should the primary link go down, only data is run across the backup. This would isolate the VoIP at that office, but the telephones would continue to work using Survivable Remote Site Telephony (SRST), and interoffice calls are made across the Public Switched Telephone Network (PSTN).

Teletext's websites make use of Cisco's Catalyst 11500 series content switches to switch traffic at OSI Layer 7 and global load-balancing facility to redirect HTTP requests to different geographic sites depending on load or route.

Security

Security is a requirement of the Teletext Ltd. license to broadcast on television, to ensure that inappropriate, offensive, and unauthorized material is not sent to air. Production systems relating to different areas of the business are isolated. Use is made of VLANs, subnets, firewalls, access control lists, network address translation, and intrusion detection. Systems have centrally controlled hardware and software monitoring and protection, including imaging, antivirus web, and e-mail filtering.

Management's Attitude Toward Technology for the Business

Teletext's management team's views on technology revolve around its need to consistently meet and exceed customer expectations. As an advertising medium used by holiday companies and betting agencies, real-time updating of holiday offers, betting odds, and sporting results provides commercial advantage to Teletext's business customers. Equally as a news agency, Teletext provides real-time breaking news stories, flight arrivals, and financial information as a component of its quality of service. The team recognizes that technology is central to Teletext's business and balances cost against the overall business objectives of high reliability and rapid information delivery.

Teletext's business strategy is rooted in technology. Therefore, the management team's attitude is extremely positive toward enabling technologies. Packetized networking and IP-based technology are perceived as core company assets. Teletext could not be in business today if it were not able to support leading-edge technologies that meet customer demands for content delivery across a variety of media.

Although the management's technology views are highly positive, they do not squander their resources moving from one technology to another. Instead, Teletext looks at the long-term benefits of technology implementations and their ability to support future business plans. In this sense, technology implementations are strategic rather than tactical to the company.

The Planning Process for the Office Moves

Teletext moved two London offices and a Glasgow office at the turn of the century to green field sites. The London moves also involved moving two data centers to new facilities. Teletext is a 24-hours-a-day, 7-days-a-week business. It was a requirement of the moves that they would not affect its service level agreements in terms of availability and real-time updating. Network planning started 2 years before the move, with selection of the sites and equipment vendors. Cisco VoIP was seen as a flexible technology that offered scalability beyond traditional PBX technology. The decentralization of the technology in terms of its modularity was advantageous, but the shift of the majority of the cost from a central PBX to the handsets was a big plus.

After careful evaluation and talking with vendors, Teletext implemented a 6-month Cisco VoIP pilot program at its Glasgow office. To stretch the experiment, the call manager was run from London, with SRST running on the voice gateway in the case of a WAN link failure. This facility was relocated first and gave Teletext the opportunity to test the AVVID architecture in a controlled environment. During the test pilot, Teletext continued to plan and strategize for implementation at their London facilities.

Decision Metrics for Implementation

  • "The system that we were going to implement needed to be modular."

  • "Modularity allowed us to break the implementation down into smaller financial chunks."

  • "We liked the cost because we could lose the PBX. But it didn't actually achieve that . . ."

  • "It (the AVVID architecture) does shift the cost away from one central PBX to individual telephones. That was attractive to our finance department, in that they could associate the cost of the telephones with headcount as opposed to one big cost for a PBX system."

  • "We could bring the management in-house using our IT team rather than having an external company supporting a proprietary PBX."

  • "It (flexibility of application support) was what attracted us to the AVVID architecture, as well as based on support for further technology. . . . For instance, the call center application that we bought through Cisco partners essentially is an add-on to the AVVID architecture."

Barriers to Implementation

  • "The barriers that were in the planning stage were putting all our eggs in one basket. It was seen as a barrier allowing the telephone system into the data architecture, which wasn't seen as so reliable."

  • "Cost. It proved to be much more expensive than using our PBX."

Lessons Learned in the Testing Phase

  • "You have to learn to allow more time for planning . . ."

  • ". . . allow more time for implementation."

  • "We learned a bit about where we needed to put in redundancy and where we didn't."

Unforeseen Benefits of Implementation

  • Teletext ran a total cost of ownership (TCO) analysis, comparing retaining its PBX and implementing Cisco's AVVID architecture. "How that compared was probably the hardware is essentially the same, but the PBX technology is not so scalable as voice over IP technology. That was seen as a plus point for the voice over IP. The ability to bring the management of it in-house was seen as a big plus point. So in terms of cost, really, the ongoing management of proprietary technology is expensive."

  • "They (the users) want the phone to ring, they want their voice mail to work, and they don't care how it is done. The fact that unified messaging is there is a big plus . . ."

  • "We can identify savings in terms of savings we are making by not outsourcing the troubleshooting of the private branch exchange."

  • As a green field site, Teletext stated, ". . . we never did have to pay for the wiring infrastructure to support telephones."

Unforeseen Barriers to Implementation

  • "We had a few software bugs to do with interoperability between the Cisco AVVID VoIP software and the call center software written by Cisco partners. These problems represented less than 1 percent of the usage of the VoIP part of the network, but because the technology is new (relative to PBX) and the call center is an important part of our communication with our customers, its importance was raised much higher than it would have otherwise been."

  • "People's expectations in terms of, they thought perhaps that a telephone system converged with the data wouldn't work properly. They were quite pleasantly surprised when for the most part it did."

Future Plans for Business Process Virtualization

  • "I've got some plans on the horizon as well for doing more streaming."

  • "We have experimented with PDAs, and we are going to do some more content management and content switching."

  • Teletext is also planning on adding additional support for the emerging, robust mobile phones. "If you think of the new phones, they are pretty good. There is a new one out from Ericsson that is a PDA, essentially. . . . Nice little colored screens, runs Windows CE; they're good."

  • "If an opportunity arose on any medium to advertise on it, we would create a framework for an advertiser to use it."

Words of Advice

"It is worth getting lots of advice. We were lucky enough to get lots of good advice from Cisco directly, as well as the reseller that we bought everything through. I think that was time well spent. The VoIP pilot was an excellent exercise. We learned a lot about deploying and supporting the technology, so we were well up on the learning curve when we came to implement it in London."

ROI

"Our ROI is, like other companies, measured in terms of reliability. The Service Level Agreements (SLAs) we adhere to are based on past performance. Each day, because of the Cisco systems we have installed, that passes without incident improves the SLAs and prevents the financial penalties associated with their breach. The improvement in SLA is measurable and is used to offset the investment."


Chapter 4. Capitalizing on Enabling Applications

Chapter 3, "Capitalizing on Enabling Technologies," demonstrated how enabling technologies can provide a powerful framework on which to build BPV. Chapter 3 illustrated the manner in which distributed storage, distributed intelligence, and an intelligent switching capability enable such functions as voice, video, data, converged networking, and unified messaging services. Chapter 3 also provided a case study demonstrating how Teletext is reaping significant benefits by using such technology to enable faster execution of some of its core business processes. As the case study demonstrated, companies have been using technological designs such as Cisco's AVVID to provide such services. However, that chapter limited the discussion of services to a high level and painted a picture that, although compelling, glossed over the deeper capabilities that can be delivered over an intelligent infrastructure.

This chapter delves into greater functionality and service capabilities through an intelligent network and converged architecture. This chapter proceeds to a detailed discussion of the implications of BPV applications. These applications enable a highly flexible and accessible virtual workspace. Not only do they provide basic business functionality in a conventional sense, but they also transcend geographic boundaries and bricks-and-mortar constraints. Virtualized applications provide capabilities that cannot be provided in a bricks-and-mortar context.

Although the networking technologies of distributed intelligence, intelligent switching, and distributed storage represent an enabling platform for the delivery of applications, the applications themselves represent the medium for interchange. Just as the technology represents virtual walls of the virtualized business's building, the applications represent the virtual cubicles within the building.

Within a bricks-and-mortar business, the cubicle provides a telephone, a computer, and access to other employees. The virtual cubicle provides communications capabilities and a medium for data, document, and brainstorming collaboration, and it is an enabler for telepresence. This chapter focuses on the applications themselves. Chapter 5, "Capitalizing on a Virtual Presence," explores how network-enabled applications can enhance capabilities that a bricks-and-mortar infrastructure can't even begin to approach.

The applications that are the focus of this chapter enable the kind of virtual presence discussed in the preceding chapter. These include technologies associated with remote access and intermittent connectivity: VoIP, streaming media, and follow-me IP addresses. Combined in various permutations, applications providing information-sharing and collaborative functionalities can extend the virtualized business to any point that the global network reaches.


VoIP

VoIP, which stands for voice over IP or voice over packet, can be thought of as simply transferring the transmission of voice communications from an analog switched medium to a digital, packet-switched medium. Of course, the actual process is much more complex, but in practice, the effect is to change the delivery medium from a discrete one that parallels the data network to a combined one that delivers both voice traffic and data traffic over the same networked infrastructure.

The natural question is, why would anyone want to do this? After all, the Public Switched Telephone Network (PSTN) is nearly ubiquitous, highly reliable, and cost effective. The answer to this question has been an evolutionary one and requires some elaboration.

When data transport came to the Bell System, it was as an overhead to conventional voice traffic. A modem (modulator/demodulator) was required to convert a data stream into tones that could be carried at low speed across a network that was optimized for a voice signal of roughly 3000 Hz. In practice, over time, this has translated into a maximum throughput of about 56 Kb—excruciatingly slow for most purposes beyond e-mail exchanges without attachments.

However, with the introduction of the Internet and general access to the World Wide Web, it wasn't long before hobbyists noticed that although the telephone company could charge you for long distance when you made an interstate call, it had no way of knowing where your packets were coming from or going to when you were interacting on the web. In short order, simple applications were written that allowed for the transmission of voice over the same data connection providing access to the web. VoIP was born as a way to bypass the toll systems for long distance.

VoIP, in its infancy, was pretty bad. The same slow connections that made web access possible were now being used to transmit a voice signal. The quality of the voice signal was sadly lacking. Anyone who heard one of the early voice transmissions across the Internet was totally unimpressed with its quality. Such connections could barely transmit a sense of what was being said, let alone transmit nuances or intonations. The phone companies took one look and went away laughing. VoIP might be free, but it would never threaten the toll revenues of the incumbents—or so they thought.

What the phone companies didn't count on was the forward march of technology. Even with 56-kbps transmission paths, it is possible to do a lot of packet manipulation to clean up a signal and compress it. In no time at all, some pretty good schemes were introduced in the market for transmitting VoIP signals. For large businesses, this soon began to look rather attractive as an alternative to toll charges.

Of course, the phone companies should have expected some development along the lines of VoIP. The Bell System had been using multiplexing, first in the form of time-division multiplexers and later as statistical multiplexers, to compress voice signals over crowded long-haul circuits. This technology depended on sampling voice signals and, in effect, turning them into digital bit streams. If you can do it with multiplexing, you can do it with dedicated codecs. As soon as the Bell System crossed the digital divide, VoIP was inevitable.

For any business that was already transporting a lot of data from one company location to another, the idea that voice traffic could be carried over these data paths, with the associated capability to reduce cost and the number of leased circuits, proved to be an irresistible temptation. Of course, the Bell companies tried mightily to prevent business from adopting such technologies, but the horse was already out of the barn: VoIP was here to stay. This was especially true when large network providers such as Level (3) Communications and T-Systems began to transport all their traffic as IP packets. Now, on long-haul routes, voice was as likely to be an IP packet stream as any other kind of transmission, whether data, audio, or streaming media.

VoIP might have stayed a niche solution for business and home if not for the fact that it is not quite your grandmother's telephone call. VoIP, it turns out, can do lots of things that conventional voice cannot.

For one thing, VoIP is a data stream. Like any other data, it can be stored, manipulated, combined, and copied. In the context of a data environment, this means that functions that are very difficult in a circuit-switched world are very easy. This includes such advanced call features as multiparty calling, call waiting, and call forwarding. Additionally, features that are impossible in the conventional telephone world are also possible. These include such capabilities as voice/text conversion, voice-embedded e-mail, and voice access through data terminals.

As noted, though, VoIP isn't all sweetness and light. It has a myriad of problems that must be addressed by the underlying enabling technology. The first and foremost is that in an IP packet environment, there are no guarantees of packet delivery, nor are there any guarantees that packets will arrive in the same order they were sent.

For nonvoice data, this isn't a problem. If a packet is dropped, the sending device is asked to resend it. If a packet arrives out of order, the receiving device waits and buffers the data, reassembling the sequence as it goes. The only consequence of a noisy network, or one in which there is a lot of contention for resources, is that there might be a slight wait while things get sorted out. This delay is usually imperceptible, causing no problem whatsoever.

In the voice world, however, the latency that such a buffering process introduces can be disastrous. The human ear can distinguish very minute disconnects in a voice signal. When these occur, the perception of quality rapidly deteriorates.

An additional problem with IP data packets, from a voice perspective, is that frequently the path that data takes from the sender to the receiver can change in midtransmission. This means that, again, packets arrive out of sequence; however, this route ambivalence also introduces microwaits as packets fly in from several directions. These microwaits introduce jitter as the signal that reaches the ear starts and stops.

Although storage and buffering can solve many of the problems associated with packet nondeterminism in a data domain, the effect in the voice domain can be to render the signal unintelligible. So how is this problems dealt with? It turns out that you have to transcend the pure IP environment and introduce quality of service through packet prioritization techniques.

A conventional IP packet contains a header that contains, among other things, routing information, security information, and the source and destination address of the packetized information. It also contains a way to prioritize the transfer. This transfer priority lets you specify how tolerant the traffic is of delays.

Conventional IP headers allow only a few discrete quality levels, none of which is typically granular enough to discriminate voice quality continuous transmissions. VoIP, therefore, is required to increase the quality of service by playing a few tricks with routing protocols. One way this can be done is by detecting the type of traffic and allowing additional resources such as bandwidth and routing priority within the networked space to facilitate the transmission of the data.

In the case of Cisco, several solutions are available to dynamically throttle network resources to accommodate VoIP. Two of these are Cisco's Quality of Service Policy Manager (CPM) and Quality of Service Device Manager (CDM). Both address problems associated with network resources and latency in traffic. By leveraging information in the packet headers, policies that are applied and enforced throughout the intelligent network allocate resources to optimize the application. In non-Cisco networks, other solutions are available. However, many of them are based on the idea of looking at the traffic as it is generated and then allocating resources to accommodate it.

With the problem of latency and jitter solved with policy management, VoIP can now deliver voice quality comparable to what conventional phone lines deliver. With sufficient bandwidth available, it can exceed that quality. This means that VoIP can now be considered a viable medium for business communications. Furthermore, because it can be delivered through any intelligent data network, it can provide voice services to any voice-enabled terminal that is connected to the network.

Up to this point, we have discussed the attributes of VoIP. We should spend a brief amount of time on the hows of VoIP. How is VoIP implemented? The answer comes from some rather clever technology.

Figure 4-1 compares a VoIP architecture and a conventional private branch exchange (PBX) circuit-switched architecture. Although the VoIP implementation seems more complex, it is useful to remember that most of the components are actually used for both data and voice and are relatively inexpensive.

Figure 4-1. VoIP Architecture Versus Circuit-Switched Architecture
[View full size image]

To understand how VoIP works, first you must understand something about how conventional circuit-switched voice works. In the circuit-switched world, a call is initiated when you dial a telephone number. This process alerts the central office switch that a call will take place and provides the information necessary to route the call through the network. If you are in North America, this process uses the North American Numbering Plan (NANP) and is composed of ten digits for routing. When the switch receives these digits, generally transmitted as a tone code, it sends a request for connection through a separate signaling network using a standard signaling protocol called Signaling System 7 (SS7). This process, as a result, is called an out-of-band signaling approach.

After the signaling channel has been established, a call can be routed to the receiver. At this point, the receiving telephone is signaled by ringing the instrument. If the telephone goes off-hook, the path is established with a dedicated channel, and the call can take place. In VoIP, the situation is somewhat more involved.

In a VoIP call, it is virtually certain that at some point the call will touch the conventional circuit-switched network. This means that the VoIP technology must understand not only the IP packet-switched environment, but also the NANP/SS7 circuit-switched environment.

For a VoIP call to be initiated, a number is dialed, but instead of instantly routing the number to a central office (CO) switch, the soft switch determines how the number maps to an IP address. If the number maps to an IP address, the call is maintained as a packet stream and is routed through the IP network. If it doesn't, the call is routed to the PSTN through a specified gateway point, and the call is set up as a combined or blended technology call.

Although you might consider this description a gross oversimplification, except for issues associated with network management, VoIP is becoming pretty straightforward, with any number of devices that are essentially plug and play. With this low-impact technology becoming more prevalent, some of the remaining barriers to adoption are falling. As noted, Cisco has many solutions to facilitate the deployment of VoIP.

Of course, if VoIP technology only promised to duplicate the telephone, regardless of how many features that telephone had, it would be hard to convince anyone to use it, unless significant cost savings were associated with doing so. This explains the original ads for VoIP services. Many service providers rolled out VoIP early on as a way to reduce costs associated with plain old telephone and toll services. Unfortunately, when you take into account the additional equipment you need to support such service, as well as the additional bandwidth necessary to carry telephone traffic, the cost savings were generally pretty theoretical. Review the Teletext case study in Chapter 3, "Capitalizing on Enabling Technologies," to see how one company defined its ROI when implementing VoIP.

Of course, intelligent networks and policy management don't just deliver a fancy voice channel. Because data is data, any kind of information can also be delivered using that same channel. The next section describes how this technology can transcend what is available from the conventional circuit-switched network.


Streaming Media

In the early 1960s, AT&T technicians created a buzz when they introduced their videophone. This device epitomized AT&T's vision for the future with a high-tech-looking console that integrated a CRT with a standard telephone handset. At the 1964 World's Fair, people stood in line for hours to try this new form of communication. In the near future, AT&T promised, everyone would have a videophone in their home. Of course, the reality was a good deal less exalted. Given the low-bandwidth channels available at the time, there was no way the videophone could be placed in the home. In fact, the phone depended on such high-bandwidth dedicated channels that not even business could figure out a way to use it cost efficiently. The last time we saw one of these sleek-looking terminals, it was gathering dust in a Bell Labs facility—a forlorn reminder of unrealized dreams, but a precursor to what technology would eventually deliver with an adequately provisioned underlying infrastructure.

Now, more than 40 years after their inception, videophones are poised to make a comeback. Of course, they will never look as good as their predecessors, but they will deliver a reasonable level of quality and in full color, something the original videophone couldn't even contemplate. The secret sauce that enables this resurgence is streaming media technology. Like VoIP, it not only provides for the obvious—video—but it also lets many other functions run concurrently.

At the heart of streaming media is the problem of squeezing a very large signal into a small-bandwidth carrier. Although it is possible to send studio-quality video over any transmission medium, the time required to do so rapidly exceeds a reasonable wait time as services such as video are involved. Compression technology is required to do the squeezing. Compression is generally based on the notion that although the bandwidth required to send a full-motion color video signal is very large when each frame is sent many times a second, it is usually relatively nominal when all you have to do is send what changes between each frame.

This concept is familiar to anyone who watched the footage of Gulf War II on CNN. The videophones that were used worked fine when the subject was standing still and there was relatively little movement in the background. When there was a lot of movement, the picture quality broke down rapidly. This was especially evident when the reporter insisted on standing in front of waving palm trees or other noisy backgrounds.

For services such as videoconferencing, such background movement can be kept to a minimum, allowing videoconferences to make the move to the desktop. Combined with other streaming media such as audio transmissions and VoIP, it is possible to simulate most of the face-to-face functions that are facilitated in a physical office. This is especially true if work is conducted across workgroups, which might be separated physically within the building.


Follow-Me IP Addresses

The interesting thing about VoIP is that it allows unprecedented new capabilities to be delivered. You might note that most of the capabilities we've discussed have been the subject of carrier-inspired media hype for some time. However, with VoIP these capabilities are implicit and do not require extraordinary modifications to either the infrastructure or the phone instruments themselves. This is because of the flexibility of packet-based communications.

Although a circuit-switched analog network requires a separate signaling network to route information, in an IP network the packets themselves can take the place of this separate signaling network. One way in which this can be done has to do with the addressing scheme for delivering packets. As most people know, the IP packet contains routing information that effectively maps a service user to a logical address. This logical address is usually mapped to a particular physical node, but what if this address could be made independent of the physical network? What would you gain if the address could be assigned to a particular user?

Of course, the analog world has seen a long debate over number portability, in which you can keep the same telephone number regardless of carrier. In late 2003, legislation was enacted to support number portability. The legislation speaks to portability between wireless carriers, but it poses a significant threat to the Bell System as consumers migrate from fixed land lines to wireless connectivity.

The idea of single-number service also has been discussed, in which a single number is applied to both wireless and wired communications. In both instances, the idea is that you should be able to receive communications regardless of your location or medium of communication. Although they are noteworthy, both these systems impose a great deal of costly structure on the delivery of information and ultimately work best for voice delivery. When you try to extend the concept to include other data types such as video, e-mail, and graphics, the concept breaks down rapidly.

In the IP world, the process is much simpler and much more flexible. Because an IP address is a logical attribute that can be assigned flexibly and dynamically, when a device moves to a new network, the translation can be performed by the local server in a way that is transparent to the user. All the user knows is that the laptop that worked at the office now works at home or on an airplane—or in Berlin, for that matter. The IP address becomes implicit in the infrastructure.

When this concept is extended to all the devices a user might use, data can route flexibly to any platform regardless of medium. For example, if the laptop is shut down, the data can jump to the desktop computer. If the desktop is unavailable, the data can route to the PDA or cell phone. In each case, the routing occurs quickly and transparently, without a lot of network overhead, as it would in the circuit-switched world.

The practical implication of follow-me IP is that the employee of a BPV-enabled enterprise needn't pre-establish a presence to conduct business. The work environment follows the worker without a lot of fuss or expensive services delivered by less-than-responsive carriers.

The enabling applications of BPV, then, simulate the virtual office. With VoIP, telephone service is freed from fixed wire lines and plain old telephones. Streaming media provide the holodeck within which the communications can take place. Flexible IP routing ensures that the virtual experience is available anywhere, anytime, and on any device the user happens to have.

These applications, combined with the enabling technologies and an enlightened concept of virtual business processes, provide the fundamental foundation on which a virtual business can be built. The following case study shows how this comes together to provide world-class functionality with a nominal investment in technology.


Summary

  • BPV applications enable a highly flexible and accessible virtual workspace. Not only do they provide basic business functionality in a conventional sense, but they also transcend geographic boundaries and bricks-and-mortar constraints.

  • VoIP can be thought of as simply transferring the transmission of voice communications from an analog switched medium to a digital, packet-switched medium.

  • When data transport came to the Bell System, it was as an overhead on conventional voice traffic.

  • What the phone companies didn't count on was the forward march of technology. Even with 56-kbps transmission paths, it is possible to do a lot of packet manipulation to clean up a signal and compress it.

  • VoIP, like any other data, can be stored, manipulated, combined, and copied. In the context of a data environment, this means that functions that are very difficult in a circuit-switched world are very easy.

  • Although storage and buffering can solve many of the problems associated with packet nondeterminism in a data domain, the effect in the voice domain can be to render the signal unintelligible. You have to transcend the pure IP environment and introduce quality of service through packet prioritization techniques.

  • By leveraging information in the packet headers, policies that are applied and enforced throughout the intelligent network allocate resources to optimize the application.

  • If VoIP technology only promised to duplicate the telephone, regardless of how many features that telephone had, it would be hard to convince anyone to use it unless significant cost savings were associated with doing so.

  • The secret sauce that enables the resurgence of videophones is streaming media technology. Like VoIP, it not only provides for the obvious—video—but it also lets many other functions run concurrently.

  • Although a circuit-switched analog network requires a separate signaling network to route information, in an IP network the packets themselves can take the place of this separate signaling network.

  • The practical implication of follow-me IP is that the employee of a BPV-enabled enterprise needn't pre-establish a presence to conduct business.

  • Streaming media provide the holodeck within which the communications can take place. Flexible IP routing ensures that the virtual experience is available anywhere, anytime, and on any device the user happens to have.


Case Study: KnowledgeNet (www.knowledgenet.com)

Personal interview conducted with Mark Rukavina, COO

Virtualized business process: Distance learning

Company Background

Company Overview

KnowledgeNet is a company whose genesis stems from understanding and responding to competitive market forces and a desire to be more than just another surviving business. Its goal is to be a company that is fiercely competitive, customer-focused, and wildly successful and prosperous.

Growing out of the instructor-led training arena, KnowledgeNet offers its customers online courses 24 hours a day, 7 days a week, 365 days a year. Its focus today is on business skills and technology training for companies of all sizes. Classes are available in both synchronous and asynchronous mode. Inter-student and student-instructor communication is not only supported but strongly encouraged to obtain a solid learning experience. KnowledgeNet's road map for growth, course offerings, and global reach is a wealth of innovation aimed at providing the optimal training experience for business users.

The founders of KnowledgeNet have deep roots in the IT training market, each bringing nearly two decades of experience to their respective positions. Today the privately held firm has over 250 employees, serving 47 of the top Fortune 50 companies. In addition, their online training is available in localized content and languages in 280 countries.

KnowledgeNet, founded in late 1998, is based in Scottsdale, Arizona. It is rated among the top five e-learning companies in terms of revenue.

Network Overview

As shown in Figure 4-2, the KnowledgeNet network has its nerve center at Level (3) Communications, a company that provides a highly secure physical environment. Leveraging an outsourced data center provides KnowledgeNet with the extreme redundancy necessary to support an Internet-based, global operation. By using an outsourced data center, KnowledgeNet is able to obtain peered groups of ISPs, utility power assurance, and fire and surge protection.

Figure 4-2. KnowledgeNet Network Topology
[View full size image]

"What was happening at that time, you have to go back to 1998–1999 when the Internet bubble was just as high and as big as it could be. Everyone demanded 100 percent redundancy, sometimes to the point where they wanted to know if you were SunTone-certified. They were doing audits on your hosted infrastructure to make sure that their IT teams, these are our customers, their IT teams would validate if you had, not only a scalable, but also a fault-tolerant environment that you were going to host their e-learning.

"We could have easily hosted all of our e-learning internally, but we would have had several points of what we call nonredundancy. . . . We would not have had the kind of fire and surge protection that we needed. It was just clear to us that if customers were going to audit us and we needed to have a 24/7, 99.99 percent uptime environment, that we had to go to an external data center. That was a reasonable investment to make.

"Now, some people go to data centers and they have the data center staff manage all of their infrastructure. That is not what we chose to do. We only chose the data center to be the physical facility and to come to the party with all the redundancy that we needed from the ISP, the fire, the security, the electrical, and things like that. We then brought to the party all of our gear we own. We have a team that goes in there and manages that gear. Level (3) personnel never touch our gear, or our cage."

Security

KnowledgeNet's business is based on its intellectual property assets—specifically, training content. The content needs to be secure from theft, but readily available to students. To achieve this complex balancing act, KnowledgeNet uses a layered approach to its security implementation.

At the highest level, the content is hosted at Level (3) Communications. Level (3) protects its customer data against natural, accidental, and man-made service interruptions through resistant routing and tracking systems. The environment is highly redundant, ensuring optimum availability under the most taxing conditions.

At the Internet connectivity level, KnowledgeNet employs the most robust technology available today, Secure Sockets Layer (SSL) and 128-bit encryption. This dual process ensures a safe logon process within the hosted environment.

The next level of security comes from KnowledgeNet's network design. The content in the database is located four levels deep in the network, rather than at the edge. This design prevents attacks, so the databases cannot be hijacked or tricked into jumping to another port, allowing outsiders to listen to traffic and harvest data. This is important to KnowledgeNet because of the sensitivity of not only its own content, but the content its customers also place within the environment.

Finally, KnowledgeNet leverages role-based policy management. Role-based policy management grants differing levels of access to content based on defined credentials. When a user makes a login request, the credentials he provides must make it through each of the four layers and be approved for the level of access requested. This ensures the highest level of protected access is achieved without compromise.

"For businesses to embrace the benefits of e-learning, they must be sure that their e-learning services are built upon the most secure, reliable, and scaleable technologies available. That's why we use the best with everything we do and our technology is world-class."

Management's Attitude Toward Technology for the Business

KnowledgeNet's management's attitude on technology does not leave any room for ambiguity. "Well, it is the lifeblood of our business. I mean, you probably won't find an executive management team on the planet that doesn't appreciate technology more than us. We feed off of that, both internally for our operations, but certainly we preach that even to our external community because we want everybody else to believe the same thing, simply because our product is an e-learning and 100% technology-deliverable."

Going further in the discussion of the role of technology in KnowledgeNet's content delivery, they indicated they have "proven that e-learning as a way to transfer knowledge, as a way to improve skills, is effective. I mean very, very effective, if not better in many, many ways than what we used to traditionally do with bricks-and-mortar classroom training."

It would be safe to conclude that KnowledgeNet is extremely passionate about technology and how it can be used to educate people anywhere, anytime. As an aside, in a separate case study conducted on distance learning for business schools, the founder was equally enthusiastic about the Internet and its education possibilities.

The Planning Process

KnowledgeNet was launched as an e-learning business. Its roots run deep in technology education, with the founders coming from instructor-led and classroom-led training. It was through their previous company, Mastering Computers, that the idea for online training evolved.

". . . understand, a company (Mastering Computers) that began as traditional classroom training, and did that for about ten years. About halfway through the life cycle of that company, which is about 1994–1995, the Internet was born, really, with Netscape going public. We began to see the effect of CD-ROM and Internet-based training on the traditional classroom training business. It basically was eroding it very, very quickly. Startlingly quickly! So when that business was sold, and this new business was born and founded, we were 100 percent from that point forward. We said this is the absolute future."

KnowledgeNet, under the Mastering Computers brand, received pressure from customers to evolve the business to a more cost-effective model for the user community.

"We were hearing it from customers. Customers will always want to save money when it comes to training—at least, corporate will. . . . So customers were asking for it, saying, 'I've heard you can do more with less money with anything technology-based.' "

"At the time, there was no term called e-learning; it was all called CBT or TBT. You know—computer-based training or technology-based training. We also saw just pure demand begin to erode instructor-led training business. We actually saw it in our revenue numbers. It was harder and harder to sell instructor-led training. You had to create as much differentiation as possible, because the gap was narrowing substantially between TBT and ILT. That's what they called it—instructor-led training."

"Those two factors were really the key pressure points. Certainly, you saw the industry, everybody in the industry, talking it up, and talking about it as the next thing. So, the three of those together were too big to ignore."

"So what we did as a classroom-based business, we started to fuel R&D into a division that would, in essence, compete with the other division. Then that business was sold, so this new company called KnowledgeNet was born. We said we are going 100 percent at that point. That was in 1998, October 1998."

A pilot program was set up under Mastering Computers that ran for a year. It included several customers who were interested in dabbling in the e-learning world. These alpha testers received free training courses in exchange for regular feedback on the methodology and implementation of online training.

Decision Metrics for Implementation

  • Customer demand for more cost-effective training.

  • Rapid, measurable drop in revenue starting in the mid-1990s due to Internet browser technology and CD-ROM training capabilities coming to market.

  • Survival in the business of technology training.

  • "We only chose the data center to be the physical facility and to come to the party with all the redundancy that we needed from the ISP, the fire, the security, the electrical, and things like that. We then brought to the party all of our gear we own. We have a team that goes in there and manages that gear . . . insourcing and outsourcing, we took the best of each."

Barriers to Implementation

  • "I would just say that when you go to the world, especially in our world of delivering hosted, Internet-based learning, that there is a lot of capital that is required up front."

  • ". . . you have to traditionally hire a very, very well-skilled staff to make sure that is well managed."

  • "You have got to have best-of-breed software and hardware, and you have to have best-of-breed talent."

Lessons Learned in the Testing Phase

  • "One of the things that we learned we had to change was that we had built a product that only supported Internet Explorer. We knew that we had abandoned Netscape. . . . No one that ran Netscape wanted to download IE. Again, keep in mind, this is 1995. IE had like 25 to 30 percent market share; Netscape had the larger market share."

  • ". . . customers did not want to install anything. You cannot scale an e-learning operation without almost being point-click-and-go easy. . . . Customers gave us feedback that said if I have to get my IT team involved to install, in essence the player or all the components that go with this, then it becomes cost-prohibitive for me to do it."

  • ". . . it needed to be hosted. . . . What happened was that e-learning was either on a CD-ROM, or you had some way to install it on your intranet or your LAN. So they said, we don't want to mess with it."

  • "Everything we do runs on cross-platform, cross-browser, and you don't need anything to run it. So we took even those early feedback points and that is the core of our business today."

Unforeseen Benefits of Implementation

  • KnowledgeNet did not like having to burn CDs and push them out, but it was able to set up a portal, and that saved the cost of the CD as well as shipping.

  • "We, for the longest time, actually physically shipped materials to students. Ninety percent of the class was virtual, but we still were bound to physical kits, if you will. We would ship out physical workbooks, job aids—we even shipped out posters that said 'I am e-learning; leave me alone.' One of the unforeseen things is that now we are going to 100 percent virtual . . . now you don't have to have a physical kit, either. A virtual classroom can be done 100 percent virtually. It meant any kind of aid, workbook, or material that would go along with that class could be electronically distributed. That has substantial cost savings for companies that do as much virtual classroom business as we do per year."

  • "When we first started the business, all of our virtual classroom training was done over a conference bridge for the audio. The visuals were put over the Internet. Most recently, we have made investments into delivering everything over the Internet."

Unforeseen Barriers to Implementation

  • "You have your typical execution hurdles, which means you go through staff you selected that wasn't as skilled as you believed, and you have to replace them."

  • "You always make execution mistakes when you implement technology . . . you get it 80 percent right, you retool the 20 percent, and you keep going on. I would say those normal types of occurrences occurred."

  • "Technology is always moving on you. So if you design something one way, with all available knowledge today, 2 years from now there is probably a different solution that is more cost-effective. Yet you have to weigh the pros and cons of switching to that, or maintaining course. . . . Everything you look at within an infrastructure, you are wondering: Is there something bigger and better out there that is less expensive?"

Future Plans for Business Process Virtualization

  • "We were also able to kind of create a multiplatform environment where we now run all of our e-learning on both PocketPC and Palm. . . . What is interesting about it is that it is all multimedia-rich, just like it is on the desktop. . . . Right now, we have over a thousand courses that we have built in the past that are now available on PDAs."

  • ". . . we are working with content delivery network (CDN)-type devices to make video more high performance based on either regional distribution, which would be by country or even by facility."

Words of Advice

". . . you have got to hire someone very experienced in, someone that is a blend of a CTO and a CIO, but maybe, if you can't afford someone at that level, you need to start with someone fairly senior that understands the mission of what you are trying to accomplish. That person's experience will be the difference between wasting a lot of money, having a lot of failed projects, or not. . . . That person, if they are experienced, has been through all of the pain of doing it wrong and can hopefully make really intelligent decisions. Traditionally, that person is going to have right behind them, hopefully, a couple of key personnel that will follow them into the job. That is key."

"The other thing is, the person will probably standardize on what we just got done discussing, which is, they know how to make IT work to scale and to avoid the pitfalls of being exotic. A lot of people in IT, they get into all these new things when they're not proven. They waste a lot of money, things break, they waste a lot of people's time. It really comes with skilled staff. Skilled staff is where it is at. It is the number one thing, because all good things follow the right people."

ROI

"In our business model, there was no kind of traditional ROI analysis ongoing because it was the entire focus of the business. . . . When we went through the strategy phase of what this business was going to be, we believed that if you are going to create a brand new business, you are either all on board or you shouldn't get into the learning business, because everything in the classroom was going to get demolished in the long run."

"So I mean, there is no ROI there. Certainly we had done business ROI analysis for the following: We are going to spend so much money on hosted infrastructure, we are going to spend so much money on software design, we are going to spend so much money on product, and the ROI is when we cross profitability . . . so our ROI was literally a 5-year investment in the business to hit profitability and then go beyond."


Chapter 5. Capitalizing on a Virtual Presence

Up to this point in the book, the focus has been on the mechanics of the virtualized business. This chapter looks at the physical appearance of a virtualized business. What is occurring within companies implementing virtualized business processes is a sea change for business dynamics. It is the rare person who recognizes a new paradigm. Those who do recognize a new paradigm are the ones who profit from it. This chapter explores some of the characteristics that denote the new business paradigm and provides the means for comparing your business to one that is structured to take advantage of the new technology. This will help you evaluate where your firm is along the BPV continuum.

The virtual business extends the boundaries of its information infrastructure to its virtual employee base. This chapter examines the ways in which the virtualized business interacts with its suppliers and partners, and even its competitors.

First, you need to explore the concept of virtualized presence—telepresence. Telepresence is a term that is used loosely to describe the extension of interaction by networked means. In the case of human-to-human interaction, this means being able to sense, communicate with, and exchange data in a natural, personal way without being in close physical proximity.

In science-fiction films, telepresence usually takes the form of a holographic three-dimensional projection that allows two people to interact in a natural way. Of course, reality hasn't quite caught up with this sophisticated level of telepresence. Such an interaction might never look quite like films present the idea. Nevertheless, BPV technology can approach these fictional notions rather closely.

The key to successful telepresence is bandwidth coupled with role-based policy management. Given enough bandwidth and application utilization control, almost anything is possible. As Arthur Clarke points out in his book 3001: Final Odyssey,[1] if you could transmit one petabit (1015) worth of data in a reasonable amount of time, you could describe every aspect of a human being, right down to the thoughts in his or her head. Of course, in the real world, such a feat is not currently possible—but would we ever want that deep of a level of description?

Telepresence and, by extension, BPV are an exercise in squeezing as much information as possible into a limited bandwidth delivery channel. As noted in the preceding chapter, this is fundamentally a problem of compression. However, on a higher level of abstraction, it also involves the problem of deciding which aspects of presence are required to adequately represent a human-to-human interaction most effectively.

The problem of bandwidth capacity and distance has been addressed in the past. When early telephone engineers were presented with the problem of designing analog networks to carry voice traffic, they were also presented with the limitations of forcing signals over copper wires over long distances. It turns out that a pair of copper wires, when extended a sufficiently long distance, begin to look less like conductors and more like phase-shifting elements such as capacitors and inductors. Worse, the distortion is highly frequency-dependent; consequently, different parts of the signal are affected differently. Just increasing the signal's strength doesn't work, because that just amplifies the distortion.

Telephone network designers decided to limit the bandwidth of a voice signal to 3000 Hz. Doing this allowed them to place coils along the path of transmission that would correct the distortion that the wires themselves introduced. This solved their problem but introduced a different problem for us as we attempt to transmit fast data streams over these same wires.

Our problem is, of course, significantly more complex. We not only have to decide what portion of a voice channel we will transmit, but also what portion of a video channel and what portion of a purely data channel we will include. Put another way, we need to decide what portion of a complete person we will transmit, not just his or her voice.

It turns out that, just as early voice pioneers discovered, it is possible to simulate a presence using far less bandwidth than the human senses are typically used to processing. The key is to identify what is truly required and then exclude everything else. Put another way, bandwidth utilization is managed by exception. For most telepresence interactions, it is sufficient to have a voice channel and an information channel of sufficient capacity to allow a reasonable facsimile of directly connected applications. Usually this is in the range of 250 to 500 Kbps, which conveniently also happens to be in the range of most digital subscriber line (DSL) services. If additional bandwidth is available, incorporating a video channel can add considerably to the sense of presence, but typically this is not required for basic telepresence.

If you're familiar with the Webex service, it provides a good example of a typical telepresence experience. As shown in Figure 5-1, in such an interaction, it is possible to conduct a conversation over a phone with a remotely located person and concurrently see what he sees on his computer screen. In most cases, the voice component is provided over the Public Switched Telephone Network (PSTN), but as illustrated in the preceding chapter, such a call can also ride over the same data channel.

Figure 5-1. Virtual Presence

Telepresence, then, is possible using networks that are available today and involving technologies that are also readily available. Using nothing more complex than a DSL pipe, or a cable delivering high-speed bandwidth, or, in many locations, a satellite dish, almost any location on the globe is now accessible with sufficient bandwidth to enable a telepresence session. What does this mean to the virtual business?


Telecommuting

Consider the dynamics of a typical day for the average employee functioning under a conventional business model. If you are like us—or, we should say, as we used to be—you get up early so that you have sufficient time to get to the office. After you get up, there is a mad scramble as various family members attempt to access the bathroom. Stress levels rise as everyone meets in the kitchen to gulp down some breakfast, prepare lunches, and generally get organized to head out.

When preparations are complete, you head for your car so that you can battle traffic for an hour or so as you head into work. At the end of the workday, you drive the same path back, where you spend a few frantic hours cooking dinner, dealing with the kids, and psyching yourself up to do it all over again the next morning. Is it any wonder that most people who die from heart attacks usually do so just before they go to work or shortly before they come home? Does anyone in HR notice this?

The fact of the matter is that a typical business cheerfully puts its most critical assets in jeopardy twice a day during commuting just so that they can be concentrated in a building, ostensibly to improve efficiency. This kind of behavior can be very risky for a company that depends on the production of intellectual property. The production of intellectual property is, of course, the foundation of most companies nowadays.

Commuting also is risky from the standpoint of impact on employees. If an employee consumes up to 2 hours each way to get to and from work, his or her real workday is nominally 8 hours plus 4 hours, or 12 hours. Add an hour for lunch, and the workday is 13 hours. For companies that depend on employees working more than a nominal 8 hours, the loading increases to the point of unreasonableness in short order. It is ironic that many companies trumpet that their employee body is their most important asset. If that were true, they would pay more attention to their use. Even copiers in some businesses have more downtime than many critical employees!

The solution, of course, is to not commute. We can hear the protests already. There is a notion among many firms that the only way for people to interact is for them to gather around the water cooler and chew the fat. We even had a boss once who refused to hire some of the best consultants precisely because they were located remotely and therefore couldn't come into the office.

Of course, telecommuting is one of those simple-sounding solutions that rapidly achieves complexity when you try to implement it. For many managers, the hurdle that must be overcome is too high. Even managers who consider themselves very forward-looking and innovative seem to have a hard time when they can't see their employees working.

This condition is a cultural one and will not be easily overcome. However, if you consider that technology can deliver an interactive experience that is similar in many respects to that of physical colocation, the prospect of a telepresence is easier to accept.

Consider the attributes of physical interaction. People separated by cubicle walls usually do not directly interact so much as they shout over the walls periodically. Managers who expect to see their people working don't really walk around and watch them working. For the most part, even in a physical environment, managers check on their people through e-mail or by phone, and workers interact using the same methods. Where people do require a lot of direct face time, there is usually a sound reason, such as manufacturing processes.

If you reduce a physical work environment to the interactions it enables, it is easy to see that many of these interactions can be facilitated by simulated presence. For managers who only feel comfortable watching their people work, a simple webcam application and streaming video might be a solution that lets them actually watch an employee. Of course, we wonder how most employees would feel about such an arrangement—maybe pretty good if they could watch their boss in return!

The telepresence we are advocating is enabled by the application of intelligence, bandwidth, and utilization management tools to deliver the important aspects of physical presence to an employee who might reside down the street or on the other side of the planet.

Historically there have been two key problems in delivering bandwidth to remote worker locations:

  • Availability of broadband access

  • Security of the network

These issues might have been problems at one time, but through technical progress they have been overcome. Figure 5-2 illustrates the impact of telepresence. As big business migrates to a virtual network-enabled environment, centralized facilities shrink, and employees tend to work where they are most comfortable doing so.

Figure 5-2. Virtual Workplace

Broadband service is now available to virtually anyone willing to make even a nominal effort to get it. You can choose from DSL service, cable service, satellite service, wireless technology, and the more-exotic digital delivery services such as ISDN and Frame Relay. For those whose jobs depend on having reasonable access to the Internet, there are multiple ways to do so.

The issue of security is a little more complex. The question for virtual businesses is how to simulate the same secure environment on the Internet that exists behind bricks-and-mortar for the physical business.

The answer is that such virtual environments must be secured. As discussed in the preceding chapter, virtual private networks (VPNs) are fundamentally an exercise in security management. Likewise, managing telepresence is an exercise in user access management.

Access management is the capability to ensure that authorized personnel are given access to the applications, documents, and resources needed to perform their jobs, no matter where they are located or over what medium they are attempting to achieve access.

This can be a complex undertaking. Fortunately, access control can be managed using the right technology. Cisco's Architecture for Voice, Video, and Integrated Data (AVVID), for example, provides very robust user access control. Security, whether data security or access security, is one area where the virtual business needs to build and maintain strong competency. Unless the workspace is secured, the business is not viable. Just as you would not set up business on a street corner and put all your wares on display without someone looking out for petty thieves, in a virtual business, you do not place all your data on display for all your competitors to review.

The trick is to apply technology in such a way that the ideas of access and data security can be applied quickly and easily. You can limit the space that needs to be secured in two ways:

  • Implement virtual LAN (VLAN) technology.

  • Build a portal through which users must pass to access your business.

The following sections examine each of these approaches in more detail.


VLANs

This section assumes that you are familiar with LAN technology. VLANs push the physical limits by extending the concept of locality.

LAN technology was invented to connect resources in a local environment to achieve interconnection of workers to share files, applications, and devices such as printers. This works fine when the environment to be interconnected is rather small or when it is mapped over a fairly small geography. Problems arise, however, when the number of users increases to more than a few hundred or when the environment over which services will be delivered encompasses large geographic areas.

The problem is with the Ethernet technology that is commonly used in the local environment. Ethernet is based on the carrier sense multiple access collision detect (CSMA/CD) protocol. In this protocol, the equivalent of a digital mob scene is refereed according to who can yell when no one else is yelling. Everyone else quiets down and lets the yeller yell until he runs out of breath. Then someone else yells. But what if there are so many people trying to yell that there is hardly any quiet space? Or, just as bad, what if the distance between two people yelling is so great that neither side can hear the other one yelling? Figure 5-3 illustrates this process: Everyone is on the same line, talking at once.

Figure 5-3. The Problem with LANs

These problems occur only when the yelling parties are in the same logical environment. If technology is applied to subdivide the environment into smaller chunks, these situations are mitigated. In practice, this is accomplished by placing routers or intelligent hubs or switches in the network architecture.

By inserting devices designed to subnet the networked environment, you can segregate serving areas so that smaller groups contend for yelling space and so that geographically separated groups or individuals don't have to wait for the echo of distant yellers to talk.

The beauty of a subnetting device is that, although a LAN is on one side, any kind of network can be on the other side. As far as the local participants are concerned, the device is a singular instance representing all the other possible participants in the local environment. The subnetting device talks to any other subnetting device, separated sometimes by extremely long distances. The local devices and users are unaware of the device's location. Figure 5-4 illustrates how subnetting allows you to segregate the load so that fewer users are contending for the same line.

Figure 5-4. Switching to Achieve a VLAN

This concept of switching between subnets or LANs not only solves the problem of contention on Ethernet-based networks but also provides a means of extending the network to any location that is connected to the switch. When combined with access control, so that only authorized entities can access the switch from the far side, the virtual business has a way of extending its network to employees as well as business partners, suppliers, and customers. The application of VLAN technology is called an intranet when used within the company and an extranet when connecting the supply chain or business partners.

Intranets

Intranets, as the name implies, involve the application of VLAN technology to achieve an extended LAN environment within the virtual corporation. Intranets tie together LANs that are physically separated by extreme distances. They also can extend the LAN to a single individual working from home. In the case of the latter, the VLAN is set up to use a VPN connection.

In the case of VLANs that interconnect separated offices, several transmission technologies can be used to provide bandwidth. These include such things as ISDN, leased T1, and fractional T1 lines, but an increasingly popular method is Frame Relay.

Frame Relay is a way of packetizing bandwidth into frames of characters. From the user's point of view, however, the Frame Relay connection appears to be a data transport channel or permanent virtual circuit (PVC) that is presented at a particular committed information rate (CIR). Although the available rates vary, a typical CIR for a carrier-provided Frame Relay PVC is 64 kbps. For office-to-office connections, Frame Relay channels can be stacked to achieve as much as a T1 rate each way, or 1.544 Mbps. If higher rates are desired, dedicated digital rates might be necessary, but they come at a higher cost. Figure 5-5 illustrates how a Frame Relay-based network cloud can allow multiple local environments to operate as though they are one giant LAN.

Figure 5-5. Intranet Architecture

The virtue of an intranet is that rather than managing a WAN with all the complexities that can entail, a virtual business can manage its data communications as though it has only a single virtual LAN to worry about. All the backbone interconnections can be outsourced to the carrier or service provider that provides them. Such an outsourcing arrangement can be managed through contract.

From the employees' point of view, the intranet makes it possible to be located anywhere with network connectivity and still have the same access that a person in the main office has. This can be as complex as access to the same enterprise resource planning (ERP) or customer resource management (CRM) applications, or it can be as simple as access to the same shared files. Combined with collaboration software, telepresence can be achieved.

Intranets extend the enterprise's physical boundary to incorporate any point on the network that requires access to corporate systems. In principle, there is no reason why such access can't be extended to other companies through extranets; this, of course, comes with its own complexities.

Extranets

One of the hot topics during the dot-com bubble was the notion of business-to-business (B2B) transactions. Such interactions were to have significantly reduced the cost of such functions as subcontracting and supplier-consumer relationships. In some cases, this occurred. In most cases, though, the technology wasn't as well-developed as it needed to be to make the process work smoothly. Since then, the technology has matured. In particular, web portals have simplified B2B relationships substantially.

Extending the business environment to other businesses is called extranet technology. In an extranet, the virtual business is made available, with appropriate safeguards and security, to other businesses and customers who might need to access the virtual company. Amazon.com and BarnesandNoble.com are two familiar examples of business-to-customer (B2C) extranets. The case study at the end of this chapter discusses how ARUP Laboratories uses extranets to support its expanding business in the pathology laboratory market. Figure 5-6 illustrates how the concept of extranets in effect increases the proximity of geographically separated businesses.

Figure 5-6. Extranet Architecture

Although extranet access can be hard wired in much the same way that an intranet can, in most cases such connections are needed only periodically. The problem then becomes how to provide the appropriate connectivity when required without having to pay for a connection that is used intermittently. The Internet provides the approach that works best in practice.


Webification and Portals

The World Wide Web addresses the problem of how to access networked data in a user-friendly manner. Before it enabled technologies such as HTML, the Internet gave a select group of technophiles access to data through such esoteric means as FTP transactions. However, with HTML-based web pages, a new kind of interaction was born—one in which you didn't need to know precisely the location of the file or the format in which it was stored. Data is now accessible to even the most nontechnical user in a graphics-friendly format.

When this concept of web-based data is extended to interactions between companies and with customers, it is clear that an extranet can simply be the entire Internet, and access can be managed through a web page. When selected functionality is combined with access control, the web page can be a gateway through which both suppliers and customers can link to internal systems to conduct real business.

Business applications, though, are rarely built to interact with the web seamlessly, so some translation is required to facilitate this connectivity. Increasingly, business applications are becoming "webified." That is, they are being mapped to an HTML-enabled interface that presents a graphical user interface (GUI) that is compatible with the web format. When this is done, a business application can interact directly with the Internet using its own URL, or it can be hot-linked to an entry site that directs the user to the appropriate URL. In either case, all that is required to use the application is a web browser.

When a single gateway allows several applications to be accessed through the same website, the result is a portal. Using a portal can simplify the application and administration of security. Only authorized users can access the secured URLs for the desired applications. Figure 5-7 illustrates how such firewall technology can secure the network that exists behind it.

Figure 5-7. Web Portal

When a web-based portal is implemented using good security, the result is a virtual business presence that can be dynamically extended to employees, customers, and suppliers. In a sense, the portal becomes the business's bricks-and-mortar. However, unlike the physical infrastructure-based business, sites can be built, expanded, contracted, and torn down in near-real time as needed. A nominal additional cost is required to expand, and no write-off is needed to downsize. The business facilities become highly elastic.

By using the Internet as the basis on which to build extranets and intranets, the virtual business avoids the physical plant and real estate costs and overhead associated with doing business. Although the cost of IT can be considerably more than for a purely physical business, the economic impact can be dramatically different. (This subject is explored in more detail in Chapter 8, "Financial Implications of BPV on Conventional Businesses.") If the infrastructure is outsourced, even the cost of the more-intensive IT environment can be ameliorated. This idea is explored in the next chapter.


Summary

  • A sea change for business dynamics is occurring within companies implementing virtualized business processes.

  • Telepresence is a term that describes the extension of interaction by networked means.

  • The key to successful telepresence is bandwidth coupled with role-based policy management.

  • Consequently, telepresence and, by extension, BPV are an exercise in squeezing as much information as possible into a limited bandwidth delivery channel.

  • As early voice pioneers discovered, it is possible to simulate a presence using far less bandwidth than the human senses are typically used to processing.

  • Telepresence is possible using networks that are available today and involving technologies that are also generally available.

  • If you reduce a physical work environment to the interactions it enables, it is easy to see that many of these interactions can be facilitated by simulated presence.

  • The question for virtual businesses is how to simulate the same secure environment on the Internet that exists behind bricks-and-mortar for the physical business.

  • Access management ensures that authorized personnel are given access to the applications, documents, and resources needed to perform their jobs, no matter where they are located or over what medium they are attempting to achieve access.

  • Security, whether data security or access security, is one area where the virtual business needs to build and maintain strong competency.

  • VLANs push the physical limits by extending the concept of locality.

  • Intranets can tie together LANs that are physically separated by extreme distances or can extend the LAN to a single individual working from home.

  • Extending the business environment to other businesses is called extranet technology.

  • When selected functionality is combined with access control, the web page can be a gateway through which both suppliers and customers can link to internal systems to conduct real business.

  • When a single gateway allows several applications to be accessed through the same website, the result is a portal.

  • When a web-based portal is implemented using good security, the result is a virtual business presence that can be dynamically extended to employees, customers, and suppliers.


Case Study: ARUP Laboratories, Inc.

Personal interview conducted with Doug Ketchum, senior network and systems administrator

Virtualized business process: Supply-chain business-to-business using VPNs

Company Background

Company Overview

ARUP Laboratories, headquartered in Salt Lake City, Utah, was established in 1984 as an independent, full-service reference laboratory. ARUP's association with the Department of Pathology at the University of Utah Health Sciences Center allows the laboratory to act in a supporting and expanded testing capacity for localized community laboratories.

The ARUP business model emphasizes support of other testing laboratories. Its clients include community hospitals, university teaching hospitals, multihospital groups, major commercial laboratories, group purchasing organizations, military and government facilities such as VA hospitals, major clinics, and major pharmaceutical firms.

Managed health care and the economy demand timely services that shorten hospital stays and reduce costs. Under newly implemented HIPPA regulations, security and privacy of test results and transmission of reports have become more stringent. The ARUP automated core lab, customized business affiliations, and comprehensive information technology infrastructure all point to a firm that has planned for the future of reference laboratories and pathology medicine leveraging secured technology as part of its business strategy.

Network Overview

ARUP Laboratories connects to most of its clientele through secured, redundant VPNs. There are a few customers that continue to use dialup modem connectivity as the primary means of communication with ARUP, but there are plans under way to migrate these accounts to VPN connectivity as well. The migration decision is based on a number of factors, with one of the leading driving metrics being compliance with HIPPA legislation requiring increased security in patient information exchange.

The LAN at ARUP Labs is a flat Layer 2 environment consisting of approximately 1500 nodes. The flat LAN is a function of the continued use of the Digital Equipment Company's LAT protocol, a nonroutable protocol. LAT is critical to a core process within the lab; therefore, a change to an IP-based protocol would be extremely difficult and challenging. Figure 5-8 illustrates the ARUP Labs network topology.

Figure 5-8. ARUP Labs Network Topology

At the core of the network, ARUP has redundant Cisco Catalyst 3640 routers. These routers connect to the WAN as well as the ARUP LIS system server. The firewall sits between the server and the wide-area network.

ARUP has implemented Cisco VPN 3005 and 3015 concentrators. Again, the design is redundant and built with failover capabilities. For security purposes, the VPNs run parallel to the firewalls. Putting VPN traffic through the firewall leaves ports open, potentially exposing ARUP to malicious activity.

The VPN concentrators and the firewall each have direct connections to the Catalyst 3640 routers providing access to the wide-area network and the Internet.

Security

Security is a significant concern at ARUP Laboratories due to government regulations within the medical industry. It is crucial that medical test results and patient information be treated as confidential. The LAN-to-LAN connectivity via VPN technology assists ARUP in meeting its security concerns.

Management's Attitude Toward Technology for the Business

ARUP's management's technology attitude evolved over the course of 5 or 6 years. Much of the attitude change was rooted in customer demand for improving communication methods. Historically, lab tests, test orders, and test results were sent and received either through fax or modem. As the Internet stabilized and TCP/IP became an industry standard, the push for technology solutions increased. Customer demand was rooted in expediting information flow as well as improving accuracy of the communication between the laboratory and its customers.

Management's attitude toward technology was also influenced by ARUP's growth as a reference laboratory. The company has seen steady double-digit growth in both new customers as well as specimen processing over the past 5 years. The strategy for handling the increase in volume had to be improved in order to continue to meet the quality of service ARUP clients had come to know and trust.

Cost pressures and demand for rapid test result turnaround also contributed to the evolution of ARUP's management's view on technology. Managed care places a strong emphasis on speed as a means of reducing costs and cost containment. ARUP's role in expediting information and lab results to doctors plays a critical component within the managed care system.

". . . about 5 years ago, maybe 6 years ago, we probably only had a dozen servers that processed our data besides our primary LIS system. We had a very small network with a couple of small Cisco 2500 routers. The consensus back then was it (technology investment) was a necessary kind of evil. We don't like to spend money on this stuff, but if we have to, I guess we will.

"We have grown at about 20 percent a year for quite a number of years, possibly more than that this past year. As we've grown, the necessity for infrastructure to drive the data and to house the data, and to supply data to our clients and to receive data from our clients, has just grown tremendously.

". . . traditionally it (technology) has been looked on as something we don't really want to do . . . we will only spend the money that we absolutely have to. Now it (technology) is being looked on as: We are trying to be at the leading edge of the technology to be able to supply the needs for our clients as well as having . . . bleeding-edge technology for in-house."

The Planning Process

ARUP Laboratories' planning process to implement business-to-business VPN technology began approximately 3 years ago. The process was driven primarily by customers requesting a more efficient way in which to work with ARUP to place test orders and receive test results. Prior to the VPN implementation, business was conducted via fax and dialup modems, two processes that require a significant amount of monitoring to ensure completion.

"Most of our clients have been requesting VPN solutions—TCP/IP connections so that they don't have to watch it, watch the process and make sure that things happen. They just know that it happens automatically and they are notified if it doesn't work for some reason. So, our clients were probably the primary driving force . . ."

ARUP looked at a variety of VPN implementation methods, including server- and software-based solutions. They settled on Cisco's hardware solution for several reasons:

  • "Cisco has got, I felt, better interfaces."

  • Cisco has a solid VPN solution for working in a heterogeneous environment. "I thought they were more solid, way easier to work with when we had to look at implementing LAN-to-LANs with other vendors like CheckPoint and Nortel."

  • The Cisco solution is more scalable, an issue that ARUP needed to be concerned with based on its steady growth.

  • ARUP did not have strong in-house expertise and needed the vendor to provide pre- and post-sales support. "If we have a problem, I know I can get Cisco TAC on the phone, and they will solve it. That was also a very key point and at least part of my choice."

Decision Metrics for Implementation

ARUP Laboratories went through an extensive 3-month test bed with WebMD, an ARUP Laboratories customer. The test bed was set up using VPN hardware from a company that was eventually acquired by Cisco Systems. In addition, a competing technology was also set up for testing and side-by-side comparison. After extensive problems with the second firm's technology, including scalability, technical assistance, and ease of use, ARUP elected to go forward exclusively with the Cisco solution.

The decision to utilize VPN technology was driven primarily by ARUP's customers.

  • ". . . the decision metrics really came from the client side . . . it was a client push to start becoming more automated . . ."

  • ". . . business metrics was driving it (the VPN implementation), the relationship with the clients."

  • "Customer care . . ."

Barriers to Implementation

  • "The biggest anticipated barrier was a lack of experience on our part and on our vendor's part."

  • ". . . a lot of misconceptions and a lot of misunderstandings about them (VPNs)."

  • "There were some barriers there to be overcome and how it was implemented and whether or not we were going to put (the hardware) behind our firewall, or whether it was going to be parallel to our firewall. There were quite a number of discussions on the format that the network structure would take before that implementation took place."

  • ARUP's IT staff met with several different VPN vendors. Each vendor introduced its own ideas for infrastructure design required for a successful VPN implementation. Part of the barrier to implementation was the confusion caused by these differing schemas and their potential impact on ARUP's security requirements.

  • "One implementation that a lot of companies use . . . was punching a hole through our firewall, then putting the VPN concentrator behind our firewall. . . If you have to punch a hole through the firewall, it just makes your firewall that much more vulnerable. The VPN concentrators do a much better job at filtering out unwanted guests, I guess, than the firewall does."

Lessons Learned in the Testing Phase

  • ". . . several of the things that we kind of figured out was that we had to understand, we had to have a mutual understanding of what was going to be accessed on both sides of the network. One of our biggest problems initially was recognizing, from a VPN standpoint, that the VPNs had to specifically know exactly which parts of whose network they were going to be talking to; otherwise, it created problems."

  • "The other problem was the actual implementation of it, of the hardware platforms. The thing that . . . I personally learned from that is that there is a lot of confusion in the network world out there about how this stuff works. So, because of that, setting these things up can be anywhere from a 10-minute job to a full-day job, depending on the level of expertise on either side."

  • Platform flexibility and ease of implementation modification were important during the testing phase. ARUP needed to move forward because of customer demand, but they also needed to be sensitive to emerging security regulations. ARUP did not look specifically at the product itself, but examined more closely the vendors behind the products. "I would have to say, honestly, that the HIPPA wasn't the biggest factor there; it was actually looking at the ability of the vendor to back us up. Having the expertise to really help us do whatever we thought we were going to need to do in the future with it."

Unforeseen Benefits of Implementation

  • "I think it (the VPN implementation) has increased our exposure in our industry."

  • "We have been named one of Fortune 500's top 100 companies to work for in the United States."

  • ". . . because of the way we are doing business, and the business process virtualization processes that we are using, it makes it much easier for people to become our clients. We give faster turnaround time, better results."

  • "We port our results directly out to web pages, so our clients can log in and see patients' results almost real-time. I think that is all due to our business process virtualization, being able to get the data in and out of the necessary systems quickly."

  • "We have seen, over even the 9/11 stuff, when everybody was having a struggle . . . we picked up 90 new clients because they were unsatisfied with how their current labs were processing their stuff. We were able to handle and manage their specimens and get their results back to them in a timely manner. Being able to do this has really driven our business."

Unforeseen Barriers to Implementation

  • ARUP did not experience any unforeseen technical barriers to its VPN implementation. This was based on the extensive testing performed with the WebMD test bed.

  • The greatest barrier ARUP encountered, and continues to encounter, is its customers' level of technical expertise to implement their end of the VPN. ARUP's technical staff has provided light support to some of its customers to ensure the correct data is accessible for both parties and data communication is accurate.

Future Plans for Business Process Virtualization

  • In its next steps to virtualization, ARUP Laboratories is looking at additional ways to enhance its customers' experiences and to expand business opportunities.

  • "We are looking into videoconferencing currently as something for some of the business development area. . . The voice over IP we have talked about. We really are not at the point where we are ready to consider that yet."

  • "We currently have a small wireless platform now, and we are using that primarily for intrusion detection for wireless devices, to see if people have PDAs and things like that that they are trying to transmit data in and out. We probably will be implementing some network-wide wireless stuff . . . down the road."

  • "We have a business plan . . . we are actually looking at a terminal server type of scenario. Where we have a terminal server that has all the programs that they would need to process and then basically kind of a smart box there that would talk to that terminal server. . . There is less downtime, less overhead for having to keep the stuff up and running . . ."

Words of Advice

". . . my best advice would be just to really look at the overall management of the business process virtualization versus not having that kind of infrastructure in place. From my point of view, the business process virtualization makes the management of everything much easier. As I said before, it allows us to wear a lot of hats, that we do wear a lot of hats. I think the business process virtualization is part of the thing that allows that. Some of the things that we have done have freed us up. I am not spending all of my time troubleshooting things like modem lines and why people can't get through.

"Other things we are doing for our business process virtualization is we implemented a SAN. We put in a SAN this year, and we are moving a lot of our servers to that and consolidating servers so we have less pieces of hardware to manage. We can move that hardware off to a platform where if we need to dynamically allocate more storage space to it, it is easy to do it rather than having to reformat RAID arrays and move it to a different platform and the process.

"The whole process of virtualization is, it is a pretty big encompassing thing when you are talking about the entire business, but I think in the long run, if you look at it from a management point of view, it is really the only thing that makes sense to be able to keep your costs down and be able to grow your business cost-effectively."

ROI

Establishing a return on investment for ARUP's VPN implementation was not a priority for the laboratory. The implementation was rooted in customer demand, business decisions, customer retention, and customer care.

"ROI, I don't think, was factored in—at least not from our standpoint. We were told by our interface department, we need to do this. They did ask us the cost, but they didn't really say yes or no on what the cost factors were.

". . . you look at it from a big picture and the cost of the hardware and the personnel to really run it, and that is just really part of what it is going to take to do business now . . . without those things, our cash flow would be dramatically different."


Reference
Amazon


Endnotes

  1. Clarke, Arthur. November 1998. 3001: Final Odyssey. New York: Random House.


Chapter 6. Capitalizing on Outsourcing

Outsourcing is a term fraught with strong emotions for the IT manager. IT has had a love-hate relationship with outsourcing for many pendulum swings. It started with service centers in the mid-1960s, continued through the application service provider (ASP) infatuation, and now manifests itself as managed service providers (MSPs) and full-service outsourcers. The concept of outsourcing has always been to reduce costs by allowing someone else to provide an IT service rather than doing it in-house. Although there have been arguments over the impact that outsourcing strategic capabilities would have on a company's viability, there has been remarkably little discussion about the true impact on company profitability.

Outsourcers would argue that by reducing capital and operational costs by reducing equipment and the number of people on the payroll, a company could reduce expenses and maximize net revenue. Until recently that was an assertion built strictly on a comparison of direct labor costs to outsourcer billing.

On the other side of the argument are the IT professionals. These people tend to point out that outsourcing hemorrhages critical skill sets that are necessary to maintain the business's viability. Outsourcing has generally been perceived as a threat by IT personnel, who, with some evidence, point to the loss of jobs as a consequence of outsourcing engagements. This argument is further substantiated with the increasing rise in near-shore and offshore outsourcing.

Within the parameters of measuring the benefits and drawbacks of outsourcing, both sides might be correct, but not for the reasons they have touted. At least, both sides have some empirical support for their assertions. However, the reason that outsourcing is a good idea and, if done properly, should pose no particular threat to IT has less to do with the idea of pure cost containment and more to do with a simple idea: You should only employ personnel to perform high-return work. In the capitalist world, margin is everything. If an employee can only point to maintaining an application as her contribution to the company, she is not producing enough value, and she should be doing something more productive with her time.

Of course, naysayers might argue that the application in question could represent a significant competitive advantage. The reply to this argument could be that competitiveness based on keeping a volatile intellectual property asset such as application software from your competitors is not worth a hoot. In such a case, the application is probably a proprietary custom application with high-maintenance requirements and an inordinate demand for resources in the form of staffing and funding.

Unless a process's benefit is demonstrably greater than its cost, it is not worth the company's effort to support it internally. Ultimately, the custom application should be abandoned for one that is more cost effective in terms of ongoing maintenance and support.

Naysayers would also argue that there might be functions that are so critical to the company, and that are so costly to perform effectively, that the company has no choice but to perform them internally. This argument is flawed. When this argument is used, it is almost always true that a company has chosen a technology path that is not sustainable. An example is building a complete accounting system on PCs running the old CPM operating system. After a period of time, the cost to support such a structure is excessive, but the application is overwhelmingly important. What is called for is a reassessment of the underlying technology before the viability of outsourcing is determined.

In essence, the virtual business's goal is to streamline and commoditize as many business processes as possible to maximize the benefits of the process. This is true whether the process is identified as a core process to be developed and supported internally or a context process to be turned over to a third-party provider.

IT is mainly in business to perform two functions:

  • To develop automated solutions to enable a business to move more quickly in the market

  • To maintain the solutions it develops

Of these two functions, the first is critical. The second function is superfluous because it is a service function, and someone else can always deliver services cheaper.

The outsourcing community got this part of the equation correct. As noted, they build their service offerings on return on investment arguments that focus on cost savings. The missing component of the outsourcing argument, though, is the idea that just because you are outsourcing the support function, you shouldn't forget that you have to develop the automated solutions first.

This is where IT personnel are justified in their skepticism. They instinctively understand that you need to plan and design automation in-house. Where they fall on their swords is when they debate cost savings with the outsourcers. Worse yet is when CIOs try to build competitive IT organizations that seek to beat outsourcers at the cost game. It is inevitably a losing proposition, and it totally ignores the high value obtainable from an IT staff that is focused strictly on building business value and then outsourcing the support of its solutions.

The automation architectures are the true intellectual property that confers great value on a corporation. This intellectual property shouldn't be left to outsourcers—in fact, it cannot be. No outsourcer, regardless of the fervor with which it preaches strategic partnering arrangements, can ever understand the business of the business as well as employees can.

So how do you use outsourcers effectively? Part of the answer is that you must understand your business better than anyone else. If you are depending on an outsourcer for business expertise, you have already lost the competitive battle. You must decide what your business is, and what its key intellectual property is, long before you approach an outside contractor.

As soon as you have articulated what you do, you must look at everything else as a potential outsourcing opportunity. Then you must carefully select the outsourcers you use and be prepared to manage them closely. How do you do this?

This chapter discusses the process of leveraging outsourcers to maximize the effectiveness of the virtual business. You will learn about effective management and identify the signs that you might be either underusing or overusing outsourcing. But first, the discussion begins with an analysis of why you would want to use outsourcing in the first place.


Why You Don't Want to Manage 100 Percent of Your Infrastructure

As noted previously, the new paradigm for business can learn a great deal from the previous paradigm. In the bricks-and-mortar world, there are few examples anymore of companies that actually own the office building in which they reside. Most companies lease building space. This confers many tax advantages, provides a flexible use of space, and drives costs down. Companies can use the buildings until they outgrow them and can delegate the management of the buildings to qualified professional building managers. Of course, there are significant exceptions, such as manufacturing concerns, but for most professional companies, the standard mode of operation is becoming one of leasing office space rather than buying it.

A virtual business runs in much the same way. Rather than managing the virtual bricks-and-mortar infrastructure on a day-to-day basis, that functionality is left to professionals who do that exclusively. Why is this a good idea, though?

Think for a moment about the virtual business. It is characterized by a virtual infrastructure based on networked technology that simulates a physical workspace that can be worldwide in its scope. The implication is that the office building for a virtual business is merely a perceptual condition enabled by a technological layer. As you have seen, that layer of technology is first and foremost comprised of network technologies, overlaid with applications and virtual work environments. Just like the building that the bricks-and-mortar business occupies, this technical infrastructure must be managed. It must be maintained, cleaned, repaired, and modified as needed to maintain the business's work environment. However, unlike a physical business, these tasks represent a much larger overhead on business.

For a typical office building, owned or leased, the overhead associated with maintenance and management rarely exceeds 10 percent of the property's value annually. On this budget, the building can be maintained practically forever without significant problems. Now think about a data network. The relative cost to maintain the network compared to a building is significantly higher. This is because, unlike the building, the network is a living organism, constantly changing. In response to increasing packet loads, aging operating systems, changes in desktop and server configurations, viruses, storage requirements, and so forth, the network is constantly changing. The network is dynamic. Within a very short period of time, a networked environment can become unstable to the point of failure.

For most companies, the consequence of this unstable dynamic is the maintenance of significant IT organizations. These IT organizations are nominally in place to engineer new automation to support the business. In reality, most IT groups spend the majority of their time maintaining the automation that is already in place. When IT uses the majority of its time acting in a maintenance capacity, it changes what could be a competitive advantage into a liability or overhead.

In addition to the pure cost of personnel to maintain and troubleshoot the network, there is also a need to evolve it in response to changing business needs and conditions. Every release of a new operating system or a new virus protection application, every new employee or new business application, requires changes to the networked space, consequently taking even more resources. In addition, every network is based on technologies with remarkably short lifetimes. As technology becomes obsolete, it must be replaced to maintain a competitive edge. However, tracking which technology is aging, and staying current on new technologies as they are introduced, involves more overhead and also involves a continuing investment in hardware.

This is like moving into a building that immediately begins falling apart. During the course of your occupancy, you are forced not only to maintain it, but also to rebuild it into a completely different building. And you have to do all this while trying to be profitable.

Of course, this isn't to say that companies can't and don't build effective networks that they then maintain. It is just that to do so, the company invests considerable resources that it could invest elsewhere. It is not atypical for a business to invest as much as 50 to 100 percent of the initial cost of the networked infrastructure annually to keep it current. During economic downturns, the ratio drops considerably, but the point is that it shouldn't if the network is to remain viable.

As IT budgets are squeezed, executives are congratulating themselves on their ability to do more with less. In reality, they are doing progressively less with less. Within a short period of time, these companies will discover that they are actually doing nothing with nothing. Networked infrastructure operates on a much different cost dynamic. It will always be more expensive than a conventional infrastructure—that is, it will always be more expensive if a company insists on developing and maintaining everything itself.

This last point explains why outsourcing works in the first place. Support for networked infrastructure does not scale linearly; it scales at a rate much less than that. The reason for this has to do with the technology itself. In a networked environment, automation can be applied to the management of that environment. Although in most cases this management automation is expensive and complex, it also simplifies support to the point that a few people with a relatively low level of training can manage a very large, geographically dispersed network.

As you are probably thinking, management technology is available to enterprises as well. Anyone who is in the business of networked automation should be using a variety of management technologies. Nevertheless, it is also true that an enterprise cannot afford to acquire, learn, and apply the best management technology as well as keep it current. Again, there is a diminishing return for companies to do so. For outsourcers, the story is substantially different.

Because an outsourcer is in business to support networked environments and is also in business to manage a large number of such environments, technology that could not be justified for a small, medium, or large enterprise network can now be justified for a metaenvironment. Another way to look at this concept is that a particular management technology in the hands of an outsourcer can be spread across many more users and networks than a dedicated one can.

So how do you select the components of the networked infrastructure to be outsourced? Do you outsource it all? To that we will now turn our attention.

As explained earlier, IT has two essential missions for the enterprise:

  • To plan and design automation in support of business objectives

  • To maintain and support those automated solutions

As previously noted, IT too often falls into the trap of day-to-day support and ignores or avoids the first mission altogether.

This dichotomy of purpose provides the first clue as to the degree to which a company should want to outsource. As shown in Figure 6-1, outsourcing is actually a continuum rather than a point in space. It can extend from none at all, where all functions are performed in-house, to completely outsourced, where everything is outsourced. We suggest that neither extreme is fiscally healthy. Although most people would argue that a little is okay and a lot might be problematic, we would counter that the opposite also is true.

Figure 6-1. Outsourcing Continuum
[View full size image]

If IT is doing its job, its primary focus should be on automating business process solutions. IT should constantly be looking at business processes to find ways to improve, streamline, and virtualize the workflow. As soon as these opportunities have been identified, the next step is to build, stabilize, and document the new automation so that it can be turned over to an outsourcer for ongoing maintenance. If the IT department is doing this, it is clear that cutting-edge solutions should be developed, maintained, and supported in-house, and routine ones should be outsourced. Although ratios might vary slightly, we believe that this is a situation in which the 80/20 rule should apply. The internal IT group should support roughly 20 percent of the networked infrastructure, and approximately 80 percent should be outsourced. The internal IT department should direct the management of 100 percent of the infrastructure.

If this is done, an interesting thing occurs: Rather than being thought of as a cost of doing business, IT becomes a strategic asset. Its focus changes from an operational one (support) to a strategic one (development). Not coincidentally, IT's cost dynamics change as well. Because outsourcing provides the day-to-day support for most networked automation, the consumers of such a service can be billed directly. This, once and for all, gets IT out of the business of budget enforcement. Currently, most IT shops are servicing an unlimited demand with a limited budget—hardly a prescription for success.

It goes without saying that such a dynamic must be carefully managed. Because a virtual business is only as successful as its networked infrastructure allows it to be, the network must be safeguarded and secured.


Ways to Safeguard Your Business Infrastructure

IT must direct the management of 100 percent of the infrastructure regardless of who is actually supporting it. This is the principle safeguard for the business when using outsourcing. IT's role must evolve from operations to management. Expertise must be held in the virtualized business in the area of technology application. How is this done in practice?

A business, whether virtualized or not, must control its means of production. In the case of factories, this means managing the production line to produce the goods that are the company's output. In a virtualized work environment, the same notion holds true; however, in this case, someone else is actually running many of the virtualized production facilities.

Of course, the challenge in selecting an outsourcer is to discover what it is good at doing and to have it do only that. Many outsourcers might try to sell the notion that they can manage every aspect of the outsourced process. A few outsourcers, such as IBM Global Services, Electronic Data Systems (EDS), and Computer Sciences Corporation (CSC), can do this. A large percentage of managed service providers, though, are unable to provide a holistic end-to-end solution. The demise of Marc Andreessen's Loudcloud, and its ultimate absorption by EDS, should be viewed as the poster child of what was fundamentally wrong with the initial foray into managed services. The concept of "all things to all companies" rarely flies.

Service providers that are stable, even during times of economic turmoil, have optimized their expertise within a particular vertical market or technology. It is through this extreme specialization that they can add significant value to their customers' outsourced processes. For example, a specialized outsourcer can anticipate its customers' needs or process change requirements before the customer is aware of the requirement, because the outsourcer has deeper and wider visibility into the overall market segment. What is needed is an outsourcer that is tightly coupled to IT management.

In such a situation, IT provides the day-to-day oversight of the outsourcer to ascertain that the outsourcer is doing its job. This includes being able to look over the outsourcer's shoulder using automated management technology. This does not mean that IT must build a parallel operational oversight capability. It just means that IT should have real-time access to the appropriate information and should have someone whose job it is to monitor the quality of the outsourcer's support services.

IT should be in the thinking and development role. This means that as new automation is developed and deployed, there needs to be a close coupling with outsourcers. Just as strategic initiatives need to be informed by operational realities, IT needs the operational perspective of the outsourcer. All deployment plans should be verified and approved by outsourcers, especially if outsourcers will ultimately take on support for such initiatives.

Figure 6-2 shows this linkage. As you can see, there is a natural evolution from prototype to deployment to support. In each instance IT and outsourcing work together to ensure that the technology is under control and managed appropriately. IT, however, is in charge at all times.

Figure 6-2. Outsourcing Process

One key characteristic of outsourcing over the past several years has been its volatility. ASPs have all but disappeared from the market. Horror stories abound, and continue to circulate, concerning companies that jumped on the outsourcing bandwagon as an early adopter, only to be dumped by their service provider when it went bankrupt. To a large extent that is why outsourcing has such a bad reputation with many business managers, and why it is never a good idea to place strategic functions with an outsourcer.

So how do you safeguard yourself and your business from outsourcing volatility? The answer is twofold:

  • Always do your homework when selecting an outsourcer.

  • Never place all your outsourcing eggs in one basket.

You must think of the outsourcing relationship exactly as you would a potential business acquisition. You must insist on conducting the same level of due diligence. Does the outsourcer have other customers? Who are they? What was their experience? Is the outsourcer willing to disclose its financial situation and provide documentation? Who manages the company, and what is their experience? All these questions and more are appropriate when you are betting the ongoing success of your business on the relationship.

The second point about outsourcers is that you should never think in terms of using just one for everything. Just as a single source of supply for manufacturing rarely makes sense, Deming notwithstanding, in an outsourcing environment, multiple providers offer some measure of security against the untimely demise of one of them.

Multiple outsourcers also come with problems. When services are fragmented among multiple providers, the complexity of management is increased. IT must stay on its toes to control a multiple outsourcing environment. Again, this is an argument for a different kind of IT—one that places it in the role of primary contractor rather than backhoe operator.

Another way in which outsourcers can compromise the business is in the area of intellectual property control. When an outsourcer has access to a business's production environment, there exists a real possibility of leakage of confidential company information. Although it would be nice to be able to implicitly trust any outsourcer, reality is much less enlightened. Intellectual property, customer lists, and financial information have all been known to leak through an outsourcer. Most security breaches are because of hackers penetrating improperly secured sites; however, sometimes the outsourcer either maliciously or intentionally leaks information.

In the case of information security, tight legal controls are the only appropriate way to ensure control. As an adjunct to contracting services from an outsourcer, there needs to be an extensive security implementation to safeguard the intellectual property. Coupled with a layered approach to security, appropriate penalties must be incorporated into the contract should the security arrangements be violated. We strongly advocate remedies with real teeth. If the business is the networked infrastructure, and if it is compromised, in our opinion, the outsourcer has just bought the business. Anything less is unacceptable and fails to acknowledge the importance of a virtual infrastructure.

Finally, reliability is an important part of security. If an outsourcer cannot guarantee a specific level of service, the company's ability to generate revenue can be seriously compromised. Service Level Agreements (SLAs) must be realistic and must be tied to real penalties when they are violated. If an SLA does not recognize and impose penalties comparable with the true cost of downtime, the SLA is worthless in a virtualized business environment.

All this might sound overly hard on outsourcers, but we don't think so. The time is long past when an outsourcer was a technician with a server in his basement. For virtualized businesses to work, implicit trust must exist between the company and the outsourcer. The market has no place for outsourcers who are unwilling to meet this expectation. BPV absolutely rests on the reliability of the infrastructure, just as a bricks-and-mortar business rests on the reliability of its infrastructure. A virtualized business with untrustworthy outsourcers is like a physical business trying to operate in a half-finished skyscraper: It can get a little chilly.


How to Select an Outsourcer

We touched on the process of selecting an outsourcer in the preceding section by noting that the first important thing to do is to ask lots of questions.

A number of questions need to be answered when evaluating outsourcing solutions:

  • How long have you been in business?

  • How many customers do you have currently? May I talk to them?

  • May I see your financial statements?

  • Do you have experience with companies like mine? With systems like mine? With applications like mine?

  • Does outsourcing include acquiring my IT employees?

  • How are your charges computed? What are your plans for charges in the future?

  • Do I pay extra to manage the process?

  • What is your biggest failure to date? Why did it happen? How will you prevent it in the future?

  • What do you consider to be a change request?

  • How will I transition your services back into my company?

  • Do you sublet any of your services?

These questions range from the obvious to the particular. Allowing an adequate amount of time for the due diligence process is critical to establishing a long-term, successful relationship with a service provider.

The process of selecting an outsourcer can be thought of as another decision model—one that has a great number of costs and benefits that must be evaluated. This decision model can be summarized as shown in Figure 6-3. As illustrated, costs can involve not only the obvious ones, but a fair number of costs associated with management functions. Remember, the use of an outsourcer imposes overhead associated with oversight. In fact, the cost side of an outsourcing decision is almost always more extensive than that quoted by the outsourcer.

Figure 6-3. Decision Model for Selecting an Outsourcer

The benefits side of outsourcing was described earlier. It has the obvious benefits of capital and operational expense reductions; however, it too has some soft benefits. As shown, business benefits are associated with time to market and revenue generation.

This decision model, aside from establishing the costs and benefits on a theoretical basis, also provides parameters on which to evaluate prospective outsourcing vendors. Each vendor should be evaluated on how well it is likely to be able to support the desired benefits, and to what extent the identified costs will be minimized. Each vendor should be able to explain, in excruciating detail, how it will benefit as well as bill your firm.

Because outsourcers must integrate tightly into your business, you must also determine to what extent the outsourcer will be able to do this. It is one thing to say that you will work closely together, and another entirely to do so effectively. Many outsourcers are not organized for comprehensive integration, and many others are not anxious to conduct business in this way. You should ask for references where the outsourcer has tightly integrated with its customers, and you should check them.

The final selection criterion is one that is difficult to put into words, because it is an emotional dynamic. It would be easy to say that the test is whether the relationship feels right, but it is a little more profound than that. An appropriate outsourcing arrangement is a melding of cultures. If the outsourcer's culture doesn't feel comfortable, there will be a significant amount of settling in before the arrangement can work effectively. If this period is protracted, your company will pay for a mismatch with time and aggravation. Can you afford the price?


Summary

  • The concept of outsourcing has always been to reduce costs by allowing someone else to provide an IT service rather than doing it in-house.

  • Outsourcing has generally been perceived as a threat by IT personnel, who, with some evidence, point to the loss of jobs as a consequence of outsourcing engagements.

  • IT is mainly in business to perform two functions. One is to develop automated solutions to enable a business to move more quickly in the market, and the other is to maintain the solutions it develops.

  • The automation architectures are the true intellectual property conferring great value on a corporation.

  • The virtual business is characterized by a virtual infrastructure based on networked technology that simulates a physical work space that can be worldwide in its scope.

  • Because an outsourcer is in business to support networked environments, and is also in business to manage a large number of such environments, technology that could not be justified for a small, medium, or large enterprise network can now be justified for a metaenvironment.

  • The internal IT group should support roughly 20 percent of the networked infrastructure, and approximately 80 percent should be outsourced. The internal IT department should direct the management of 100 percent of the infrastructure.

  • Just as strategic initiatives need to be informed by operational realities, IT needs the operational perspective of the outsourcer.

  • You must think of the outsourcing relationship exactly as you would a potential business acquisition.

  • If an outsourcer cannot guarantee a specific level of service, the company's ability to generate revenue can be seriously compromised.

  • BPV absolutely rests on the reliability of the infrastructure, just as a bricks-and-mortar business rests on the reliability of its infrastructure.

  • The process of selecting an outsourcer can be thought of as another decision model—one that has a great number of costs and benefits that must be evaluated.

  • This decision model, aside from establishing the costs and benefits on a theoretical basis, also provides parameters on which to evaluate prospective outsourcing vendors.


Case Study: InfoWorld Media Group

Personal interview conducted with Chad Dickerson, CTO.

Virtualized business process: Desktop and server management

Company Background

Company Overview

InfoWorld Media Group (InfoWorld) is a division of IDG, a world-renowned technology, media, research, and event company. InfoWorld Media Group was launched in 1978 to provide in-depth coverage and evaluation of IT products for technology experts involved in major purchase decisions for their companies.

InfoWorld provides its constituency a number of venues to obtain breaking IT news, technology comparisons, and focused research information. These venues include print media, online distribution, and targeted trade shows. InfoWorld is not just a provider of technology information; it is a heavy user of technology as well. With staff and contributing writers spanning the globe, getting breaking news into the newsroom and out to its readership in a timely manner is crucial. There is no time or patience for technology glitches.

In April 2001, InfoWorld hired a new chief technology officer (CTO). In an effort to understand the current state of the network and user satisfaction levels, the CTO had a survey conducted of InfoWorld employees. An appalling 49 percent indicated they felt the service levels they were receiving were poor or fair, the lowest levels available on a scale of 1 to 5.

In the same time frame, InfoWorld Media Group was beginning to experience the first ripples of the faltering economy with a substantial drop-off in advertising revenues and subsequent budget slashing. The CTO was faced with a broken IT infrastructure, dissatisfied users, and a centralized IT team in a world of distributed users who were inadequately tooled and trained to support the existing environment. Serious changes needed to take place that addressed improving support service levels for all the users at a price point that was below the current IT budget. To achieve these objectives, InfoWorld turned to business process virtualization through a managed service provider.

Today, InfoWorld looks to its managed outsourced service provider, CenterBeam, to keep operations up and running at peak performance. InfoWorld is able to retain its focus on delivering solid, timely information to its audience without having to worry about the background technology implemented to support its operations.

Network Overview

InfoWorld's network is geographically dispersed. It consists of a central office, six remote offices, and 15 home offices. In addition, the journalists frequently travel to cover trade shows and industry events. Secure, reliable remote connectivity is a must-have for this highly mobile workforce.

More than 75 employees need to have their desktop and laptop devices supported. Antivirus software needs to be embedded into the devices and maintained to ensure intellectual property security. Furthermore, a large number of applications need to be kept up to date, patched, and integrated.

CenterBeam brought the InfoWorld environment from a cluster of disparate operating systems and applications to one of consistency and standards-based, improved overall user satisfaction, as well as improved collaborative efforts and the fruits of joint projects.

Security

Security is a pervasive issue across InfoWorld's networked environment. Much of the staff is mobile but needs to communicate regularly with the corporate facilities regarding a variety of sales activities, event planning, column submittals, and a host of other activities in the media, research, and event marketplace in which InfoWorld participates.

Before InfoWorld used CenterBeam as an outsourcer, the intranet VPN was unreliable and was perceived to be broken beyond the technical capabilities internally available to InfoWorld. Furthermore, many of the remote users did not have reliable antivirus functionality installed on their desktops; they were exposed to potential attacks of all kinds.

InfoWorld was able to address its wide-area connectivity security issues by turning to an outsourced service provider. "A company like CenterBeam simply has more people who are highly specialized in dealing with VPN and WAN connectivity."

Management's Attitude Toward Technology for the Business

Executive management's attitude toward technology enables or hinders the IT department's ability to optimize technology in meeting business objectives. The more open management is to technology as an enabler, the easier the migration path to business virtualization.

The management team at InfoWorld was on the fence regarding technology as a company asset over a cost center. "We report on technology, so we weren't necessarily viewed completely as a cost center, because we write about the strategic value of technology. There is an understanding of that. But on the other hand, as a publishing company, we are somewhat of a cost center because we are not selling a technology product, necessarily. As a media company, InfoWorld produces a magazine and a website and other services about technology."

At InfoWorld, the management team started out a bit leery of executing on its help desk virtualization strategy; even the CTO was initially skeptical. By keeping an open mind and a willingness to explore all options, as well as conducting extensive due diligence, the results of virtualizing the help desk have been positive for the firm. "I wasn't a fan of outsourcing, at all, before this particular experience. When your back is against the wall and you have x amount of dollars to accomplish a particular goal, then you just have to look at it differently and see what else is possible."

InfoWorld has virtualized a variety of functions, outsourcing them to a handful of different service providers. As the firm moves along the virtualization path, management's attitude has evolved to a more positive position regarding technology. "CenterBeam is . . . one . . . spoke in a giant wheel of many different things that have improved. So, I think, CenterBeam was part of a set of good choices."

The Planning Process

InfoWorld conducted extensive planning and testing prior to a complete rollout of its outsourced desktop and server management. They took the opportunity to upgrade supporting functions and processes that feed into desktop and server management—specifically, the directory services related to authentication. Info-World had already started migrating its directories, so "it actually made sense to match up the back-end servers that our client machines were logging in to with the standardized desktops."

Prior to actual rollout, InfoWorld went through 6 weeks of evaluating its network and understanding exactly what was running where. After the network evaluation was completed, it moved into 4 weeks of extensive testing. "So we tested and tested and tested, every key application, every key function of everything. Then, when we were satisfied, we did the rollout."

The actual rollout was conducted over several weekends due to the highly geographically distributed nature of the InfoWorld networked environment. ". . . the first rollout was our main office, which was probably 75 percent. We did that over one weekend. Then the next weekend we did some of the branch offices and home users, and then the next weekend we completed the branch offices and remaining home users."

Decision Metrics for Implementation

InfoWorld had three core decision metrics they used in determining whether to implement the virtualized desktop and server management solution.

". . . it was cost, user feedback . . . the vision of the vendor. I talked to CenterBeam, I talked to another [outsourcing] company. . . . I took a quick look, although I didn't really engage with larger companies . . . which handle outsourcing in a more traditional way. I was looking at the technical direction of the company and whether I thought their vision was good or not . . . whether or not I thought, based on their technical vision, they could actually do what they were saying they could do."

Barriers to Implementation

  • "The big barrier was getting people used to picking up the phone and calling a number and understanding that someone could remote-control their machine and help them solve a particular problem and not actually be there. So, dealing with people who are virtualized to the point where you never actually see them—just basically dealing with voices on the phone. I think that made some people uncomfortable."

  • ". . . the fundamental problem is the virtualization aspect. The technology exists to deal with these issues virtually, but people like someone physically standing in front of their computer."

Lessons Learned in the Testing Phase

  • "We found a lot of people running applications that weren't really the kinds of things you would want on a corporate network . . . music applications and file-sharing applications and things like that. We dealt with those. It didn't really slow us down; we just had to make a policy change that these things are not supported—which actually helped our bandwidth quite a bit."

  • "We did run into some legacy applications that didn't run on Windows XP, but none were critical to the operation of our business."

  • "CenterBeam's inventory was so thorough and so organized that we found applications and, frankly, business processes that we didn't know existed."

  • "People in finance were using software to clear credit cards . . . for business services that we were offering. We weren't aware of that. We . . . put a better process in, and something that made more sense. Something that was . . . easier to monitor. There were lots of things like that . . ."

  • "In doing this, we really turned everything upside down and took a look at everything. It was actually a big help. We weren't really expecting to go through that sort of business process review, but we ended up reviewing some things."

Unforeseen Benefits of Implementation

  • "We did such a thorough analysis in the beginning that I felt like we got everything that we wanted and the service is actually better than I expected."

  • "It wasn't really unforeseen, but it was good to see, that this fairly large population of people who weren't in our central office, 25 percent of the company, suddenly had the same level of service as everyone in the company."

  • "Application awareness across the company was determined to be definitely a benefit."

  • "Actually, just plain standardization across the whole company. In the workplace, when two people are using different versions of Microsoft Word and they are giving each other hints on how to do things, it doesn't always work. It is kind of a soft benefit, but the fact that people are all on the same page technology-wise, it really helps. They can help each other a bit more."

Unforeseen Barriers to Implementation

  • InfoWorld did not experience any unforeseen technical barriers to its desktop and server management virtualization. This was based on the extensive testing InfoWorld conducted for each application and business process prior to rollout.

  • ". . . the hardest thing to deal with was just the mental shift that people had to make from having internal, onsite help to having a number to call."

  • "There were a lot of doubters in the company who were trying to find holes in the way things worked."

  • "The virtualization concept and calling a phone number and not having someone there were really the roots of all issues."

Future Plans for Business Process Virtualization

  • To date, InfoWorld has executed on numerous virtualized business processes, including a hosted website, sales force automation, support for its messaging environment, Macintosh support, and a prepress publishing system.

  • ". . . in general, it's just a mantra in my IT group: We need to be able to fix anything from anywhere. Everything we are doing is focused on remote management and redundancy, and when one of our employees needs to do something, we don't necessarily know where they are, but we need to give them the means to do whatever they are doing securely."

  • "We don't really have a business process virtualization plan, but the way we have been doing things, it is really just implicit in everything we do."

Words of Advice

"Spend a lot of time talking with the people in your company that will be affected and explaining to them really the whole idea of what business process virtualization is, but in plain English. Explain to them how the needs that were being met via some other method will just be met differently."

"You need to focus on the technology, like we did with CenterBeam, and be comfortable that it will work and understand all of the details of how it will work before you actually turn it over. Just because you are outsourcing doesn't mean you don't have to understand how it all works."

"The key thing is you are dealing with people, and people are often more comfortable dealing with people face to face. When you go to a more virtualized environment, that face-to-face interaction goes away. It doesn't mean that you cannot accomplish the goals that you were trying to accomplish."

ROI

"We saved at least 30 percent on support costs in the first 12 months of the engagement. A really key point with the way CenterBeam operates is the utility pricing model, which is per . . . person per month. So, in a company that is getting smaller, as a lot of companies have been in the past couple of years . . . if ten people leave the company in a month, then you stop paying for ten seats to CenterBeam the next month."

"For example, if you are doing internal help desk staffing, and you have 100 people, ten people leaving leaves you with 90. Internal help desk staffing is just not as efficient in terms of cost. But with CenterBeam, when you remove ten seats after ten people leave the company, 10 percent of your costs go away. Whereas [with the internal staffing model] you have to figure out how many help desk people you need to support 90 versus 100. You might not be able to make your help desk smaller by one person until you get to 75, because going from 100 to 90 might not be enough to reduce headcount."

"If I graphed our employee population with our desktop support cost, the lines would run parallel to each other, which just isn't possible in a traditional support model."


Chapter 7. Internal Security Implications of Managing the BPV-Centric Company

The discussion up to this point in the book has focused on the virtues of virtualized business, including coverage of many of the enabling technologies, applications, and business arrangements that provide the infrastructure to conduct business in a virtual environment. A recurring theme that has run through each of these discussions is security. This has included securing access to the logical infrastructure of the business (both raw data and intellectual property) and the transmission of data from one point to another.

Security is the essential enabler that allows a virtual business to operate. As you have seen, security at the fundamental level enables technologies such as VPNs and portals. Security in the form of encryption ensures that data streams that are integral to the virtual business remain inaccessible to outsiders. Security in the form of identity management functions in a need-to-know manner, ensuring that users have access only to the information they need to do their jobs.

Security, though, above the fundamental level has a profound impact on the conduct of the virtual business as well. As you will see in this chapter, most service provisioning can be reduced to security. Security, as a pervasive enabler for virtual business, is known as Confidentiality, Integrity, and Authorization (CIA). CIA should be in the forefront of managers' minds when they are contemplating virtualizing a business process.

This chapter explores the multiple aspects of access control and how the virtual business can use this concept to manage its personnel and data resources to flexibly adapt to changing market forces. The next section begins with a discussion of internal security.


The Importance of Internal Security

Suppose your virtual business has just created significant new intellectual property. This intellectual property is a new method of analyzing business processes that will revolutionize the creation and management of technical work teams. Its value is significant to your company and confers on you great competitive advantages over your competition. Because your business is virtual, this process will be applied in consulting engagements by personnel who function in a temporary or less-than-full-time capacity. The dilemma you face is that, when an engagement is finished, how do you ensure that your intellectual property will not leak out?

Of course, one way to control the inappropriate disclosure of your trade secrets is to execute complex and binding contracts. Of course, you would do this to some extent anyway. However, a contract merely gives you the right to sue when a disclosure has taken place. An employment contract, although designed to prevent intellectual property leakage, cannot guarantee that no leakage will occur. This situation is highly unsatisfying to a firm, especially when you consider that it is unlikely that it will ever recover damages sufficient to both make you whole and ensure that you can continue to use your intellectual property profitably. Generally speaking, once the damage has been done, it is irrevocable.

Even more problematic is the idea of internal leakage of information associated with different customer accounts. If you are in a position to know trade secrets of different, competing clients but would violate the confidences you have established with each of the clients, you must have some way of ensuring that such secret information will not leak within your business processes or systems.

Managing information is at the core of a virtual business. Any dynamic that would tend to expose this information to either unauthorized internal personnel or external agencies can rapidly diminish or destroy the viability of the virtual business. As shown in Figure 7-1, security threats can come from a variety of sources. For a virtual business to survive, it is important to have processes and technology in place to manage each of these threats.

Figure 7-1. Security Threats to the Virtual Business

The virtual business is exposed to the same sorts of internal and external security threats as a conventional business. These include such things as intellectual property theft, industrial espionage, and employees' malicious deeds. However, the virtual business, because its intellectual assets exist in virtual space and can be accessed using networked technology, suffers from unique threats such as intrusion, hacking, flawed software, spamming, and viruses. Also, because the information is stored electronically, there is the danger posed by corruption or sabotage.

Virtualized businesses do not need to concern themselves with regionalized security issues that a conventional business must address when developing business continuity plans. Regionalized threats include acts of nature, fire, power outages, and a host of other unforeseeable situations that affect both security and business continuity. A virtual business, like the Internet, is ubiquitous; it is not at risk of localized threats to continuity.

The unique security threats that virtual businesses experience arise from the nature of generating value in virtual space. Value is created when intellectual property is applied to solving a problem. Anything that would compromise the intellectual property degrades the value.

When the intellectual property is generally known, there is no particular reason for anyone to seek it out. When the intellectual property is corrupted, its ability to solve a problem is likewise corrupted. Intellectual property is the most important asset of any business, but especially so for a virtual business, where the emphasis on capital is minimized.

Of course, network security is a well-known idea. Virus protection (to protect data integrity) and firewalls (to ensure that willful penetration of the virtual business does not occur) are in general use. If you are not running similar technology on all your systems, you are courting disaster, regardless of whether your business is virtual.

However, in the virtual business, securing the enterprise takes on additional importance and involves much more extensive measures than simple firewalls. Because an employee of today can easily become the competitor of tomorrow, and vice versa, the virtual business must manage security in a dynamic environment rather than in an environment that can be assumed to be static for a significant period of time.

How is this done? The concept can, at first, be daunting. If the process is so complex that only a few firms can accomplish it, the concept of the virtual business might seem somewhat irrational. However, the good news is that technologies exist to facilitate the control of access and data integrity in a virtual space. To these we now turn our attention.


Safeguarding the Company's Intellectual Property

The virtual business must implement a way to ensure that a flexible employee dynamic does not compromise the company's essential information assets. This is accomplished through the compartmentalization of information so that those who need specific information can access it, and those who don't have a need for the information can't access it.

Compartmentalization is a concept that is familiar to anyone who enjoys spy films. The idea is that when you don't know who might be an enemy agent, you set up information access so that only people with a demonstrated or predetermined need to know can use classified data. This principle is equally valid for the virtual business. In fact, it's more easily accomplished than the spy films would have you believe.

Compartmentalization is accomplished in two ways. In the first method, business processes are applied so that projects are never under the exclusive control of temporary employees. Every business has permanent employees. The virtual business is no different. In the case of a virtual business, however, the number of permanent employees is minimized. The full-time employees are responsible for managing the company's work flow. Their job is to see that customer needs are satisfied and to divide the work so that the appropriate talent accomplishes each task.

The second way to compartmentalize intellectual property is to make a conscious effort to ensure that when the talent that is applied to a project is not a full-time employee, that employee is not vested with all or a substantial piece of the company's intellectual property. Temporary employees should be assigned specific tasks within their skill set. In addition, temporary employees should be constrained with the appropriate nondisclosure agreements to ensure that anything they do learn about internal intellectual property is appropriately controlled.

In a conventional business, this approach is usually sufficient to prevent major leaks of information. However, in a virtual business, where an adept technician could wreak havoc when allowed behind the firewall, additional security steps are required.

The first added security step is to use technology to ensure that only data specific to a discrete task is accessible electronically. This ensures that as tasks are defined, the data that is necessary to perform each task is directly linked to that task. In the case of an engineering function, for example, if developing a widget is defined as the task, all information that pertains to widgets would be made accessible. However, information on thingamajigs would not be accessible—unless, of course, some of that information was necessary for the task at hand.

The second step is associated with levels of abstraction. Whereas a first-line technician might need detailed information on a widget, a process control manager might only need to know what a widget is and how it corresponds to the larger project of building a washing machine, for example.

These tasks might seem pretty reasonable when only one project is underway and when full-time employees can take the time to completely map out security control for the project before it starts. However, we live in the real world, where there is never enough time and where many projects are always going on at once.

As noted earlier in this book, a virtual company is made up of a core team, with the majority of employees acting in a free-agent capacity. All projects are owned by a member of the core team. Various members of the team may own components that make up the project, allowing them access to specific resources and information, but never access to the entire company knowledge base. In this way, knowledge management is directly tied to the level of project responsibility.

It turns out that managing security in a virtual business is essentially a problem of managing complexity. As shown in Figure 7-2, this problem can grow exponentially as the company's business grows.

Figure 7-2. The Complex Web of Security Control

Happily, technology is available to manage this complexity. Two technologies currently in use and supported with Cisco solutions are directory-enabled policy-based management and role-based access control. The issues with policy-based management and role-based access control are somewhat different in practice, so we will address them separately.

Directory-Enabled Policy-Based Management

How does a typical business figure out what needs to be done when and by whom? If you have any experience with small businesses, you know that the answer is to make lists. Lists exist for inventory, for employee tasks, for revenue earned, for bills to pay. Some small-business owners seem to run around with dozens of lists.

It would be nice to think that as businesses mature, they do away with the lists, but that isn't the case. The lists just become more sophisticated. Originally, automated data processing (ADP) was applied to business to manage the enormous lists that had developed to service payroll and accounting functions.

A virtual business has the same lists, but it also can minimize their management. It does this by building a hierarchy of lists. Each business process has lists associated with the tasks that need to be done, the people who need to do them, and the information available within the company to do them. Each of these lists is built as a directory to that particular resource. To find out what applies to any task, you just look at the directory and see what is being referenced.

The beauty of building lists into directories is that it is easy to change a directory reference. If a particular employee needs to be applied to a task, it is easy to insert an entry into the task directory so that the task now points to that individual. If the person needs to be plugged into the company's business systems, these directory attributes can easily be changed so that the task itself authorizes the appropriate access. With a little care in defining systems and directories, such directory structures can enable complex processes.

For example, suppose the company defines a task. Several employees are assigned to the task, and several contract or part-time employees are engaged. As soon as the employee resources are defined, the directory is modified so that each existing employee has access to the task workspace. New employees are allowed to access HR functions such as payroll and benefits so that they can be compensated appropriately. Based on the security rating of the temporary employees, only certain company databases can be made available to them.

In practice, such sophistication evolves over time, moving from VLANs based on floor or department to directory services based on policy. This security evolution also moves the company from a task-based orientation to a process-focused one. It is easy to see that for simple functions such as securing the company against intruders, an HR system can trigger security to issue passwords and specific access rights. More importantly, an HR system can trigger security to revoke passwords and access rights.

Technologically, most of this functionality has evolved around a particular standard known as Lightweight Directory Access Protocol (LDAP). Although other methods have been tried, LDAP has become the de facto industry standard. LDAP has the virtue of being relatively easy to build into database products and other applications. It ensures that directory tasks are uniform across all directory-enabled functions. This makes building the security management arrangements for virtual business fairly straightforward.

LDAP has the virtue of being built to enable web-based searches from a wide variety of platforms. Unlike the directory standard on which it was based, and which has been in use for years in the enterprise (X.500), LDAP was designed to have a much smaller footprint and to incorporate security from the start. As a consequence, LDAP-enabled directories can be built to accept queries from authorized clients for specific information types. LDAP directories may contain many domains of information but can be set up to provide access to only certain areas based on predefined access arrangements, as shown in Figure 7-3.

Figure 7-3. LDAP Directory Structure
[View full size image]

LDAP directories can also be set up to reference other LDAP-enabled directories. In this way, very complex data structures can be defined that incorporate various levels of security and access. Thus, it is possible to allow employees to drill down to only a specific level of granularity based on their function or role within the company. Returning to the example at the beginning of this chapter, this might allow a widget engineer to access very specific widget information while allowing administrators to access only higher-level constructs. This can all be accomplished in the same data structure using LDAP.

This brings us to the subject of how, in practice, these directories can be defined to allow this kind of discriminatory access. In the physical world the process of defining who gets access to what company resources and information typically falls within the realm of HR and Legal. This asset allocation involves developing and enforcing policies.

A policy is nothing more than a statement of who gets to do what and who doesn't get to do it. Put more simply, and somewhat less flippantly, a policy is merely a statement that defines access. When defined in this way, it is clear that a policy for a virtual business can be set up as a rule in a directory. In fact, policies can be defined dynamically. Whereas a physical company is relatively rigid because its policies are defined to last and are changed infrequently, a virtual business process is characterized by its ability to change quickly and in response to external conditions. This is done through policy management.

Policies can be defined to allow specific personnel to access specific data types, applications, and databases. The beauty of this process is that policy management in practice can be as simple as setting up another directory. As policies are defined, changed, or appended, this can be done as a modification to a directory-enabled database. Policy management becomes a function of business need and can (at least theoretically) be quite simple.

We say "theoretically" because policy management can actually be quite complex and can require the talents of a data architect. However, the process of building and maintaining directory structures can be far less complex than what goes on in a physical enterprise, with compliance and enforcement procedures, extensive staffs, and documentation.

Most network equipment vendors provide policy engines to simplify the process of building and maintaining policy management structures. Many of these engines are special-purpose policy-management systems pertaining to specific domains, such as the network element level. However, some policy engines have a wider range of applicability and can manage policies into the application space. These include some enterprise resource planning (ERP) applications.

Of course, technology marches on. As LDAP and policy structures are beginning to gain general acceptance within the industry, newer technologies that embed many of these concepts are emerging. One, Extensible Markup Language (XML), attempts to control access through smart documents that contain their own executables and access controls. This can extend to encryption as well. The difficulties associated with determining exactly how to do this in practice, perhaps between companies as well as within company structures, is just now being addressed by such companies as DataPower.

Whether a firm chooses directory-based policy management or an XML approach, a common difficulty remains: defining access policy in the first place. Policy is easy to talk about but hard to do. It usually involves someone acting as a referee to determine who gets access to what and how much. It goes without saying that such policies must be made before the technology is deployed. The result, otherwise, can be executive warfare, with the technologist put in the position of enforcer without authority.

One of the simplest policies in concept, but most complex in practice, has to do with resource and information access based on job function or role.

Role-Based Access Control

Who gets access to what company information and resources? It's a simple question, but one fraught with ambiguity. Should every executive have access to everything? Or should there be limitations based on responsibility? In other words, should a person's role define access to important intellectual property, or should access to such resources be based on identity? Consider the corruption and ethical bankruptcy that have come to light within so many companies. Corporate piracy has taken place over the past decade because top-level executives have had unrestrained access to all the company jewels. Discussions of limitations on access often lead to emotionally charged discussions.

In a physical business, the process of access is simplified and strengthened through the fact that it is easy to restrict access to physical facilities based on personal recognition. It is easy to assert access restrictions when you issue keys or ID badges coupled with biometrics and guards to verify them. In a virtual business, the issue is less clear-cut. In a virtualized business, identity can be different from role. When workspaces are defined by passwords, it is harder to debate exactly what those passwords should unlock. Most personnel find it reasonable to expect access to everything on a network.

The virtual business can use policy-based management to ease the tension involved in defining resource access arrangements. This is done through the application of role-based policies. It works as follows.

Suppose John is an engineer working on the widget project. Sally is a project manager working on the same project. Sally is also a contract worker who has been hired in a temporary capacity to manage the project flow. When Sally was hired, she was loaded into the HR system, which through directory updates allowed her to access the project workspace and task-level details for each of the engineers, including John. Her level and responsibilities define the kinds of task-level access she will have. This policy was predefined and is automatic based on her role in the organization. When she is added to the payroll, the only specific information required is her title, the project she will be working on, and the specific workgroup she will be joining.

John, on the other hand, is an engineer and a full-time employee. His access is defined by his role. If he should change job functions, the HR staff would load his new title and definition into the HR applications, which would then adjust his pay and accessibility to company resources.

As you can see, employees' changing roles constantly redefine their access privileges. The entire virtual infrastructure can be modified to deliver exactly the kind of support that is required for each individual and project as the company's needs change.

What if an employee leaves the company? Again, the employee's role defines the access. In this case there is no role in the company, so there is no access.


Quality of Service

As discussed previously in this book, quality of service is also a function of great concern to the virtual business. One of the beauties of applying a policy-defined access arrangement to the networked infrastructure is that this application can be extended to states of partial access.

If you consider resource access to be a continuum from total access to total denial, it can also be correlated to levels of service quality. For example, e-mail can be delivered instantly or not at all, but it can also be delivered in defined intervals. Likewise, access to networked resources can be delivered with greater or lesser degrees of quality. These levels of quality can be defined by policy.

Getting back to our example of Sally and John, John might need high-quality voice services and high-speed delivery of CAD drawings. This facilitates his job and can be defined as implicit to accomplishing his tasks. Likewise, Sally might need virtually instant access to project-management software but might not need any access to video teleconferencing. Consequently, quality of service can be defined within the context of access and can be delivered using the same access infrastructure that is used to secure the company's intellectual property.

The beauty of security in the virtual business is that it can be expressed as a continuum of concerns. Security can extend from the way in which services are delivered to the employee to the way in which that employee conducts his or her work and which intellectual properties he or she will access. As you have seen, this continuum can be managed within the context of directory-enabled access structures that can be flexibly built, modified, and dissolved based on business needs. The following case study shows how Motorola uses Cisco technology to accomplish this vision of flexible business response within the context of a secure role-based management structure.


Summary

  • Security is the essential enabler that allows a virtual business to operate.

  • An employment contract, although designed to prevent intellectual property leakage, cannot guarantee that no leakage will occur.

  • Intellectual property is the most important asset of any business, but especially so for a virtual business, where the emphasis on capital is minimized.

  • The virtual business must implement a way to ensure that a flexible employee dynamic does not compromise the company's essential information assets.

  • In a virtual business, where an adept technician could wreak havoc when allowed behind the firewall, additional security steps are required.

  • Managing security in a virtual business is essentially a problem of managing complexity. Two technologies currently in use and supported with Cisco solutions are directory-enabled policy-based management and role-based access control.

  • This security evolution also moves the company from a task-based orientation to a process-focused one.

  • Technologically, most of this functionality has evolved around LDAP.

  • This asset allocation involves the development and enforcement of policies.

  • A policy is merely a statement that defines access.

  • One of the simplest policies in concept, but most complex in practice, has to do with resource and information access based on job function or role.

  • The virtual business can use policy-based management to ease the tension involved in defining resource access arrangements. This is done through the application of role-based policies.

  • If you consider resource access to be a continuum from total access to total denial, it can also be correlated to levels of service quality.

  • Quality of service can be defined within the context of access and can be delivered using the same access infrastructure that is used to secure the company's intellectual property.


Case Study: Motorola (www.motorola.com)

Personal interview with Eric Milard, network architecture manager

Virtualized business process: Quality of service using policy-based management

Company Background

Company Overview

Motorola is a global leader in wireless, automotive, and broadband communications. Sales in 2002 were $27.3 billion. Motorola is a global corporate citizen dedicated to ethical business practices and pioneering important technologies that make things smarter and life better, honored traditions that began when the company was founded 75 years ago, in 1928. Motorola introduced its first product, a battery eliminator, to allow consumers to operate radios from household current instead of using batteries. Over the course of its history, Motorola has introduced a wide variety of consumer-related electronics, including automobile radios, two-way radios, two-way paging systems, bidirectional text messaging, and two-way cellular telephones. Quality and quality of service (QoS) are hallmarks of Motorola. In 1988 Motorola was the first recipient of the Malcolm Baldrige National Quality Award and again received the Baldrige award in 2003. Quality on the outside stems from quality on the inside. Within the Motorola institution, quality is critical to its customers' satisfaction and Motorola's retention of these customers. With such a strong emphasis on quality, it is not surprising that the level of quality to Motorola customers, both internal to the organization and external, is constantly measured. It is because of this strong quality value that Motorola was selected to be part of this book—specifically, to illustrate how an emphasis on quality and quality measures can become a strong contributor to the firm's bottom line.

Network Overview

Each business unit within Motorola used to have its own wide-area network. Several years ago, corporate management decided to bring all the WANs together under the corporate umbrella. Combining the individual WANs allowed significant economies of scale but introduced a new set of challenges in terms of bandwidth utilization and application prioritization. These challenges, and how Motorola overcame them, are the focus of this case study.

The Motorola network is made up of literally thousands of devices distributed around the globe. It is predominantly a Cisco-centric network consisting of over 1100 routers, 2500 switches, 60,000 fixed and mobile desktops, and countless application servers and applications. These devices are connected with over 1100 circuits and 600 wireless access points.

To support such a vast network, Motorola has divided its data network team into three focal areas. "The way we are organized in the network is that there is an architecture team, there is a team that does network management system, and there is the operations team. So basically, the design of the QoS includes these three organizations, and the whole idea is that when we come up with a solution that we are going to implement, it needs to be global, simple, and common to everybody. So that it can be managed, so that we provide the tool from the network management standpoint to the operations so they can manage it. We provide a solution that is scaleable so that it is not like we are implementing thousands of different configurations that everyone will have to tie into others and be very complicated to manage. We want to have something that is common to every platform."

Security

Motorola does not look at QoS from purely a security perspective. QoS and security are intertwined. Security is inherently included with the implementation, though, because of the way Motorola has characterized as well as categorized business-critical applications. With every application being put through rigorous testing in its test lab, Motorola is able to accurately establish response times for any approved application running on the corporate network.

Management's Attitude Toward Technology for the Business

As a technology company, management understands the role of technology as a business enabler. Even with this understanding, management also sees IT as a cost center. IT is under constant scrutiny to add value to its customers, the different divisions, and users, while reining in expenditures. Management's latest move in cost containment is to outsource the entire operation and support of the network infrastructure. The only component Motorola is keeping in-house is the architecture.

The Planning Process

Motorola's planning process was comprehensive due to the need to solicit input from all the different business units. From a technology perspective, implementing QoS was not the most challenging part of execution. The challenge came from trying to coordinate the business unit representatives and synchronizing busy calendars for meetings. "We tried several things. The first thing we tried was to come up with a policy committee and have some IT directors participating in this. That runs a little bit, but it did not work too well because the IT directors either do not have the visibility of all the applications or the detail. It is very difficult to have them available. The calendar is not widely open."

Success came to Motorola's planning when they moved up the reporting structure to a business-level person and out of IT. "We have someone that is called a global account manager for the network, for the infrastructure organization, that talks directly to the business. They are the interface between IT and the business. What we decided to do was to use that role, those persons, and talk to the business unit through that person. That worked pretty well."

Decision Metrics for Implementation

Motorola went through an extensive 2-year evaluation prior to implementing application-centric QoS in its network. A significant portion of the testing phase was spent testing various QoS technologies, working with the vendors to fix glitches in order to ensure the solution will work as expected and will be stable enough prior to implementation. Characterizing the business-critical applications was an important step prior to implementing them within the QoS architecture. "Basically, what we are saying is that before an application goes into quality of service, it needs to meet two criteria. The first criterion is it needs to be business-critical. The second criteria, it needs to fit technically in the class of service."

"The carriers have marketed these classes of service as gold, platinum, bronze, silver. But this is based on economic purposes. Here, we are not trying to make money; we are trying to put some organization within the network flows and give some priority to some applications. Rather than calling these classes of service gold, platinum, bronze, we call them with the technical characteristic of an application. So the platinum and gold, we call them the class J for the jitter-sensitive; the class T for the time-sensitive; normal, class N for the normal, which is going to be the bulk of the traffic; and class BI for bandwidth-intensive—that would be the equivalent of the truck lane. . . . Only a few applications are going to be eligible to go in QoS in the upper class, in the class J and the class T."

Two of the driving demands for implementing QoS throughout the corporate network were the constant demand for bandwidth as well as improving application performance. There is a perception that bandwidth is cheap, but in many parts of the world, that is not accurate. "Until QoS was there, the only way to guarantee performance for an application was to throw bandwidth. What we decided to do was to put a little bit of intelligence into the network. A little bit more organization into the flow so that rather than throwing bandwidth, which in some places in the world is extremely expensive, QoS would do the trick."

Barriers to Implementation

"I think that the biggest obstacle we foresaw was the politics, the politics of QoS. I mean, my application has to go into the upper class because it is the most business-critical application. Even though it has been designed and acts like a dog, it is sending megabytes across the network; it needs to go there. So we needed to have a very, very straight process and methodology in order to accommodate these requests."

Lessons Learned in the Testing Phase

  • Application vendors do not test their software in a network or across a wide-area network. To counter this problem, Motorola offers application architects an opportunity to ". . . put your application in our lab. We are going to see how it will act when we put the factor of what the wide-area network will bring to the picture. The delay, the latency, the jitter, the condition, and see when it breaks."

  • Politics can be resolved when QoS criteria are firmly established in terms of application characteristics rather than using the vendor's Olympic type of classifications of gold, silver, and bronze.

  • Measuring the correct application characteristics is critical. To ensure QoS and service levels, applications' measures should not be technical, but should be behavioral when implemented in a complex environment.

  • Buy-in at the management business level is critical to success.

Unforeseen Benefits of Implementation

  • "I think what QoS has brought on top of the influence within the network is that characterization methodology, that new tool that we have put in place, provides process and methodology to the networkers so that they understand better why an application goes slow."

  • Motorola reaped benefits by "plugging that gap between the network and application." Understanding the impact that a complex network, spread across the globe, has on an application has led to better dialog between users and the operations support team.

  • "Troubleshooting applications . . . with the tools and methodology we have put in place enables us to identify in a timely manner which element within the application is causing the slowness, therefore leading to a faster root cause identification and problem fix."

Unforeseen Barriers to Implementation

Motorola did not experience any unforeseen technical barriers to its QoS and service-level implementation. This was based on the extensive testing Motorola conducted in its laboratory on different QoS mechanisms and techniques, ensuring that the solution is technically viable. Enhancing the network-monitoring tools with QoS monitoring capabilities was also a vital element of the successful implementation. The greatest barrier Motorola encountered was the politics of defining which applications belonged in the highest-priority service level. The solution to this barrier is described in other sections of this case study.

Future Plans for Business Process Virtualization

  • In taking the next steps to virtualization, Motorola has outsourced its infrastructure and management of the infrastructure. It has retained in-house the management, support, and deployment of applications.

  • "Another technology that we are currently looking at is multicast—financing the multicast capabilities so that the network is multicast-ready."

  • Motorola is also evaluating adding "more intelligence into the understanding of data flow, data flow management, so NetFlow from Cisco is what we are considering."

Words of Advice

"I'd say, understand the ramifications of what you are doing. So, you are going to touch QoS, you are going to touch the network, but you have to understand that when you touch QoS you are going to touch the applications. You need to address all of the ramifications of what you are doing. If you don't look at that, you are not going to be successful."

ROI

"That was the first thing on the project plan when we designed the solution. We needed to calculate the ROI. . . . We looked at an implementation we did for voice over IP in Latin America. The ROI was very, very big, very, very, and quick. We saved, I think, half a million dollars a year with very little investment. That is just for voice over IP. Implementing QoS was minimal because we are using the existing routers. There was no major investment outside of time. I think very, very quickly we decided we are not going to do any ROI calculations. This one was kind of a no-brainer that it is going to help. It is going to help the business. It is going to help the way we manage our network, and it was bringing value. So saving on the bandwidth was probably minimal. We might have saved a few thousands dollars here or there because we don't need to upgrade the link, but that is nothing compared to the millions of dollars of consolidating servers or applications. QoS is more an enabler. It will enable a new architecture (consolidated or more centralized model), VoIP, better application performance, etc."


Chapter 8. Financial Implications of BPV on Conventional Businesses

As this book has shown, virtual businesses are more nimble than conventional businesses. This nimbleness comes with a price. Unlike the infrastructure of a conventional business, which can be built and maintained with semiskilled labor, a virtual business pays for its flexibility with a more sophisticated (and complex) infrastructure. This infrastructure depends on establishing and main-taining a secure and reliable network within dynamic and relatively unreliable cyberspace.

This complex infrastructure takes a high degree of training and applied knowledge to manage and maintain. The typical technical support personnel for a virtual business are highly compensated and relatively rare. A fundamental reason to consider outsourcing business processes is to leverage other companies' expertise and pool of highly trained personnel to support your business.

These people are typically hard to manage and expensive to carry. They expect autonomy, and they frequently follow their own plan rather than paying allegiance to any corporate vision. To paraphrase a widely used comment on these types of personalities, these people are a pain in the butt.

So why even do this if the pain is so great?

The question is a profound one. We have seen many companies turn away from virtualization opportunities because they looked at the personnel issues and concluded that the cost to build a business on the backs of such people was too high. But is it?

Ultimately, people as well as virtualized processes can be managed by other people. As discussed earlier, it is appropriate to think of human resources and personnel as issues that must be addressed so that you can reap the benefits associated with virtual infrastructure. In other words, rather than thinking of human resources and personnel as issues that can't be addressed, perhaps it is better to think of the overall loading on technical personnel to be higher than for a conventional business. To counter the higher loading, it would be wise to consider placing the process loading on the technical personnel directly by virtualizing human resources.

Personnel is not the only issue along the overall loading lines. As you have seen, network infrastructure, along with the equipment and software that make it function, is not cheap. It is complex and expensive and has a rather short operational lifetime. The loadings on the business from such a complex infrastructure can be rather high if the business acquires and owns the infrastructure in its entirety.

From the standpoint of a manager examining the virtues of becoming virtual, it is easy to focus on either the benefits or the costs and forget that the decision to go virtual depends on both sides of the equation. This chapter wraps up the discussion of BPV with a detailed look at the real costs and benefits of virtualizing. If you're considering going in this direction, will the benefits exceed the costs? To put it another way, will the return on investment (ROI) be near-term and positive?


Reduced Costs

Previous chapters noted that the point of virtualizing is to increase revenue, reduce costs, and improve survivability. Of all these objectives, perhaps the most important short-term objective is to reduce costs. In fact, cost reduction traditionally has driven outsourcing functions. Not surprisingly, as an objective, it has inspired a certain amount of antipathy.

Historically, there has been dynamic tension between executive management and IT. Executives have tended to think of IT as another overhead, perhaps necessary to conduct business, but no more critical, generally, than any business overhead. Combine this with a fundamental, and natural, distrust of that which you can't understand, and IT has traditionally been in the position of a high priest of an unpopular but entrenched religion. The rulers don't like worshipping at the IT altar, but there is no option if the crops are to come in on time.

It is hardly surprising, therefore, that when choosing between using internal IT (with its known and expensive price tag) and using an external provider (with a smaller price tag), many executives have chosen to outsource.

The case studies throughout this book have illustrated that management absolutely must change its attitude toward IT and will do so as the BPV process unfolds. Companies that have successfully executed BPV have management teams who walk the talk on IT's value to the company's long-term success and viability. As a business value proposition, IT can be handled in-house, outsourced, or blended. Whichever way IT is implemented is not the critical factor in BPV success—it is management's attitude toward IT as a business asset or liability.

Of course, outsourcing is only one aspect of virtualizing a business. Other aspects include building a robust networked infrastructure that can support business operations regardless of where they might need to occur. Although virtualization is a way to address fundamental concerns associated with the cost of doing business, if it's pursued strictly as a way to reduce costs, a dysfunctional dynamic is established that will almost certainly ensure failure.

BPV is the process of embedding efficiencies into the business using technology. If that technology can be provided efficiently and securely by a third party and at a lower cost, the firm should pursue that option. Federal Express proved this when it used tracking technology to not only level the playing field with competing package carriers such as UPS, but also to redefine the overnight shipping process. By implementing technology early, FedEx avoided significant backfill costs such as head-to-head competition with what were then the market-dominating forces of UPS. More importantly, FedEx was able to impose the higher costs of remaining in the overnight shipping industry on its competitors. The bottom line of understanding where the infrastructure will be deployed and managed begins with a clear understanding of the total cost of ownership (TCO).


The True Total Cost of Ownership

Listen to almost any vendor of technology, and you will hear the same litany of clichfis: "Our technology is so easy to use, a monkey could install it. It runs right out of the box and provides useful functionality in seconds! It's plug and play." Generally these are the sorts of claims that fall apart in practice.

Studies conducted by both analyst firms and large management platform vendors have consistently found that nearly 10 percent of all management software sold has never worked properly. This figure does not take into account the amount of management software that has been relegated to the shelf, never having been installed because of excessive complexity. In a market characterized by investments in the billions of dollars annually, this is an appalling figure.

If that data point fails to resonate, consider this: Most enterprises that use a networked infrastructure usually solve performance issues by deploying additional hardware or bandwidth. This is a reactionary response, driving up costs. Studies have indicated that such approaches have produced networks that are less than 40 percent efficient. Consider how much you are spending for your network, and then deduct 60 percent of the cost. You can easily make a case that a networked infrastructure probably costs nearly twice as much as it should. These costs can be mitigated with the proper use of technology, leveraging all the features and functionality of a network product or tool before implementing yet another spot solution or adding bandwidth.

So what is the true cost of ownership of virtualizing business processes? Clearly, it includes the cost of the software and hardware necessary to make it work. This is the easy part—sort of.

It is easy in the sense that for an absolute demand, you can easily obtain the price of systems, software, and bandwidth. It is hard in the sense that, if you were to build the network based on strict demand calculations, you would end up with a nonfunctional infrastructure.

As any network engineer will tell you, any process designed to merely address a particular load will ultimately fail when the load exceeds the design point. Consequently, one additional cost is the cost of designing in additional capacity for unexpected peaks and circumstances. But how much over capacity should this be before the costs exceed the benefits?

One good rule of thumb is to design a system or network to handle all the demand you can anticipate plus 20 percent. This ensures that spikes and peak loads based on unexpected circumstances will not push performance below unacceptable levels. It also provides a sufficient safety margin to allow for built-in redundancy.

Redundancy is the process of building backup processes into a system or network. In practice this amounts to ensuring that critical data is stored in multiple locations, that critical servers are mirrored by redundant systems, and that there are no single points of failure. The best way to determine where you need to build in a failover capability is to ask yourself how long you can afford to have any single component of the networked infrastructure out of action. If the answer is not very long (seconds or minutes versus hours or days), build in an appropriate recovery option.

Another significant expense for any investment is that associated with depreciation. In other words, how fast will the infrastructure wear out? In the case of technology investments, this can be fairly quickly—currently 3 years. Although depreciation expense does confer some tax benefits, from the standpoint of a total cost calculation, its only significance is as an indication of how frequently you will need to replace the equipment that makes up the networked infrastructure. If you must replace servers every 3 years, the replacement cost spread over a typical year can be 30 percent of the base infrastructure cost—a considerable expense. This cost could be substantially greater if a company factors in Moore's Law and an 18-month technology life cycle. The need to upgrade or replace technology every 18 months is a double hit: loss of depreciation benefits and an increase in upgrade frequency.

The next significant question to ask is how will all this equipment be managed. In the case of some hardware, built-in failover capabilities are implicit. This capability is automatic and is managed at the processor level. For other situations that are more complex and that involve multiple networked devices, management solutions need to be applied.

Any networked infrastructure requires a certain amount of management to achieve its maximum reliability potential. Management solutions (applications that provide management control over networked infrastructure) provide this capability.

Currently, the enterprise can apply several thousand management applications to its infrastructure. It would be too bewildering and confusing to discuss even a fraction of these solutions. Suffice it to say that for any management need, such as fault isolation, inventory, service provisioning, or access control, you have multiple competing solutions from which to choose. Of course, each of these comes with a price and drives additional costs in the networked infrastructure as well.

Another cost of building and maintaining a networked environment is training. As new technology is introduced into the network, people must be trained in its use. The more people a change touches, the more training that is required. If a technology is pervasive—say, a new productivity application—far more people than IT might need to be trained. This can be daunting to an enterprise and can take a substantial amount of time to accomplish.

The most apparent cost associated with networked infrastructure is people. Although it might be possible to outsource many of the operations functions and associated people involved in process virtualization, it usually isn't possible to outsource such functions as network and systems architecture or critical application design and support. These two areas, in addition to being complex and unique to each business, are also considered strategic to a firm and are seen as a competitive advantage. Likewise, management functions typically require some level of internal personnel involvement, even if such functions are provided by a third party.

Finally, the TCO must take into account the cost of conversion. These costs can be significant and pervasive. To facilitate the implementation of IT processes, the British government sponsored the development of guidelines that can be used to aid in the conversion and documentation of IT processes. These guidelines, called Information Technology Information Library (ITIL), impose a tremendous amount of overhead associated with documentation and process control. The ITIL methodology might be overkill for small and medium-sized firms, but it provides a good framework for the questions that must be addressed to successfully implement a networked infrastructure.

So what does a TCO evaluation of BPV include? As shown in Figure 8-1, it includes the following:

  • Hardware

  • Software

  • Maintenance

  • Implementation

  • Depreciation

  • Personnel

  • Training

  • Excess capacity

  • Outsourcing, if separate from the other items

  • Conversion costs

Figure 8-1. Total Cost of Ownership

By now, if we have done our job right, you should be suffering some anxiety. You might be wondering what the total cost of a given virtual process is. Although we can't answer that specifically, a good rule of thumb is that the total virtual process cost will be twice the hardware and software costs.

This might sound like a lot, and it is, but compare this cost to the TCO for a bricks-and-mortar process, and the price is substantially less.


The ROI for a Virtualized Business

The fact is, you need a compelling reason to pursue a virtualization strategy that transcends the pain associated with doing so. There are several compelling reasons to take a process virtual. Chief among them is cost reduction.

Where virtualized businesses build infrastructure to support access to information, typical businesses build infrastructure to house people. The overhead associated with the latter can be considerably more than for a networked approach. Consider one example: the cost of floor space.

For a typical business located in a major metropolitan area, the cost of 1 square foot of real estate can be about $20 per year. For a typical employee in an average-sized cubicle, this can amount to roughly $1600 annually. For extremely expensive locations such as Silicon Valley, the real estate rate can be considerably more. However, just based on a nominal $1600 per employee, for a 100-person operation the floor space costs alone can be $160,000 a year. This does not include the cost of equipment, furniture, or supplies. It also doesn't take into account that a purely physical business uses people to accomplish tasks that automation could perform.

For the same 100-person virtual business, the floor space requirement could conceivably be reduced to zero. However, there might be a need to house some networked equipment and potentially provide meeting facilities. When combined with the efficiencies driven by process automation, the costs can be orders of magnitude less for the virtual business. Of course, cost of ownership is only half the equation. Cost benefits are the reason for virtualizing.

Typical businesses, especially those with a wide geographic presence, incur costs associated with placing decision makers in close proximity. Business travel usually is an internal exercise. Teams require face time, executives need to meet for strategic decision making, employees need to be trained. The list goes on. Unless you are actively involved in sales, the likelihood is that travel supports internal business needs, not your customers.

A virtual business eliminates much of this internal travel. Rather than moving people, information is moved. Rather than spending money to place critical personnel in harm's way, investment is reserved for customer-focused functions. And when you consider that much of travel is actually unproductive, laptops and cell phones notwithstanding, the productivity of networked workers over conventional workers can be astounding.

Another area where costs are dramatically reduced for the virtual business is automation. A virtualized business applies automation to the business process, whereas a conventional business applies automation to the person.

Consider a typical workgroup in which each individual has a desktop computer and access to e-mail. Each person interfaces with everyone else and with a supervisor. Each person uses a word processor and a spreadsheet and accesses company information through specific applications that allow identity-based sign-on. Although compared to earlier businesses this seems pretty virtual, it nevertheless requires that each person work in isolation. To the extent that tasks are accomplished on the web, they are accomplished through simple communication.

A virtual workgroup, on the other hand, has all the same personal productivity tools, but instead of statically mapped business applications, it uses productivity software to marry group dynamics to business processes. In other words, instead of working individually, virtual work groups work collaboratively. This means that business automation can be much more efficient; instead of enabling single operations, it enables multiple operations and interactions. This can have a major impact on the scaling of business applications as well as the ways in which they are delivered. Overall costs associated with this automation can actually be less than for the hard-mapped kind typical of physical businesses.

When these cost savings are tallied, they greatly exceed the cost of implementing a virtual business. In addition, cost savings associated with taking a company virtual can provide lasting benefits over conventional business. As shown in Figure 8-2, when Figure 8-1 is modified to include the cost savings benefits associated with BPV, a strong case is made for ROI.

Figure 8-2. ROI for BPV

As noted in previous chapters, such ROIs, based strictly on cost dynamics, can provide for paybacks that are significantly less than 1 year in most cases.

Clearly, this simplistic approach to ROI ignores non-cost-related benefits. When these are included, the ROI equation can be considerably more complex. Executives typically consider such factors as revenue growth, customer product bundling, measurable customer satisfaction as it relates to additional wallet share, cost containment, and cost reduction. The fact is, although cost reduction is a big part of ROI evaluations, it is not the only factor. Decisions made on this basis are never simple.


Knowledge of Customer Issues

If cost containment were the only reason for virtualizing a business, it would be a worthwhile undertaking. However, cost control should not be the primary reason for adopting new approaches to conducting business. In most cases the comfort factor prevents the adoption of fundamental change. Even in your personal life this is so.

If you are a professional with a family, you are constantly weighing the option of seeking new job opportunities. If you are like most people, you have passed on such opportunities when they appeared to impose too much lifestyle modification. Even if the benefits associated with the new job are significant, you might decide not to pursue it if it requires that you uproot your family and go through the process of relocation; the pain associated with change exceeds its benefits. This axiom is true of business as well.

However, just as your personal life has reasons that ultimately compel you to make a change in spite of the pain involved, in business there are reasons why you will ultimately decide to adopt BPV. The most compelling is the absolute need to get close to your customers.

The name of the game for business in the 21st century is understanding your customers' issues. If you can't live with your customers, know what they know, understand what they think, and feel their pain, you won't be able to beat your competitors who do. And if your approach to achieving this customer knowledge is to fly out and visit them once or twice a year, as we discussed previously, your expenses will eat you up.

What is required is the infrastructure necessary to place your employees literally down the street from your customers—ideally, in a spare office in their building. If your technology can't accommodate this, you will be competitively eliminated by businesses that do have a local presence.

The reason is simple: All business is running faster and harder. There is no longer time to dispatch a person to find out what is going on and then offer services or products to solve customer problems. Your customers' needs change from minute to minute, and the only way you can understand those changing needs is to experience them firsthand.

BPV, by making the business location precisely where the employee is located, obviates the need to travel and also makes on-site presence practical. This might mean acquiring employees based not on their willingness to move but on where they are already located.

Customer presence has other implications. Assuming that a professional business environment means an office, which would you rather do: build buildings to give your employees that space, or have your customers provide it when needed? One important aspect of customer presence is the cost shifting that can take place when the customer is actively involved in its own support.

The virtualized business has no problem achieving and maintaining customer presence. Physical businesses will always be at a disadvantage in this area. In fact, this expense usually is cut first, because it is perceived as discretionary overhead. Virtual businesses understand that this is the point of business, and they build their networked infrastructure around supporting it.


Improved Decision Making

Virtual businesses, as discussed in previous chapters, are very much into actionable information. Physical businesses dwell on data. A virtual business knows that it is data in context that matters, and it builds automation to facilitate the generation of information that can be used to support decision making.

Decision making is why executives spend so much time traveling. They travel to meet other executives, they travel to meet employees, and they travel to visit customers. Every one of these exercises is to facilitate information acquisition to support decision making. As we have discussed, this is inefficient and costly, not to mention possibly dangerous.

Virtual business collects information directly from the source in near-real time. Employees are right on the customer premises and are located everywhere the virtual enterprise does business.

Networked infrastructure ensures that decisions can be made by the employee on site and, if needed, supported and approved by executives located where they need to be.

A virtual business can outperform a physical business because it is more efficient. One of the chief efficiencies is the way in which it uses its people. Rather than running a significant portion of the workforce ragged by placing data collection and analysis responsibilities on its back, the virtual company makes data collection implicit in operations and makes information generation a natural extension of the business process.


Competitive Advantages of a Virtualized Corporation

The virtual business, as you have seen, is a more nimble and competitive animal than its physical counterpart. In the natural order of things, it is more evolved. It is like comparing a cheetah to a velociraptor. In any kind of fair comparison, the dinosaur would lose.

The velociraptor was fleet of foot and probably hunted in packs. It was armed with razor-sharp claws and could run upwards of 30 miles per hour, but it couldn't think as effectively as a cheetah. The cheetah, although armed not quite as well, nevertheless is a more effective, more adaptable hunter. If the CT asteroid impact had not wiped out the velociraptor and its friends, ultimately calculating animals like the cheetah would have.

Likewise, in the evolution of business, the asteroid impact has occurred, but the dinosaurs don't understand it yet. The virtual cheetahs are beginning to enter the market with vastly superior thinking capabilities, more efficient tool sets, and far superior speed. These are the competitive advantages of a virtual business.

Virtual business, by virtue of its more efficient nervous system, perceives the world more directly, in full color. Its actions are precise because its employees are located where they need to be, and they are the most qualified for their jobs. They know they can be informationally supported wherever they need to be and that whatever resources they need to get the job done are instantly available.

Virtual business, by focusing investment on innovation rather than infrastructure, is a more efficient eater. It requires less energy to exist, so it can focus its attention on its objectives. In a virtual business, the thinking is clear, because it doesn't need to dwell on the demands of existence.

Virtual business is fleet of foot, because it does not constantly filter data, trying to decide what to do next. It makes decisions in real time and executes those decisions with lightning speed. By the time a conventional business decides that there is a potential opportunity, a virtual business will have identified and exploited that opportunity and will be prepared to leverage it for additional opportunities.

The world of business has changed, and technology has become the ultimate competitive advantage. As we prepare to enter the true Information Age, we will find that size no longer confers any great advantage to a business. Only information confers an advantage. Only an information-enabled infrastructure will make possible the kinds of business dynamics that will be required for growth and survival.

Just as a new World Trade Center is being erected on the site of the old one, a new business architecture is well under construction. Just like the new World Trade Center, the new business paradigm will be characterized by a breathtaking new scope and form. Unlike the new World Trade Center, though, you will not be able to see it. It will, after all, be virtual.


Summary

  • Unlike the infrastructure of a conventional business, which can be built and maintained with semiskilled labor, a virtual business pays for its flexibility with a more sophisticated and complex infrastructure.

  • It is appropriate to think of human resources and personnel as issues that must be addressed so that you can reap the benefits associated with virtual infrastructure.

  • The loadings on the business from such a complex infrastructure can be rather high if the infrastructure is acquired and owned in its entirety by the business.

  • From the standpoint of a manager examining the virtues of becoming virtual, it is easy to focus on either the benefits or the costs and forget that the decision to go virtual depends on both sides of the equation.

  • Companies that have successfully executed BPV have management teams who walk the talk on the value of IT to the company's long-term success and viability.

  • Although virtualization is a way to address fundamental concerns associated with the cost of doing business, if it is pursued strictly as a way to reduce cost, a dysfunctional dynamic is established that will almost certainly ensure failure.

  • Although it might be possible to outsource many of the operations functions and associated people involved in process virtualization, it usually is not possible to outsource such functions as network and systems architecture or critical application design and support. These two areas, in addition to being complex and unique to each business, are also considered strategic to a firm and are seen as a competitive advantage.

  • A TCO evaluation of BPV includes the following:

    - Hardware

    - Software

    - Maintenance

    - Implementation

    - Depreciation

    - Personnel

    - Training

    - Excess capacity

    - Outsourcing, if separate from the other items

    - Conversion costs

  • A compelling reason must exist before you pursue a virtualization strategy that transcends the pain associated with doing so.

  • A virtual workgroup has personal productivity tools, but instead of statically mapped business applications, it uses productivity software to marry group dynamics to business processes.

  • The name of the game for business in the 21st century is understanding your customers' issues.

  • A virtual business knows that it is data in context that matters, and it builds automation to facilitate the generation of information that can be used to support decision making.

  • A virtual business can outperform a physical business because it is more efficient.

  • Virtual business, by virtue of its more efficient nervous system, perceives the world more directly, in full color.

  • Virtual business, by focusing investment on innovation rather than infrastructure, is a more efficient eater.

  • Virtual business is fleet of foot, because it does not constantly filter data, trying to decide what to do next.

  • Only an information-enabled infrastructure makes possible the kinds of business dynamics that are required for growth and survival.

  • Just like the new World Trade Center, the new business paradigm will be characterized by a breathtaking new scope and form.


Appendix A. Survey Instrument

The survey instrument was developed as a base tool to conduct the case studies that appear at the end of the chapters. Using the same survey instrument for all the case studies ensured that consistent information was gathered for continuity in writing and reporting on the business process virtualization (BPV) implementations.

The survey instrument was sent to the interview subjects several days before the teleconference. This gave the subjects an opportunity to gather any information they did not have readily available and gave them time to collect their thoughts. When the survey was sent to the interview subjects, the company background preamble was included for their review. The subjects were asked to verify and confirm the information in the preamble because it would be used to introduce the case study in the book.

The interviews were conducted via telephone. Each interview took approximately 1 hour. The interview was conducted in a conversational format to best obtain the anecdotal information underlying key concepts in the interview. The survey was modified during the teleconference with the case study subjects depending on responses received to specific questions and technologies being discussed. This modification was at the discretion of the interviewer.

The interview was transcribed and sent to the interviewee for review and approval. During the transcript approval period, the case study was written. It was also sent to the interview subject for review and approval. Any changes or modifications requested by the interview subjects to the case study write-up were addressed.

Written approval for publication was obtained from each case study subject after all edits and modifications were addressed. The chapter content, summary, case study, and graphics were then sent to the publisher. At no time during the interview, transcript review, or case study review did anyone other than the interview subject and the interviewer see the raw materials.


Survey Instrument Format

The survey is laid out in six parts.

Part 1 defines the BPV process the company enacted. The authors developed the definition of BPV. This definition was included with the survey to ensure that the interview subjects were familiar with the ideas being explored.

Part 2 describes the company being interviewed and what process has been virtualized. A firm can virtualize numerous processes at any time. By showing BPV's incremental capabilities, we hope users will move forward with their strategies more confidently, knowing that BPV can be implemented in small, manageable increments. BPV is not an all-or-nothing proposition; it is a spectrum along which companies of all sizes can move.

Part 3 launches the interview. It addresses the preliminary steps the company took in evaluating BPV. This section addresses the why of BPV. It explores the metrics used in weighing the BPV decision, executive management's attitude toward technology, and what was going on within the company that made the decision makers consider BPV as a business strategy.

Part 4 explores the execution stage. This section addresses the how of BPV. The questions in this section examine the steps a firm takes in making substantial changes in the organization, timelines for testing and test beds, understanding the metrics of defining how success was measured, and where course adjustments were made along the implementation path.

Part 5 examines the feedback loop. These questions identify unforeseen barriers and benefits of the BPV implementation, ROI measurements, and how the strategy was rolled out across the company.

The final part of the survey, part 6, addresses the firm's future plans in terms of outsourcing, BPV, and big-picture strategies for other areas under consideration of being virtualized. This section wraps up with experience-based, practical advice from experienced implementers of BPV.


The BPV Survey Instrument

The survey instrument begins with the following information:

Questions for XYZ Company

Interviewee name and title

Personal interview, date of interview

Defining Business Process Virtualization

BPV is the application of networked intelligent Information Technology (IT) infrastructure to enhance skilled personnel, processes, and assets to enable improved company efficiencies, increase competitive advantage, heighten brand awareness, reduce costs, and improve bottom-line revenues. Unlike business process automation, it involves a significant focus on new management approaches for personnel and technology. BPV involves a fundamental change in thinking about business and its objectives.

The current market is bifurcated. On one hand, some companies view, use, and think about technology and networked infrastructure as a cost center. On the other hand, some companies view, use, and think about technology and networked infrastructure as a corporate asset to be used as a business enabler and to achieve a competitive advantage.

Why XYZ Company?

In this section, a few short paragraphs describe the company being interviewed, why it was selected, and what process it has virtualized that is discussed in the interview. It acts as a lead-in for the case study.

Questions Addressed in the Interview

The following sections describe the categories of questions covered in the interview.

Planning Stage

This section explores the firm's timeline, from planning up to the point of preparing to implement BPV. We also look at the roles of people involved in the planning stage and what input they had in moving forward with the process. Finally, we look at the decision metrics the company used in weighing the decision to move forward or table the project.

  1. Describe your network in terms of the number of desktops, switches, routers, application servers, web servers, applications, and so on that are supported.

  2. What is your executive management's general attitude toward technology relative to the business? (For example, is it seen as a cost center, a business enabler, an asset, or a liability?)

  3. When did your firm start to consider moving toward business process virtualization?

  4. Why did the company start to explore BPV as a way of conducting business?

  5. Which departments were involved in the initial exploration of potentially moving to BPV?

  6. Why were these departments part of the initial planning team? What did they bring to the planning process?

  7. When, if at all, were other departments brought into the planning stage?

  8. In the exploratory stage, what decision metrics were used to establish the company's need to move to virtualization?

  9. At what point in the decision process did the firm determine to either keep the virtualized process in-house or move it to a service provider?

  10. List the top three to five decision metrics used in keeping the process in-house or moving it to a service provider.

  11. What departments within your company had input into the decision to keep the process in-house or outsource it?

  12. Identify any anticipated barriers to virtualization that came up in the planning stage.

Execution Stage

This section explores the steps the firm took to implement BPV and the timeline to execution. We establish if additional departments were brought into or removed from the execution stage. We determine if the company ran into unanticipated barriers while executing the project and how it overcame them. We also look at what decision metrics were established to measure the project's ROI.

1. When did the firm begin implementing the BPV plan?

2. Did you run a test bed or pilot before a full rollout?

3. How long did the pilot run before you moved forward with the rest of the rollout?

4. Do you consider your virtualization strategy complete? Why or why not?

5. Identify three to five data points you learned in the pilot that modified or changed the initial BPV plan.

6. Describe how the BPV plans were modified.

7. As the company moved toward full execution of the BPV implementation, were any other departments brought into or removed from the execution process?

8. What metrics were used to establish the ROI on the BPV implementation?

9. Did the ROI metrics change during execution of the BPV plan? If so, how?

10. Were any positions added or eliminated because of the BPV implementation?

11. What was the average fully-weighted cost of these positions?

12. What costs did your firm incur in implementing the BPV process (for example, upgrades to desktops, business-critical applications, increases in software licensing, upgrades to infrastructure, outsourcing costs, legal costs associated with contracts, termination costs, hiring costs)?

13. What savings did your firm realize in implementing the BPV process (for example, headcount reduction, elimination of or reduction in real estate/leases, improved inventory for hardware and software, improved employee training, reduction/elimination of travel, improved business process efficiencies such as time to close the books, reduced engineering time, faster time to market)?

Feedback Loop

This section tries to determine the full value of the virtualized process, if the company is planning to implement the process further through horizontal or vertical execution, and if any other processes are expected to be virtualized. We also see what the triggers are for either bringing back in-house or outsourcing future BPV projects.

  1. Looking back, has your firm reaped unforeseen benefits based on virtualization? Describe a few of them.

  2. Describe any unforeseen barriers that needed to be overcome to make the BPV implementation successful.

  3. What are your firm's plans for future BPV implementations?

  4. Historically, has your firm rolled out IT implementations vertically or horizontally?

  5. Does your firm test IT initiatives in its field offices or in its home office?

  6. Describe how your IT department has changed because of BPV (for example, it increased/decreased in size, it was eliminated, it was redeployed in a more strategic role, it became more/less involved in strategic business planning).

Future Plans

  1. What leading-edge technologies has your firm implemented or is planning to implement (for example, wireless, unified messaging, converged networking, distance learning/training, application webification, desktop management webification, PDAs)?

  2. Does your firm expect to implement some or all of these technologies in a virtual manner?

  3. Does your firm expect to use a service provider to roll out and support these emerging technologies?

  4. Would you say your firm has moved closer to or further away from a standardized infrastructure (desktops, desktop applications, servers, storage, business-critical applications)?

  5. What would trigger your firm to bring its IT management and support services back in-house?

  6. If you could offer specific advice to a firm considering virtualizing some or all of its business processes, what would that advice be?


Appendix B. BPV Providers

Vendors of all sizes, with a wide range of geographic scope, provide BPV services. Most of these firms can be classified as managed service providers (MSPs). The largest firms covering the greatest geographic area also have a professional services organization for your planning and integration needs.

Table B-1 is a partial list of providers with headquarters in North America.

To locate service providers outside North America, as well as to virtualize other business processes beyond information technology, check out these websites:

Outsourcing Institute at www.outsourcing.com

Outsourcing Central at www.outsourcingcentral.com

Sourcing Interests Group at www.sourcinginterests.org

Table B-1. Service Providers with BPV Services
Company | Website
A
B
C
D
E
F
G
H-I-J-K
L-M-N
O-P
S
T
U-V
W-X-Y-Z
Absolute Software | absolute.com
Accenture | accenture.com
Affiliated Computer Services (ACS) | ACS-inc.com
Affinity Internet, Inc. | affinity.com
Agiliti, Inc. | agiliti.com
AimNet Solutions | aimnetsolutions.com
Alicomp | alicomp.com
Altoria Solutions, LLC | altoria.com
Altoros Systems | altoros.com
Alvaka Networks | alvaka.net
Appliant | appliant.com
AppShop | appshop.com
ArrAy, Inc. | arrayinc.com
Arrow Electronics | arrow.com
Atesto | atesto.com
ATL Corporation | atlusa.com
ATS Services Pvt., Ltd. | servicesats.com
ATT | ATT.com
Automatos | automatos.com
Avaya Managed Services | Avaya.com
Avnet Computer Marketing | avnet.com
Avon Software Technologies, Inc. | avonsoftware.com
Aztec Software, Inc. | aztecsoft.com
BancTec Computer | banctec.com
Baseline Systems Monitoring, Inc. | baselinesys.com
BASP, Inc. | basp.com
BellSouth | bellsouth.com
BlueStar Solutions, Inc. | bluestarsolutions.com
Boom Vang Consulting | boomvang.com
Brute Force Security | bruteforcesecurity.com
Bull Groupe | bull.com
Center7, Inc. | center7.com
Centerbeam | centerbeam.com
Center Partners | centerpartners.com
CMA Consulting Service | cma.com
Collective Technologies | collectivetech.com
ColoWatch | colowatch.com
CommTech Services | commtech-services.com
Computer Breakthrough | cbi.net
Computer Network Solutions, Inc. | computerns.com
Computer Sciences Corporation | csc-fs.com
Comstor | comstor.com
Connected TLM | connected.com
Consonus | consonus.com
Convergys | convergys.com
Converse Software | conversesoftware.com
Coradiant | coradiant.com
CoSine Communication | cosinecom.com
CrownPeak Technology | crownpeak.com
CTG | ctg.com
Damicon, LLC | damicon.com
DataArt | dataart.com
Database Systems Corp | databasesystemscorp.com
DataStream Systems, Inc. | datastream.net
dba Direct | dbadirect.com
DCN Technologies | dcntech.com
Digital Edge, Inc. | digitedge.com
DirectPointe | directpointe.com
e4eInc. | e4einc.com
Ebusinessware | ebusinessware.com
Electronic Data Systems (EDS) | EDS.com
eLevel | elevel.com
Empirix | empirix.com
Employease | employease.com
Emtec, Inc. | emtec.com
Entomo, Inc. | entomo.com
Everdream | everdream.com
ExperExchange, Inc. | experexchange.com
Fiserv, Inc. | fiserv.com
Fortrust Solutions | fortrust.biz
Fujitsu Technology Solutions, Inc. | fujitsu.com
Fullscope, Inc. | fullscope.com
Fusepoint Managed Services | fusepoint.com
FusionStorm | fusionstorm.com
Geotrust | geotrust.com
Global Access LLC | globalaccessllc.com
Global Data Systems, Inc. | gdsconnect.com
Global Enterprise Management | gemscorp.com
Goldstone Technologies | goldstonetech.com
Gomez | gomez.com
Guardent | guardent.com
HCL Technologies America, Inc. | hcltechnologies.com
Hitachi Data Systems | hds.com
HP Global Services | hp.com
IBM Global Services | ibm.com/services
InFlow | inflow.com
InsynQ | insynq.com
Intacct | intacct.com
Intellinet | intellinet.com
InteQ Corp | inteqnet.com
Interland | interland.com
Internap Network Services Corporation | internap.com
Internet Security Systems | iss.net
InterProm USA | interpromusa.com
(i)Structure | istructure.com
ITGuardian | itguardian.com
IT OnTime, Inc. | it-ontime.com
Logical | us.logical.com
Lucent WW Services | lucent.com
MindShift Technologies | mindshift.com
Msource | msource.net
N-Able Technologies | n-able.com
NaviSite | navisite.com
NETeffect | neteffectcorp.com
NetSolve | netsolve.net
Network Guidance Co. | network-guidance.com
New World Apps, Inc. | newworldapps.com
Noxent | noxent.com
OpenService, Inc. | open.com
OSSID | ossid.net
Outsource Partners International | opiglobal.com
Panurgy | panurgy.com
Paradigm Technology Partners | ptpinc.net
PatchLink | patchlink.com
PerformanceIT | performanceit.com
Puzzle Solutions | pzs.com
Q-R
Q9 Networks, Inc. | Q9.com
Qwest | qwest.com
RackMy.com | rackmy.com
RackSpace | rackspace.com
Raritan Computer, Inc. | raritan.com
Red Siren | redsiren.com
RMS Business Systems | rmsbus.com
Rolta International, Inc. | rolta.com
Rspeed | rspeedinc.com
Salesforce.com | salesforce.com
SaskTel | sasktel.com
Savantis | savantis.com
SBC | sbc.com
Sector, Inc. | sectorinc.com
SevenSpace | sevenspace.com
Seventh Wave Technology | seventhwavetech.com
SiteLite | sitelite.com
Situs Management, Inc. | situs-manage.com
SmartPipes | smartpipes.com
SonicWall | sonicwall.com
Sprint E-business | sprint.com
Storability | storability.com
Tech Data | techdata.com
Telecom Lab | teamtli.com
TorchQuest | torchquest.com
Totality | totality.com
Triactive | triactive.com
T-Systems | t-systemsus.com
Unisys | unisys.com
Vanguard Managed Solutions | vanguardms.com
Vector Internet Services | visi.com
Vital Networks | Vital-NS.com
Voda One | vodaone.com
Voyus | voyus.com
We Manage Servers | wemanageservers.com
Worldcom | worldcom.com
Zoolink Corporation |


Glossary

access management

Having to do with the automation of security within the networked infrastructure. Access management pertains to the degree of access to specific applications and resources a user is allowed.

achieving consensus

Having to do with negotiations that lead to a mutually agreeable outcome for all parties involved in a decision.

actionable intelligence

Information that can be acted on. For example, information that a competitor might be planning a new sales campaign is not actionable. Information that a particular competitor is planning to reduce the price on one of its products with which your products compete is actionable intelligence, because it allows you to make specific plans in response.

adaptive business intelligence

Business information that is provided in the appropriate context for the given decision maker.

analyst

A class of information worker devoted to tracking financial or market trends in specific areas, such as stocks, consumer goods, or technology.

analyst community

The collection of information workers that monitor a particular market.

ASP (application service provider)

A third-party business that provides a variety of application-based services such as leasing of applications and integration of applications to businesses.

automation

Having to do with the conversion of manual processes to information technology-supported processes.

AVVID (Architecture for Voice, Video, and Integrated Data)

An approach developed by Cisco Systems to rationalize the information infrastructure to support any rich-media-based service, including voice over IP, streaming media, and data transfer.

bandwidth

A term originally developed to define the frequency range of a particular analog carrier signal. More recently, it has become synonymous with the total number of bits a particular data link can carry in a given amount of time.

BPO (business process outsourcing)

The provision of a complete business process (human resources, for example) by a third-party business.

BPV (business process virtualization)

The act of reducing the overhead imposed by a business process through either outsourcing or automation.

CIR (committed information rate)

Used in the context of data services where a specific bandwidth is guaranteed.

circuit-switched analog network

The Public Switched Telephone Network, where virtual circuits are established and maintained for the duration of a communications session.

client/server architecture

The distributed data architecture that places multiple servers in close proximity to users and that connects servers and users with a network. This is in contrast to a centralized mainframe-based architecture, in which all data processing is centralized and users are connected to the mainframe with dedicated links.

command-and-control management

Hierarchical management in which orders flow from the top down and all control is vested in the highest layers of the organization.

communications service

A service that facilitates communications between two or more parties.

compartmentalization

Parsing information or functions into discrete units.

competitive advantage

A business strategy or product attribute that confers a significant advantage over a competitor.

compression

Reducing the required bandwidth for a given signal without degrading that signal's information content.

compression technology

Technology, usually a numerical algorithm, that enables the compression of a signal.

converged architecture

The standardization of networked infrastructure architecture to support many data types, such as voice, e-mail, video, and data packets.

core business function

The enterprise's primary business.

core competency

The essential capability or intellectual property that a company leverages for revenue.

corporate governance

The approved business and financial processes that are applied to a corporation to ensure ethical and fiscally responsible behavior. This is the primary role of the board of directors.

cost of obsolescence

A financial principle that asserts that an obsolete machine or process introduces costs into a business when compared to the efficiencies that could be gained through a state-of-the-art approach.

CRM (customer resource management)

Also called business intelligence management. The collection and use of customer-related data for business advantage.

CSMA/CD (carrier sense multiple access collision detect)

The essential protocol employed by Ethernet transmission technology. In CSMA/CD, all participants are allowed to talk, but they are required to wait for specified periods of time when they detect others talking.

customer presence

Interaction with a customer at the customer's location.

data

The plural of datum. Refers to a collection of facts.

Data Age

The period from the late 1940s to the end of the 20th century, when automation was applied to collecting and managing data.

See also [Information Age]

data-rich environment

Any process whose operation creates large amounts of data.

Decision Analysis Society

The professional society established to promote the adoption and continued improvement of decision-support methodologies.

decision definition

The essential decision that must be made.

decision modeling

The graphical representation of a decision within a numerical model.

decision theory

Broadly, the branch of game theory devoted to the optimization of decision-based outcomes.

decision tree

A graphical way to represent a decision model.

directory

An organized listing of information. In the case of information technology, a directory is usually expressed in terms of attributes for particular logical identifiers.

directory service

An automated service that links directory information, such as access rights, on demand to individuals and information systems.

distributed data storage

The process of compartmentalizing the storage of data so that it can be stored across the networked infrastructure rather than at a central location.

distributed intelligence

The process of compartmentalizing and distributing data-processing priority information across the networked infrastructure.

don't-com revolution

The backlash by conventional business and the financial community after the dot-com bomb where Internet enabled businesses were looked on with great skepticism.

dot-bomb
See [dot-com bomb]
dot-com

A company that exists primarily as a virtual presence on the Internet.

dot-com bomb (dot-bomb)

The period beginning in early 2001 when many Internet-enabled businesses failed.

dot-com bubble

The period just before early 2001 when the rate of growth of Internet-enabled businesses was at its peak.

Dot-com Era

Roughly, the period from 1995 to 2001, when the concept of Internet-enabled business was developed and implemented.

DSL (digital subscriber line)

A way to deliver broad-bandwidth signals through a narrow-bandwidth transmission line using compression. DSL signals are usually impressed on conventional telephone lines and are primarily intended for personal home use.

e-commerce

Business transactions that are facilitated by the Internet.

ERP (enterprise resource planning)

A type of management automation that seeks to tie customer-, market-, and business-derived intelligence into the management of the business.

external security

Securing the enterprise networked infrastructure from intrusion by external threats.

external security threat

When an individual or business entity seeks to penetrate the enterprise networked infrastructure for gain or malicious purposes.

extranet

A network that connects a business with its suppliers or customers.

firewall

A logical barrier set up in a networked environment to limit the intrusion of third parties into that environment.

free-market economy

Generally, an economic system based on free-enterprise principles.

gaming strategy

The application of game theory to a competitive business process.

Generally Accepted Accounting Principles

Also called GAAP. The common set of accounting principles, standards, and procedures. GAAP is a set of standards that evolved over time in response to changing financial circumstances. Although they are not binding in principle, they are nevertheless followed by most companies and government agencies.

geographic dispersion

Dispersing company assets such as employees and information technology resources over geographic distances using networking technology to connect the resources.

GUI (graphical user interface)

The display of data and information in a graphically mapped way, as opposed to a character-mapped way, usually on a video display device.

hacker

Someone who attempts to penetrate a network or system without proper authorization, usually for malicious reasons.

Heisenberg Uncertainty Principle

A statement of observational uncertainty: The harder you try to resolve something, the less quantifiable its properties become.

horizontal incrementalization

The process of extending business virtualization across business functions within an enterprise over time.

HTML (HyperText Markup Language)

The standard language for scripting web pages on the Internet.

incrementalization

Extending BPV through small additions. Incrementalization is an important component in migrating a firm to a fully implemented BPV environment.

Industrial Age

The age of industrialization. Generally thought of as being synonymous with the 20th century, although many of the principles associated with industry (such as assembly lines and mass production) were in use during the 19th century.

influence diagram

A way of representing decision models in terms of influence variables.

influence vector

Within an influence diagram, a connection that denotes influence among the variables.

Information Age

Incorrectly thought of as having occurred during the latter half of the 20th century. In reality, the manipulation of information is just now becoming possible.

information-driven decision

The use of information, as opposed to data, to facilitate the process of decision making.

information poverty

A situation in which there might be overwhelming amounts of data but little information.

information technology

The combination of information-processing systems and services combined with data networking.

intellectual property

Ideas, trademarks, patents, copyrights, and trade secrets.

intelligent network switching fabric

The combination of switching logic with policy management that allows a network to respond dynamically to changing data communication demands.

internal security

Security policies and technologies applied behind the firewall to ensure that only those who are authorized gain access to services and data.

internal security threat

Generally, an action taken by an authorized user that compromises the integrity of the enterprise's networked infrastructure and/or its intellectual property.

Internet

The network of networks, derived from the early DARPAnet, that currently interconnects most of the world's computing resources.

Internet-based business model

A model for business transactions, both internal and external, that depends on networks rather than physical assets.

intranet

A network internal to a business.

intuitive decision making

Making decisions based on emotion rather than from a logical basis.

IPSec (IP Security)

A standard for imposing security on Internet Protocol (IP)–based data packets.

islands of technology

A situation in which discrete technological capabilities are scattered and isolated throughout an organization rather than being pervasive or integrated into the overall business objectives.

ITIL (Information Technology Information Library)

A standard approach, developed in response to requirements set forth by the British government, that defines how information technology systems and services are to be developed and documented in response to business requirements.

jitter

A situation that occurs in IP-based networks in which data packets arrive out of sequence.

LAN (local-area network)

A network, generally no larger than campus-sized and usually based on the Ethernet protocol, that ties together local computing resources.

latency

A situation that occurs in IP-based networks in which data packets experience varying delays in transmission.

LDAP (Lightweight Directory Access Protocol)

A standard that defines the ways in which information directories can be interrogated by applications.

management solution

In the context of BPV, an application that allows a virtual business's networked infrastructure and business applications to be monitored and manipulated to maintain quality of service.

metaenvironment

An environment of environments. In the case of a BPV-enabled company, it is the overarching computing infrastructure that connects all the geographically dispersed computing infrastructures.

Monte Carlo Analysis

A tool used in decision modeling that allows all variables defined by maximum and minimum numerical limits to vary randomly within those limits for the purpose of determining the range of allowable values of the decision outcome.

MPLS (Multiprotocol Label Switching)

An emerging standard used to define the security attributes in a virtual private network.

MSP (managed service provider)

Any one of a broad range of service providers that includes active remote management of service quality as an adjunct to the provisioning of the service.

NAS (network-attached storage)

A storage device that is attached to a network and that provides a common storage medium for multiple network-attached processors.

near-shore outsourcing

An outsourcing arrangement involving a domestic service provider.

networked automation

Data processing done using network-attached processors.

networked infrastructure

The combination of processors, network elements, and work stations that constitutes the infrastructure of a BPV-enabled business.

nondeterministic

As opposed to deterministic; not predictable using numeric methods.

North American Numbering Plan

Also known as NANP. The ten-digit telephone dialing convention used in North America.

number portability

The process by which telephone numbers can accompany users from one communications carrier to another.

offshore outsourcing

An outsourcing arrangement involving a foreign country-based service provider.

optimum decision

Recognizing that decisions are seldom perfect, an optimum decision is one that satisfies the most criteria to the maximum extent.

outsourcer

A company that provides outsourced services.

outsourcing

Supplying a business function to an independent third party.

paradigm

A state of being; a worldview or approach.

paradigm shift

The discontinuous transition from one view, approach, or state to another.

paradigm stagnation

The condition that exists when a particular worldview no longer provides a rational basis for action.

permanent virtual circuit

Also called a PVC. The approach used in the Public Switched Telephone Network in which a circuit is established electronically for the duration of a communication session.

policy-based management

An automated management approach that changes in response to changing conditions based on a set of predefined rules.

prime contractor

The principal contractor in a business engagement.

PSTN (Public Switched Telephone Network)

Generally, the common-carrier telephone network.

QoS (quality of service)

Any of a series of metrics that measure the quality of a service as experienced by the user.

RAID (Redundant Array of Inexpensive Disks)

A process whereby reliability in a storage device is achieved by using multiple inexpensive disk drives rather than one highly reliable and expensive disk drive.

remote access

Pertaining to the ability to interact with a device from a distance.

ROI (return on investment)

A financial equation that measures an investment's benefit versus its cost.

role-based access control

A security arrangement that assigns access based on a user's role and responsibility.

role-based policy management

Policy management for which rules are based on the user's role or function; a form of security and network access control.

SAN (storage-area network)

A network of storage devices.

scientific management theory

A theory developed by Frederick Winslow Taylor at AT&T to optimize the output of production lines.

security breach

A violation of security protocols.

security management

A system, usually automated, to manage access arrangements.

sensitivity analysis

In decision analysis, variables that affect a decision are tested to determine to what extent they affect the decision.

SLA (Service Level Agreement)

Generally, a contract that binds a service provider to particular measurements of service quality.

SNMP (Simple Network Management Protocol)

A standard protocol or taxonomy for constructing automated management systems.

SS7 (Signaling System 7)

An out-of-band signaling protocol used in the Public Switched Telephone Network.

strategic asset

An asset that is critical to the enterprise's performance.

strategic function

A function that is critical to the enterprise's continued success.

strategic planning

Business planning that is considered critical to the enterprise's success.

streaming medium

A service that can be expressed as a packet stream and that can be transmitted continuously over a packet-based network.

structured decision model

A formal approach to representing decisions that includes variables and influences among variables.

structured decision process

A decision-making process based on a structured approach.

subnetting

Logically partitioning networks into subdomains.

TCO (total cost of ownership)

A financial metric that seeks to express an investment in terms of all the costs it could generate beyond the initial acquisition.

telecommuting

Achieving virtual access to a company's resources by using a network-linked workstation.

telepresence

Achieving a virtual presence at a particular location using networked technology.

teleprocessing

Literally, processing at a distance; processing over a network.

tornado diagram

A way to graphically express a Monte Carlo Analysis, typically used in structured decision modeling.

unified messaging

Enables message delivery over a variety of media.

URL (Uniform Resource Locator)

An addressing scheme used to locate HTML pages within the World Wide Web.

validation

Verifying the efficacy of a change.

variable

In the context of decision analysis, a factor that can influence a decision.

vertical incrementalization

Implementing information technology along vertical organizational lines to achieve BPV.

video teleconferencing

A communication that involves a video signal in addition to an audio signal.

virtual business

A business that has replaced much of its physical infrastructure with a networked infrastructure.

virus protection

Applications that detect and intercept electronic viruses and worms.

VLAN (virtual local-area network)

Using the Internet to simulate a conventional LAN's physical connectivity.

VoIP (voice over IP)

Audio communications that use packet streams rather than analog circuits.

Von Neumann model for computer architecture

A conventional processing architecture that includes input, output, arithmetic logic, control logic, and memory.

VPN (virtual private network)

Using the Internet to simulate dedicated circuits using security protocols.

WAN (wide-area network)

A network that covers geographic distances.

web-enabled business

A business whose networked infrastructure incorporates web-based technology.

web portal

A gateway that brings information, buyers, and sellers together via web-based resources. Web portals are topic-specific and rooted in communities of interests.

World Wide Web

The collection of Internet-connected servers that support HTML-formatted documents.


Prev don't be afraid of buying books Next


[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X]

80/20 rule
criteria for outsourcing 2nd 3rd


[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X]

access management
VLANs 2nd
extranets 2nd
intranets 2nd
VPNs
ARUP Laboratories, Inc. case study 2nd 3rd 4th 5th 6th
webified business applications 2nd
accessibility of intellectual property
securing
achieving consensus 2nd
ALU (arithmetic logic unit)
application-centric QoS
case study
applications
enabling virtual presence
follow-me IP addresses 2nd
streaming media
VoIP 2nd
implementing
latency
webified 2nd
ARUP Laboratories, Inc.
case study 2nd 3rd 4th 5th 6th 7th 8th
AVVID
communications services 2nd
Internet business soluitions layer
unified control plane
AVVID (Architecture for Voice, Video, and Integrated Data) 2nd


[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X]

bandwidth
role in successful telepresence 2nd
role in telecommuters
Barker, Joel
board of directors
role of in BPV 2nd
BPV
effect on organizational dynamics
incremental deployment
incrementalization 2nd
horizontal
vertical
origins of
role of board of directors 2nd
role of executive management 2nd
role of HR
role of information technology implementers 2nd
role of legal staff
role of technology 2nd
BPV (business process virtualization)
BPV service providers 2nd 3rd 4th 5th 6th 7th 8th
business assets
centralization
business models
Internet-based 2nd


[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X]

calculating 2nd 3rd 4th 5th 6th
calculating ROI for QoS implementation
call setup and termination
VoIP versus circuit-switched technology
capital
as constraint on business
case studies
ARUP Laboratories, Inc. 2nd 3rd 4th 5th 6th 7th 8th
KnowledgeNet 2nd 3rd
management attitude toward technology
network overview
security 2nd
Motorola
company background 2nd 3rd 4th
survey instrument
defining business process virtualization 2nd 3rd 4th
format 2nd
vCustomer Corporation 2nd 3rd 4th 5th 6th 7th
planning process 2nd 3rd
CBT (computer-based training)
CDM (Cisco Quality of Service Device Manager)
centralized management
centralized processing environments
CIA (Confidentiality, Integrity, and Authorization)
CIR
circuit-switched technologies
versus VoIP
circuit-switched technology
Clarke, Arthur
communication services
AVVID 2nd
compartmentalization
competitive advantages of virtualization 2nd
compression technology
in streaming media
control plane
AVVID
core business functions
IT 2nd
R&D
cost of conversion
calculating TCO
cost-benefit analysis
calculating total cost of ownership 2nd
cost of conversion
depreciation
personnel
training
ROI 2nd
cost-benefit analysis of outsourcing 2nd 3rd 4th 5th
CPM (Cisco Quality of Service Policy Manager)
criteria for outsourcing
80/20 rule 2nd 3rd
criteria for selecting outsourced services 2nd 3rd
cyclical nature of business


[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X]

Data Age
data overload
effect on decision making 2nd 3rd
role of industry and financial analysts
decision making
achieving consensus 2nd
data overload
role of industry and financial analysts
data overload, effect on 2nd 3rd
reduction
validation
decision model for selecting outsourcers 2nd
decision modeling 2nd
gaming strategy
Monte Carlo Analysis
sensitivity analysis
tornado diagrams
decision-making processes
improving through virtualization 2nd
deploying
VoIP
depreciation
calculating TCO
directory-enabled policy-based management
asset allocation
LDAP 2nd
theoretical nature of
XML
distribute storage 2nd 3rd
distributed intelligence 2nd
dot-bomb
technology as cause of
dot-com revolution
lessons learned


[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X]

e-learning [See Internet-based learning]
education
Internet-based learning
KnowledgeNet case study 2nd 3rd 4th 5th 6th 7th
employee contracts
securing intellecual property
employee telepresence
telecommuting 2nd
access management
need for bandwidth
employees
training
CBT
employees of virtual businesses 2nd
enabling virtualized presence
through applications
follow-me IP addresses 2nd
streaming media
VoIP 2nd 3rd
VoIP:implementing
ERP (enterprise resource planning) appliations
evaluating outsourcers performance 2nd
executive management
role of in BPV 2nd
extranets 2nd


[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X]

follow-me IP addresses 2nd
Frame Relay
fulfilling customer needs
as goal of virtualization 2nd
functions of core business
IT 2nd
R&D


[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X]

gaming strategy
effect on decision modeling
geographical dispersion of virtual businesses
goals of virtualization
fulfilling customer needs 2nd
improved decision-making 2nd
obtaining competitive advantage 2nd
reduced costs 2nd
Greenspan, Alan
irrationalexuberance comment


[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X]

Heisenberg Uncertainty Principle
horizontal incrementalization
HR
role of in BPV


[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X]

impact of technology on business models
implementing
VoIP
implementing QoS
case study 2nd 3rd 4th 5th
improved decision-making
as goal of virtualization 2nd
incremental deployment
of BPV
incrementalization 2nd
horizontal
vertical
information poverty
effect on decision making 2nd
information technology
supply and demand
information technology implementers
role of in BPV 2nd
intellectual property
accessibility of 2nd
compartmentalization
impact on outsourcing
jeopardizing through outsourcing
role-based access control 2nd
securing, importance of
employee contracts
regional threats
intelligent switch fabric 2nd
internal security
employee contracts
importance of
intellectual property
accessibility of 2nd
compartmentalization
role-based access control 2nd
regional threats to
Internet business solutions layer
AVVID
Internet-based business models 2nd
Internet-based learning
KnowledgeNet case study 2nd 3rd 4th 5th 6th 7th
intranets 2nd
IP
intelligent switch fabric 2nd
IP headers
irrational exuberance
irrationalexuberance of market valuation
IT
as core business function 2nd
functions of
operations management
evaluating outsourcers performance 2nd
outsourcing 2nd
jeopardizing intellectual property
multiple services 2nd
shelf life of new technologies
volatility of 2nd


[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X]

jeopardizing intellectual property through outsourcing
jitter


[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X]

knowledge management
relationship to project responsibility
KnowledgeNet
case study 2nd 3rd 4th 5th 6th 7th
Kuhn, Thomas


[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X]

labor
as constraint on business
latency
of VoIP traffic
LDAP (Lightweight Directory Access Protocol) 2nd
leasing offic space
versus purchasing
legal staff
role of in BPV


[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X]

managed services
outsourcing
criteria for outsourcing
multiple services 2nd
shelf life of new technologies
volatility of 2nd
quality of services 2nd
selecting outsourced services 2nd 3rd
management technologies
outsourcing 2nd 3rd
McNeeley, Scott
memory
distributed storage 2nd 3rd
modeling decision-making process
Monte Carlo Analysis
sensitivity analysis
tornado diagrams
Monte Carlo Analysis 2nd
Motorola case study
company background 2nd
implementing QoS 2nd
multiple services
outsourcing 2nd


[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X]

NANP (North American Numbering Plan)
NAS (network-attached storage)
networked computers
distributed storage 2nd 3rd
processing versus standalone computers 2nd


[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X]

objectives of virtualization
reduced costs 2nd
obtaining consensus 2nd
office space
leasing versus purchasing
operations management
of outsourced activities
organizational dynamics
origins of BPV
out-of-band signaling
outsourcing
cost-benefit analysis 2nd 3rd 4th 5th
criteria for 2nd 3rd
intellectual property, jeopardizing
IT
operations management
shelf life of new technologies
management technologies 2nd 3rd
multiple services 2nd
reliability of
selecting outsourced services 2nd 3rd
volatility of
protecting against


[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X]

packet-switching
follow-me IP addresses 2nd
paradigm stagnation
performance of outsourcers
evaluating 2nd
personnel
calculating TCO
Peters, Tom
Pierce, John
policy engines
policy management
effect on VoIP QoS issues
policy-based management 2nd
directory-enabled
asset allocation
LDAP 2nd
theoretical nature of
XML
impact on company resources
role-based access control 2nd
portability
follow-me IP addresses 2nd
portals
protecting against outsourcing volatility
purchasing office space
total cost of ownership
PVCs


[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X]

QoS
application-centric
case study
implementing
case study 2nd 3rd 4th 5th
Motorola, case study 2nd
quality of service 2nd


[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X]

R&D
as core business function
reduced costs
as goal of virtualization 2nd
redundancy
regional threats to security
reliability
of outsourcers
remote workers
telepresence 2nd
access management
need for bandwidth
ROI 2nd
calculating for QoS implementation
role of board of directors in BPV 2nd
role of executive management in BPV 2nd
role of HR in BPV
role of information technology implementers in BPV 2nd
role of legal staff in BPV
role of technology in BPV 2nd
routing
intelligent switch fabric 2nd


[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X]

SAN (storage area network)
Santayana, George
security
access management
VLANs 2nd 3rd 4th 5th 6th
webified business applications 2nd
CIA
complexity of controlling
directory-enabled policy-based management
asset allocation
LDAP 2nd
theoretical nature of
XML
employeed contracts
importance of
intellectual property
accessibility of
compartmentalization
role-based access control 2nd
quality of service 2nd
regional threats
selecting
networked infrastructure for outsourcing 2nd 3rd
selecting outsourced services 2nd 3rd
sensitivity analysis
tornado diagrams
service providers (BPV services) 2nd 3rd 4th 5th 6th 7th 8th
service quality 2nd
simple decision-making model 2nd
Monte Carlo Analysis
sensitivity analysis
tornado diagrams
SLAs
reliability of outsourcers
standalone computers
processing
versus networked computers 2nd
versus networked computers
distributed storage 2nd 3rd
stock market
irrationalexuberance
structural components of virtualized businesses
structured decision model
survey instrument for case studies
defining business process virtualization 2nd 3rd 4th
format 2nd


[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X]

Taylor, Frederick Winslow
technology
as cause of dot-bomb
as impetus for optimism
impact on business models
role of in BPV 2nd
shelf life
telecommuting 2nd
access management
need for bandwidth
telepresence
role of bandwidth 2nd
telecommuting 2nd
access management
need for bandwidth
VLANs 2nd
extranets 2nd
intranets 2nd
webified business applications 2nd
theoretical nature of policy management
tornado diagrams
displaying sensitivity analysis
total cost of ownership 2nd
calculating 2nd 3rd
cost of conversion
calculating
depreciation
personnel
calculating
purchasing office space versus leasing
training
calculating
training
calculating TCO
CBT


[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X]

unified control plane
AVVID


[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [J] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X]

validating decisions 2nd
vCustomer Corporation case study 2nd 3rd 4th 5th 6th 7th
planning process 2nd 3rd
vertical incrementalization
videoconferencing
virtualization
virtualized presence
role of bandwidth 2nd
telecommuting 2nd
access management
role of bandwidth
VLANs 2nd
extranets 2nd
intranets 2nd
webified business applications 2nd
VoIP
enabling virtualized presence 2nd
implementing
latency
versus circuit-switched architecture
volatility of outsourcing
protecting against
Von Neumann model of computer architecture
distributed intelligence 2nd
input
output
standalone computers versus networked computers 2nd
distributed storage 2nd 3rd
VPNs
ARUP Laboratories, Inc. case study 2nd 3rd 4th 5th 6th